Samsung S Fascinate (SGH-T959D) on Bell Mobility


So I'm hoping that I am posting in the right place...

I just picked up a TELUS Samsung Galaxy S Fascinate 3g+ (SGH-T959D) and have brought it over to Bell Mobility, I unlocked it.

I am able to get the phone and text working but do not have any data. I called Bell but of course its not their phone so the best they could do is advise to go through the APN settings; which I have as per the following with one question? Periods were used in the place of commas

Name: Bell
APN: pda,bell,ca
Proxy: web,wireless,bell,ca
Port: 80
Username: <Not set>
Password: <Not set>
Server: <Not set>

MMSC: 5778154
****is this supposed to be ###, then space and the address?

MMSC proxy: web,wireless,bell,ca
MMS port: 80
MCC: 302
MNC: 610
Authentication type : <Not set>
APN type : <Not set>

I have tried a few variations of this but have still not been able to get on the net, market, fb, etc.

Anyone have any success getting this working? Any help would be greatly appreciated.


Update: just wanted to say that I have solved this. By default, 'Use Packet Data' was not selected. Once I checked this off everything was find.