1. Download our Official Android App: Forums for Android!

Support Samsung S3 external power pack problem

Discussion in 'Android Devices' started by Jamesb1974, Jan 4, 2014.

  1. Jamesb1974

    Jamesb1974 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 4, 2014

    Jan 4, 2014
    1
    0
    5
    Hi,

    This is my first post here and I need some assistance. I have a Samsung S3
    GT-I9300 which is running Jellybean 4.3. The phone is not rooted and is totally standard.

    I required an external power pack as my job means that I do not regulary access charging points. For this I chose a Tecknet iEP387 which is rated at 7300 mHa. It has two USB jacks, one rated at 5v 1.0A and the other at 5v 2.1A.

    The information from the company website states that the device is compatible with the Samsung S2, S3 and S4 (which is why I chose it). Now the problem.

    The powerpack charges my wife's iPhone 4S, my Samsung Note 10.1 and the kids Tesco Hudl. However, when I connect it to my S3, nothing.

    I have been connecting the pack to the phone using a genuine Samsung cable, however this is a replacement as I lost the original. The USB cable works fine as it connects the handset to my PC and I can also use the standard mini wall charger that came with the phone.

    Therefore, I have eliminated the Powerpack being the issue as it charges several other devices. I have eliminated the USB cable as it connects my S3 to my PC (for using KIES 3) and also the mini charger.

    So, does the problem lie with the handset? Is there something I am missing in the settings?

    So far I have done the following, with no success.

    Factory reset.
    Entered the USB settings via the *#2784# menu and changed the settings between modem and PDA and back again.
    Started the phone in download mode, connected to my PC and then loaded driver software.

    Basically a whole host of things but what ever I do, the phone stubbornly refuses to connect to the powerpack and charge up as it is supposed to.

    Can anyone help me out, as it is literally driving me mad.

    Thanks, James:mad:
     

    Advertisement

Share This Page

Loading...