1. Are you ready for the Galaxy S20? Here is everything we know so far!

Samusng tab 2 10.1 ---- wont come to life (ish)

Discussion in 'Android Devices' started by no1grizzly, Jul 7, 2017.

  1. no1grizzly

    no1grizzly Lurker
    Thread Starter

    I know this subject has been asked many times and referral to the guides seems to fix most things.

    However my situation is this.

    I acquired a "dead" tab from a colleague.... battery won't charge after trying all the available tricks on Google.

    I took it home tried them all myself (other than the mega long trickle charge).

    Resigned myself to the fact it was a defunct battery. So off to Google and a new one swiftly arrived. Painstakingly removed old and inserted new battery.....TA DA......nothing .

    When plugging in original charger and cable (colleague who donated has tried other chargers and cables in the past to try to resolve with no joy) with old battery gave a quick battery view then black.

    Now I get the quick flash of battery with one gold bar then blank screen. I do however get a regular screen flicker of the circular icon......approx. every 7-8 seconds

    Does this flicker mean its attempting to charge ? (wishful thinking again).

    Will the trickle charge option eventually resolve this? Is it just that the battery has little to no life (albeit NEW).

    Am I chasing a lost cause or is there life out there for my daughter to one day have a working bit of kit.

    Have even tried the "remove LCD cable and trying to charge"...... this is happening now.....
     



    1. Download the Forums for Android™ app!


      Download

       
Loading...
Similar Threads - Samusng tab wont
  1. ManojGowda
    Replies:
    0
    Views:
    224
  2. oneytlam
    Replies:
    2
    Views:
    343
  3. Matthias Goddé
    Replies:
    1
    Views:
    275
  4. Lane Lester
    Replies:
    2
    Views:
    335
  5. rossasaurus
    Replies:
    4
    Views:
    450
  6. neil4958
    Replies:
    1
    Views:
    218
  7. onthevirg
    Replies:
    5
    Views:
    1,186
  8. afroag
    Replies:
    4
    Views:
    958
  9. Gargus
    Replies:
    6
    Views:
    1,772
  10. NirupaR
    Replies:
    0
    Views:
    383

Share This Page

Loading...