1. Download our Official Android App: Forums for Android!

Root SBF Recovery issue with frg01b

Discussion in 'Android Devices' started by rollo, Aug 24, 2010.

  1. rollo

    rollo Newbie
    Thread Starter

    Aug 7, 2010
    I have moto droid with latest OTA update FRG01B on the phone. Wanted to go back to root so was going to install SBF recovery.

    Tried to install SPFRecovery_ESE81.sbf both from linux and window$ but failed on both machines. Also tried Peter's SPFRecovery_FRG01B.sbf but failed to install from linux but haven't tried with window$.
    I'm not home but have the output for linux when failed but not for RSDlite as I did that on friends pc. The md5sum was good for the ESE81 but didn't find md5sum for peters frg01b.sbf .

    Would like to root from here but if have to follow OMJ's guide to get back to stock 2.1 then root from there so be it.

    Any help is appreciated and thanks in advance.


  2. Jedii

    Jedii Android Expert

    May 4, 2010
    At what time is it "failing"? If it fails in the middle, your phone shouldnt work. If it fails at the very end, that is normal. Is your phone not down to 2.1?

    also, try downgrading to 2.0.1 then rooting. See if that helps:

    Step 1, go to stock 2.0.1
    [file link removed]

    Step 2, download to root. ONLY on 2.0.1!

    Then, begin your rooting.
    rollo likes this.
  3. Jedii

    Jedii Android Expert

    May 4, 2010
    rollo likes this.
  4. johnlgalt

    johnlgalt Antidisestablishmentarian

    Oct 28, 2009
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    And update your RSDLite - the one at Pete's is version 4.7, elsewhere you find 4.6
    rollo likes this.
  5. rollo

    rollo Newbie
    Thread Starter

    Aug 7, 2010
    It seems from the beginning in window$ and linux. Phone still functions normally and stock recovery is still functioning. Linux completed the task but recovery didn't stick, but near beginning said something (panic or error) but can't remember exactly what .

    No, phone is updated to FRG01B. Sorry must have stated incorrectly before. Was trying to root from here but said if I had to go back to stock 2.1 ,like before using OMJ's guide I would, then root from there. Unless your saying I won't be able to root from stock 2.1 Jedii?

    Drivers are up to date on the window$ pc.

    Now this I haven't done so will have to update RSDlite to latest.

    Thank you both for such quick responses. Really good site and members. I will have to wait till get off work tonight to downgrade to stock 2.1 then root. Wish I would've left phone alone now when from when I manually updated an rooted frg22 per OMJ's tutorial.
  6. rollo

    rollo Newbie
    Thread Starter

    Aug 7, 2010
    Code (Text):
    1. 1st time tring to install just sbf recovery
    3. bash-3.1$ sudo ./sbf_flash -r --recovery SPRecovery_ESE81.sbfSBF FLASH 1.08 (mbm)
    5. Droid found.
    6.  CG63 0xC0000000-0xC001FFFF mbmloader.img
    7.  CG30 0xC0020000-0xC00BFFFF mbm.img
    8.  CG55 0xC00C0000-0xC015FFFF mbmbackup.img
    9.  CG31 0xC0160000-0xC01BFFFF cdt.bin
    10.  CG38 0xD01CE000-0xD0359FFF pds
    11.  CG34 0xC035A000-0xC03BCFFF lbl
    12.  CG57 0xC03BD000-0xC041FFFF lbl_backup
    13.  CG41 0xC0400000-0xC057FFFF sp
    14.  CG42 0xC0580000-0xC061FFFF logo.bin
    15.  CG44 0xC0620000-0xC067FFFF misc
    16.  CG35 0xC0680000-0xC09FFFFF boot
    17.  CG47 0xC0A00000-0xC0E7FFFF recovery
    18.  CG39 0xD0EF4000-0xD9FB6FFF system
    19.  CG40 0xD9FB7000-0xDFF3BFFF cache
    20.  CG37 0xDFF3C000-0xF0D29FFF userdata
    21.  CG53 0xDFD40000-0xDFF3FFFF kpanic
    23. Index[1]: Unexpected chip 16
    24. Index[2]: Unexpected chip 16
    25. === SPRecovery_ESE81.sbf ===
    26. 00: RDL03 0x80500000-0x8054CFFF FE66 AP
    27. 01:  CG35 0xC0680000-0xC08E37FF ABCB AP boot
    28. 02:  CG47 0xC0A00000-0xC0D5C7FF 02C0 AP recovery
    30. Skipping CG35 0xC0680000-0xC09FFFFF
    31.  >> waiting for phone: Droid found.
    32.  >> uploading RDL03
    33. Uploading: 100% OK
    34.  >> verifying ramloader
    35.  -- OK
    36.  >> executing ramloader
    37. Droid found.
    38.  >> sending erase
    39.  >> uploading CG47
    40. Uploading: 100% OK
    41.  >> verifying CG47
    42.  -- OK
    43.  >> rebooting
    Code (Text):
    1. 2nd time - tried to flash stock 2.1 sbf
    3. sudo ./sbf_flash -r --recovery VZW_A855_ESE81_QSC6085BP_C_01.3E.03P_SW_UPDATE_02.sbf
    4. SBF FLASH 1.08 (mbm)
    6. Droid found.
    7.  CG63 0xC0000000-0xC001FFFF mbmloader.img
    8.  CG30 0xC0020000-0xC00BFFFF mbm.img
    9.  CG55 0xC00C0000-0xC015FFFF mbmbackup.img
    10.  CG31 0xC0160000-0xC01BFFFF cdt.bin
    11.  CG38 0xD01CE000-0xD0359FFF pds
    12.  CG34 0xC035A000-0xC03BCFFF lbl
    13.  CG57 0xC03BD000-0xC041FFFF lbl_backup
    14.  CG41 0xC0400000-0xC057FFFF sp
    15.  CG42 0xC0580000-0xC061FFFF logo.bin
    16.  CG44 0xC0620000-0xC067FFFF misc
    17.  CG35 0xC0680000-0xC09FFFFF boot
    18.  CG47 0xC0A00000-0xC0E7FFFF recovery
    19.  CG39 0xD0EF4000-0xD9FB6FFF system
    20.  CG40 0xD9FB7000-0xDFF3BFFF cache
    21.  CG37 0xDFF3C000-0xF0D29FFF userdata
    22.  CG53 0xDFD40000-0xDFF3FFFF kpanic
    24. Data[4]: start_addr incorrect
    25. === VZW_A855_ESE81_QSC6085BP_C_01.3E.03P_SW_UPDATE_02.sbf ===
    26. 00: RDL03 0x80500000-0x8054CFFF 62D6 AP
    27. 01: RDL01 0x00150000-0x001FFFFF 88CB BP
    28. 02:  CG03 0x00000000-0x008C25BF 4A29 BP
    29. 03:  CG31 0xC0160000-0xC01637FF F15F AP cdt.bin
    30. 04:  CG34 0xC0340000-0xC03437FF 8F6F AP lbl
    31. 05:  CG35 0xC0680000-0xC08E3FFF DA2C AP boot
    32. 06:  CG37 0xDFF3C000-0xDFF3D07F F6CE AP userdata
    33. 07:  CG39 0xD0EF4000-0xD86879FF 4E73 AP system
    34. 08:  CG42 0xC0580000-0xC05BFFFF 73E3 AP logo.bin
    35. 09:  CG47 0xC0A00000-0xC0CA17FF 43F3 AP recovery
    37. Skipping CG31 0xC0160000-0xC01BFFFF
    38. Skipping CG34 0xC0340000-0xC039FFFF
    39. Skipping CG35 0xC0680000-0xC09FFFFF
    40. Skipping CG37 0xDFF3C000-0xF0D29FFF
    41. Skipping CG39 0xD0EF4000-0xD9FB6FFF
    42. Skipping CG42 0xC0580000-0xC061FFFF
    43.  >> waiting for phone: Droid found.
    44.  >> uploading RDL03
    45. Uploading: 100% OK
    46.  >> verifying ramloader
    47.  -- OK
    48.  >> executing ramloader
    49. Droid found.
    50.  >> sending erase
    51.  >> uploading CG47
    52. Uploading: 100% OK
    53.  >> verifying CG47
    54.  -- OK
    55.  >> rebooting
    Code (Text):
    1. This time I tried in window$
    2. MODEL = SE Flash OMAP3430 MI
    3. PORT = 1
    4. PORT TYPE = USB
    5. IME/ESN/MEID= N/A
    6. STATUS = failed flashing process. failed flashing process. Phone(0000): phone did not re-enumerate after RAM -downloader was sent (0x703E)
    7. : phone disconnected,
    8. PROGRESS = executed 100%
    9. RESULT = fail
    I did notice after trying to flash with linux that (by mistake) pressing the "x" during reboot after flash it would go into SBF Recovery so tried to update but failed. If I allowed phone to reboot then power down and then back on while pressing "x" per instructions it would go to stock recovery (triangle with exclamation point). The update.zip is in the root of sdcard.

    I updated to RSDLite 4.7 and made sure drivers were updated in window$ (XP Pro SP2 ). I tried both as user and admin in XP. The .sbf file is in the C:/ folder/directory. In windows the fail came at the end of process. Phone is still functioning fine but still have stock FRG01B.
  7. rollo

    rollo Newbie
    Thread Starter

    Aug 7, 2010
    Issue has been solved. I'm now rooted, clockworkmod and rom manager installed, and backup has been made.
    Thanks Slawson help and others whose name(s) I don't know.
  8. OMJ

    OMJ Bazinga

    Nov 27, 2009
    glad you got it resolved. I have to update the linux guide today because of the issue that you had.
    rollo likes this.
  9. rollo

    rollo Newbie
    Thread Starter

    Aug 7, 2010
    Thank you OMJ for the leg work you're doing with the Linux tut., I hope the output will help you and others with this issue, but maybe just user error lol.

    I never got sbf recovery installed on the phone, I rooted using Universal Androot. Worked great on my moto droid with OTA update FGR01B. I get to try using the 2.0 or 2.0.1 SBF's but some say must use them for froyo, not sure.

    The tut's you have stickied worked great for me the other times I tried them before I updated OTA to FRG01B.

    I definitely like using Linux over window$ for anything. If it helps I use Slackware 12.0 .

    Thanks to all!!!

    Edit: Here's the guide I used with Universal Androot .

Share This Page