1. Check out our app, Forums for Android! Download and leave feedback here!

Support Screen doesn't shut off when I press off button

Discussion in 'Android Devices' started by WalkingSnake, Jul 25, 2010.

  1. WalkingSnake

    WalkingSnake New Member
    Thread Starter
    5

    Jul 25, 2010
    2
    0
    5
    Over the past two days I've had a recurring problem with my Moment - the screen no longer shuts off when I press the Off or End Call button. This is a pain because buttons end up being pressed when I slip the phone in to my pocket.

    I'm running the official 2.1 update and have been since the week after it came out, and I haven't had this problem before.

    I can't seem to figure it out. The button still works to turn the screen on, and will still turn of the screen if it's at the lock screen, but at the home screen or in an app, nothing happens when pressing the button.

    This was a little awkward today when the body heat through my shorts opened up my Alarm Clock app and started playing the various alarm clock ringtones! :x
     

    Advertisement

  2. emm5150&reg

    emm5150&reg Member
    5

    Jul 25, 2010
    5
    0
    5
    Mechanic
    Greenville, SC
    I have the same exact problem and came to this forum to try figure out a solution!! This is my second Moment, the screen shut off fine when I pressed the off button on the first phone but the phone ended up not working too well so Sprint gave me a new one. Now, on my new phone, the screen will not shut off when you press the off/hang-up button. When the phone is locked (where you have to slide your finger to the right to unlock) you can press the off button and it shuts off again, but not when it's unlocked....please help!!! Tired of the phone texting and calling people when in my pocket...thanks!!!
     
  3. WalkingSnake

    WalkingSnake New Member
    Thread Starter
    5

    Jul 25, 2010
    2
    0
    5
    Great to know I'm not the only one with this problem, and for me it just recently started happening.
     
  4. dbelleman

    dbelleman Well-Known Member
    36

    Dec 27, 2009
    50
    7
    36
    Delaware
    Have you installed any new programs lately?
     
  5. pastafarian

    pastafarian P√Ętes avec votre foie
    523

    Nov 4, 2009
    5,622
    4,625
    523
    Sales
    The Sea of Tranquility
    I had the same issue. I asked around but found no solution. I did a system b/u via recovery, flashed to stock DE03, flashed back to noobnl's rom and did a restore but the problem was restored with the b/u. I ended up re flashing and installing my apps from scratch. At least the problem hasn't reappeared. Good luck!
     
    emm5150&reg likes this.
  6. emm5150&reg

    emm5150&reg Member
    5

    Jul 25, 2010
    5
    0
    5
    Mechanic
    Greenville, SC
    No, no new installs at all!!! I took the phone back to Sprint yesterday and they swapped it out for another phone...hopefully 3rd times a charm! So far so good, thanks for all the input!
     
  7. ovrrdrive

    ovrrdrive Well-Known Member
    163

    Dec 18, 2009
    1,215
    389
    163
    Make sure your contacts are backed up in google and do a factory reset. I've gotten to where I can fully set the phone up, customize it and reinstall all of my programs in about 30 minutes. Sad but true..
     
    emm5150&reg likes this.
  8. emm5150&reg

    emm5150&reg Member
    5

    Jul 25, 2010
    5
    0
    5
    Mechanic
    Greenville, SC
    I didn't try a hard reset on the phone but everyone I've spoken to has said that should work! You might want to try that! That's the route I was gonna go but my phone was only 3 weeks old, so I just took it back!!! Good luck!
     
  9. AndroidSPCS

    AndroidSPCS Well-Known Member
    183

    Nov 12, 2009
    3,222
    478
    183
    geek
    USA
    Does this happen all the time, or just after talking on the phone?
     
  10. kurban

    kurban New Member
    6

    Jul 30, 2010
    1
    2
    6
    I've also had this problem recently. It has nothing to do with talking on the phone or not.

    Glad to hear someone else is having the problem so it's not just me, but my phone does all weird things in my pocket when on.

    I did install a bunch of apps, and uninstalled a most of them.

    EDIT: I did Update Profile, under Settings -> About Phone -> System Updates and everything seems to be better now.
     
    K-Rizzle and VcV like this.
  11. VcV

    VcV New Member
    5

    Jun 22, 2010
    1
    0
    5
    The "Update Profile" worked for me, thanks.
     
  12. tbag1122

    tbag1122 Active Member
    16

    Dec 5, 2009
    38
    3
    16
    shift lead
    wisconsin
    sounds like you guys got it under control but I'll add my 2 cents anyways. I used to have an app called "spare parts" on my phone and I remember an option in the settings "end button behavior". Like I said I don't have it anymore so I could be wrong but maybe you guys have the do nothing box checked.
     
  13. K-Rizzle

    K-Rizzle Well-Known Member
    58

    Nov 21, 2009
    368
    20
    58
    Dog Walker
    North Carolina
    This JUST happened to me about 10 minutes ago for the first time. I had remembered seeing this posted on here and came looking for it. The 'update profile' worked for me too! thanks kurban!!! :)
     
  14. dbelleman

    dbelleman Well-Known Member
    36

    Dec 27, 2009
    50
    7
    36
    Delaware
    Funny but now mine just did it too. updated profile and now it's fine.:D

    Weird:rolleyes:
     

Share This Page

Loading...