1. Are you ready for the Galaxy S20? Here is everything we know so far!

Screen not waking up with wifi on Froyo

Discussion in 'Android Devices' started by andrew.johnson, Sep 14, 2011.

  1. andrew.johnson

    andrew.johnson Well-Known Member
    Thread Starter

    I'm having the same problem as CM7 with the black and white notification bar rom and wondering if anybody has a fix. I have flashed CM7 before and i always restore data under advanced restore when flashing a new rom to save time if that helps narrow it down. Thanks in advance.
     

    Advertisement

  2. AtticTRON

    AtticTRON Android Enthusiast

    I think the rom you have breaks wifi

    Edit. Can you provide the link to the rom you are using?
     
  3. andrew.johnson

    andrew.johnson Well-Known Member
    Thread Starter

    it doesnt break wifi. wifi still works fine. i know princely rom was or still is breaking the wifi but thats not the one im using. http://androidforums.com/triumph-al...om-op-updated-9-14-5-10pm-est-wifi-works.html theres the link but im almost positive thats not the problem. its almost as if the bug from cm7 is permanent or something ever since i first flashed it.
     
  4. AtticTRON

    AtticTRON Android Enthusiast

    I doubt the bug is permanent since I flashed the same rom over the CM7 alpha build and I've had no problems. Try restoring the stock rom then load the black rom over it. Make sure you clear the dalvik cache and do a factory wipe. When I cam from cm7 i also formatted /system just to be sure.
     
  5. andrew.johnson

    andrew.johnson Well-Known Member
    Thread Starter

    yea i always wipe everything and format system too. but i'll try loading stock rom 1st and see how that goes.
     
  6. mantera

    mantera Android Expert

    If I'm understanding your issue correctly, you're on froyo and when your phone goes to sleep with wifi on and then when you wake it, the wifi is having a hard time getting reconnected? Is that correct?

    If that is the case, I recommend that you do the following to change your wifi setting to Never shut down when your phone goes to sleep. Basically, what is happening is that, by default, your phone turns off the wifi when it goes to sleep and when you wake it, it takes a while to switch over from 3g back to wifi.

    To change that, go into
    1. Settings --> Wireless & networks --> Wi-Fi settings
    2. Hit Menu --> Advanced
    3. Wi-Fi sleep policy is at the top of the Advanced menu.

    This also might help your battery life too since, from what I understand (but I could be wrong), wifi will use less battery than 3g and your phone won't constantly be seeking a 3g connection while it's sleeping.
     
Loading...
Similar Threads - Screen waking wifi
  1. Rob Ingles
    Replies:
    7
    Views:
    186
  2. Brad Wood
    Replies:
    8
    Views:
    207
  3. Lightsmith
    Replies:
    3
    Views:
    240
  4. Rob
    Replies:
    1
    Views:
    184
  5. dmtr
    Replies:
    13
    Views:
    837
  6. Tcrumpen
    Replies:
    1
    Views:
    324
  7. kernal99
    Replies:
    3
    Views:
    485
  8. ldm1417
    Replies:
    8
    Views:
    1,924
  9. FullGrownNut
    Replies:
    0
    Views:
    333
  10. L Dot
    Replies:
    6
    Views:
    7,430

Share This Page

Loading...