1. Download our Official Android App: Forums for Android!

screen orientation lag fix in EC05 froyo version

Discussion in 'Android Devices' started by katanaram, Mar 29, 2011.

  1. katanaram

    katanaram Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Sep 13, 2010

    Sep 13, 2010
    13
    3
    16
    Got the official EC05 froyo update from sprint today and I installed it over my previous official EB13 version (unrooted).Everything worked fine except for the annoying screen orientation lag when switching between portrait and landscape:-( It was ridiculously slow and een after calibrating it thetraditiona way, noticeable lags still existed.

    Did something crazy with the calibration and it fixed the annoying lag issue. After clicking calibrate button, I tilted the phone and put it on the screen side over a flat surface instead of traditonal method(I.e. leave the phone on camera lens side over flat surface).

    Result was almost ZERO lag when switching between portrait and landscape modes for all supported applications.

    Give it a try - it worked for me and I am glad the lag is gone finaly!!!!!!
     

    Advertisement

    Gavisann, linda7585 and TheEngineer like this.
  2. TheEngineer

    TheEngineer Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    268
    Joined:
    Feb 23, 2011

    Feb 23, 2011
    268
    55
    53
    Yeah, others have been saying to hold it over your head the same thing. Thanks.
     
  3. simcha

    simcha Android Enthusiast
    Rank:
    None
    Points:
    78
    Posts:
    436
    Joined:
    Sep 3, 2010

    Sep 3, 2010
    436
    165
    78
    Male
    Employed
    Oakland, CA
    Thanks for the tip. It worked like a charm.
     
  4. toyman317

    toyman317 Member
    Rank:
    None
    Points:
    16
    Posts:
    92
    Joined:
    Aug 9, 2010

    Aug 9, 2010
    92
    6
    16
    Didn't work for me. Major lag after oprning/closing keyboard slide plus major lag coming out of some apps to the home screen. Icons don't show up for about 15 seconds. I am about to hard reset again to see if that fixes it but I did that before too.
     
  5. cokemanpac

    cokemanpac Newbie
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Dec 11, 2009

    Dec 11, 2009
    10
    0
    15
    Just lay the phone facedown. The front of it is completely flat compared to the back. Do that and it'll work I promise
     
  6. katanaram

    katanaram Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Sep 13, 2010

    Sep 13, 2010
    13
    3
    16
    Sorry you are having trouble. I am not running into any issues that you have mentioned except it does take about 3-5 secs for all icons to show up once I close the keyboard. I was running into this 3-5 sec delay even before I calibrated it and in my previous versions. So I am really not concerned about it.....
     
  7. toyman317

    toyman317 Member
    Rank:
    None
    Points:
    16
    Posts:
    92
    Joined:
    Aug 9, 2010

    Aug 9, 2010
    92
    6
    16
    Thanks Katanaram. My wife got her update last night from EB13 and her phone rocks. No problems at all that I can see. Another problem I am having is when in Managing Apps, if I open up an app to move it or uninstall it and then go back out of that app, the phone goes into "Loading" and gets locked up. I also tried to reformat my SD card and it wouldn't let me do that either. I probably need to go to the repair center.
     
  8. rogand

    rogand Newbie
    Rank:
    None
    Points:
    15
    Posts:
    17
    Joined:
    Dec 29, 2010

    Dec 29, 2010
    17
    0
    15
    Cool, I'll try this later tonight after work. I was hoping EC05 would have fixed it, but no go. Mine has usually been 3-5 seconds since the first Froyo update (in my case, OTW) but is sometimes 12-14 sec. I am SO crossing my fingers. If it doesn't work I'm breaking contract and chucking this Epic (which I otherwise love)
     
  9. tx_brandon

    tx_brandon Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    187
    Joined:
    May 28, 2010

    May 28, 2010
    187
    48
    43
    mosaic artist
    Austin
    This fixed the lag I was having too, thanks!
     
  10. markophonic

    markophonic Newbie
    Rank:
    None
    Points:
    15
    Posts:
    11
    Joined:
    Feb 24, 2011

    Feb 24, 2011
    11
    0
    15
    Thanks Much! It worked for me. The lag time was driving me nuts. I'm still dealing with battery issues. Prior to the update my battery life was excellent...now it sucks.
     
  11. Gavisann

    Gavisann Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    290
    Joined:
    Mar 31, 2011

    Mar 31, 2011
    290
    24
    38
    Wow thanks! Completely fixed the 1 to 2 second lag I had since DK28 every time I opened the keyboard or tried to view it ho horizontally.
     
  12. katanaram

    katanaram Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Sep 13, 2010

    Sep 13, 2010
    13
    3
    16
    Glad the rotation lag fix worked for you. How bad is your battery life? I have not run into any battery issues yet - mine easily lasts the entire day with medium use. Of course sprint signal is very strong at my workplace. And I also use "Greenpower" app (free version with DAY mode) to increase battery life. Maybe you should give it a try and see if it helps.
     
  13. linda7585

    linda7585 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    10
    Joined:
    Jan 24, 2011

    Jan 24, 2011
    10
    3
    16
    Thanks! I was able to fix both mine and my husband's phone. That lag was about to drive him crazy and he thought he had to just live with it.
     

Share This Page

Loading...