1. Download our Official Android App: Forums for Android!

Support SD Card issue - Card being read, apps not launching

Discussion in 'Android Devices' started by gafel, Mar 30, 2011.

  1. gafel

    gafel Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 28, 2011

    Mar 28, 2011
    1
    0
    5
    I went to the movies tonight with my phone functioning as normal. No service in the theater. Came out, regained service.
    However, I can no longer launch Apps installed to my SD card.
    It just says "Error while launching activity"

    When I go to view my SD card storage, it shows my my total SD card size and my available SD card size.
    When I go to Applications>Manage Applications>On SD card, it shows everything installed to it. However, instead of showing their respective icons it is a gray icon that says Android, with a picture of the android, and then an icon over it that says "SD card," everything in different shades of gray.

    The apps read as this: instead of "Adobe Reader" it reads com.adobe.reader
    Etc for all other apps.

    Pictures and video that I have taken on my phone that are stored on my SD card(s) are still viewable and playable.

    When I connect my phone to my computer, it shows "Removable E" and "Removable F." When I click explore it says "Please insert disk to volume E" and "F" respectively.

    I have tried the following:
    -Shut down
    -Soft reset
    -Hard reset
    -Power down>Remove SD>Turn on>Insert SD after full boot

    When I select "Unmount SD card" a force close error appears for "Activity SD & phone storage (in application settings) is not responding."
    The other card allows me to Unmount and Remount, but does not change anything.

    I have absolutely no idea what went wrong nor how to fix it.

    Please, help.
     

    Advertisement

  2. AuTumnPunkin

    AuTumnPunkin Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Oct 12, 2010

    Oct 12, 2010
    5
    0
    5
    WOW!!
    (Except for the movie)...sounds EXACTLY like ME!!
    I'm all (droid) Ears...for an answer!!!
    Have got NO real answers from Verizon..have FACTORYRESET..(&ALL other forms of RESETing)
    Tried 2 "new" phones...still...no answer!!
    (GBu!)
     
  3. sdrawkcab25

    sdrawkcab25 Android Expert
    Rank:
     #64
    Points:
    423
    Posts:
    5,589
    Joined:
    Aug 5, 2010

    Aug 5, 2010
    5,589
    2,005
    423
    Male
    PA
    Probably a bad sd card, try reformatting it or get a new one.
     
  4. Dana-DInc

    Dana-DInc Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jun 4, 2010

    Jun 4, 2010
    2
    0
    5
    This just happened to me the second time.

    I couldn't find the fix that I found before but I kind of remembered it.

    Boot into recovery mode by powering off the Incredible then holding down the volume down key the pressing the power on button until the phone boots into recovery.

    Use the volume buttons to move to the "recovery" entry then press the power button to select its menus.

    Select "reboot" item and press the power button to reboot.

    (Now you probably don't have to do this part. Shortly after rebooting I try to run an application installer on the sdcard and it doesn't run. I then unmount the sdcard after which I remember it takes my phone quite awhle to complete the mounting of the sdcard. I then mount the sdcard again and wait longer to get the card mounted.)

    The apps should be runnable and you can unmount the sdcard.

    Hopefully I'll be able to find this fix again for myself by replying on this thread!

    Thanks to whoever it was (and wherever it's posted) that posted this fix in the first place.

    -dana
     

Share This Page

Loading...