1. Are you ready for the Galaxy S20? Here is everything we know so far!

SD Card Mounted ReadOnly After 2.2 Update

Discussion in 'Android Devices' started by Diamond72, Aug 4, 2010.

  1. Diamond72

    Diamond72 Lurker
    Thread Starter


    Can anyone help with this,

    Update my Desire to 2.2 yesterday now everytime i turn the phone on i get an error message saying:

    Mounted ReadOnly
    The SD card has an unexpected problem. Tapping.....(cant read the rest of the message)

    Can anyone help with this. The only way i can access my photos or music is going via a file explorer.

    Thanks in advance

    1. Download the Forums for Android™ app!


  2. Diamond72

    Diamond72 Lurker
    Thread Starter

    Can anyone help with this please??
  3. anoniemouse

    anoniemouse Android Expert

    Try turning the phone off & remove the battery, take your sd card out then put it back in again.
    Replace the battery & turn your phone on, see if that helps.
    If not do a factory reset settings/sd & phone storage
  4. Tigrisan

    Tigrisan Lurker

    I got the same thing today on my EVO with the Froyo update and a 16G card. (SanDisk) I didn't have a problem prior to the update and this is the first time I've transferred data from my laptop to the SD card through the phone.

    Right now, I'm moving everything off the phone using an adapter for just the card and have replaced the 8G card that came with the phone. I'm not having a problem with that.

    I'm going to reformat the 16G then try again, but I'm wondering if this will happen if I load from the laptop to the card through an adapter rather than through the phone. Maybe it's something to do with the OS rather than the card.

    I did turn off the phone, removed the battery and card and reinserted everything, then tried again. That didn't work and I'm not willing at this point to do a hard reset. That will be my last resort.

    Anyone else having this problem and have you fixed it?
  5. marctronixx


    i have a evo and a 16gb Sandisk card. never had this error occur until today. i updated to froyo officially and not the leaked version. stock unrooted device. i have about 30 ish apps and out of those only 4 were able to be moved to SD card, so i did that. thats the last big thing i have done.

    this sounds like an issue with Froyo rather than the end user. ill bookmark this thread and smoke over any other responses...
  6. scirio

    scirio Lurker

    I just logged in after months of inactivity to say I'm having this exact same issue on my froyo'd Evo.

    I've tried 2 different 8gb cards, partitioned and wiped directly on the phone.
    I've also experienced the issue on 2 different Roms
    marctronixx likes this.
  7. marctronixx


  8. andy88488

    andy88488 Well-Known Member

    I'm having the same problem with my HTC Incredible.
  9. SUroot

    SUroot Extreme Android User

    general consensus in the thread in the evo forum is to reformat the card. Just be sure you backup the data first
    marctronixx likes this.
  10. marctronixx


    i had this issue again so now its been 3 times thus far and i suspect it will happen more.

    prior to the error, i had BT'ed a huge .wav file to the phone (a track i was working on). shortly after that i noticed the Sd card error.

    im running a 16gb sandisk and never saw this error until after Froyo. there are many others experiencing this also and they posted in the HTC forum.

    i have formatted this card every way i could--form the phone, from the ltop.. does not seem to matter how its formatted the issue can still crop up.

    this time as i was copying contents FROM the card to ltop, there was an error in the "tunnybrowser" folder. it was a folder within the tunny browser main folder. that suspect sub folder was empty, nevertheless it gave an error. i attempted to delete it and couldnt. so i took the card OUT of the phone and placed it into the ltop. THEN i was able to complete the transfer. i deleted the sub folder. im not sure if the folder was regenerated and i have used the dolphin browser since with no issues.

    just documenting what was going on to cause my card error this time...
  11. andy88488

    andy88488 Well-Known Member

    I've been trying that. It looks like the Inc with 2.1 might have screwed up the card. Several PC's won't recognize it at all. The one that will recognize it can't delete the files or format the card. The Incredible itself says it will reformat the card, but doesn't seem to do that. When I reformat on the Incredible, it doesn't generate any errors, but when I look at the card in Astro, all of the files and directories are still there.

    I downloaded the SDFormatter utility from Panasonic, but it says that the card is write-protected. I don't see how that's possible, because I don't see a write-protection switch on the Micro SD card.

    Am I basically screwed here?
  12. marctronixx


    What brand card do you have?

    Can you copy the files over? What size card?
  13. andy88488

    andy88488 Well-Known Member

    It's a Topram 16 gb card.

    I have a Windows 7 laptop which recognized the card and copied the files off of it. I tried deleting the files from the SD card using Windows Explorer. Windows said the files were successfully deleted, but they weren't. Windows also wasn't able to format the disk, using FAT32. The message was "Windows was unable to complete the format".

    It was to this machine that I downloaded the SDFormatter program, which gave me the "Memory Card is write-protected" error.

    Two other machines, both Windows XP, would not even recognize the SD card.

    Also, I tried to delete a file from the SD card using Astro File Manager. That was also unsuccessful. And Froyo was unable to reformat the card, which I think I already mentioned. It didn't produce any errors, but there was still data on the card after the format attempt.
  14. marctronixx


    How much available memory when all this happened?

    Also where did you purchase? Should be a warranty on it.

    What were you doing prior to the card error?
  15. SUroot

    SUroot Extreme Android User

    Are you rooted? It would be lovely if the answer to this is yes.
    marctronixx likes this.
  16. Baz8755

    Baz8755 Well-Known Member

    Having seen several similar threads involving various Android phones I was wondering just how often Android rewrites data to the MicroSD card. These cards are supposed to have a life of between 10,000 & 100,000 cycles but if Android is hammering it with updates.... who knows

  17. andy88488

    andy88488 Well-Known Member

    I'm not sure why it would be lovely, but the answer is no. I received this update from Verizon via OTA, and I've never rooted my phone.
  18. SUroot

    SUroot Extreme Android User

    The custom recovery "ClockworkMod", that you could have booted into if rooted would have given us (well you) an extra tool to format the card on the phone itself.

    I'll be honest, I haven't heard of the brand your card is and I would be tempted to say it's irreparable (I can't be sure but that's my thoughts right now)... Luckily you have your data, which is the main thing.

    Can you mount it on the windows 7 PC, right click the drive in "Computer" and select properties, select tools from the tab menu and do an error check?
    marctronixx likes this.
  19. andy88488

    andy88488 Well-Known Member

    The message happens intermittently. It's usually in conjunction with Newsrob, which is the only app I have which actively uses the SD card storage. Newsrob will also typically display an error message saying that it's having a problem with the SD card.

    Newsrob does typically work, so it looks like the SD card is usually okay.

    I bought this from Amazon, and they are not great about warranties. I'm not sure how long Topram's warranty is.

    I can't get the SD card to screw up at the moment, so I'm not sure how good the available memory info is. Right now, Available Phone memory 647 mb, Phone storage 6.29 gb, SD storage 14.81 gb.
  20. SUroot

    SUroot Extreme Android User

    Ooooh I didn't know that. is it worth ceasing use of newsrob temporarily?
  21. andy88488

    andy88488 Well-Known Member

    Thanks for your suggestion. I just tried doing the error check, and Windows 7 came back with "No errors found".
  22. marctronixx


    yeah i think the fact that now we can put APPs on the card coupled with the writes and re writes.. this is causing some to have some issues with card performance.

    the first time i had this issue happen i had about a gig or two left out of 16 and i had sent over a huge movie to the card.

    i would shy away from using top ram again in the future. although they are a national brand, i have seen more negative comments about the card than positive. certainly there are satisfied topram customers out there... however i would just stick to tried and true Sandisk. :D
    SUroot likes this.
  23. andy88488

    andy88488 Well-Known Member

    I don't really want to. I use Newsrob a lot.

    I don't think it's Newsrob's fault, because we're seeing some signs that there is a deeper problem with the SD card at the moment. I could switch Newsrob to Phone storage.
  24. SUroot

    SUroot Extreme Android User

    Certainly my brand of choice.

    @Andy, Sorry I thought your error was permanent not intermittent. Everything I said can be ignored ;)
  25. SUroot

    SUroot Extreme Android User

    yeah try that see if your SD card behaves.
    marctronixx likes this.

HTC Desire Forum

Features and specs are not yet known.

Release Date

Share This Page