1. Download our Official Android App: Forums for Android!

Support SD Card Not Mounting

Discussion in 'Android Devices' started by n1ghtwish, Aug 31, 2010.

  1. n1ghtwish

    n1ghtwish Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    113
    Joined:
    Feb 17, 2010

    Feb 17, 2010
    113
    4
    36
    Las Vegas, NV
    Has anyone else had any issues with their Droid 2 refusing to realize that there's an SD card inserted? I went through basic troubleshooting steps for this:

    1) try a different SD card - no dice
    2) format the SD card - again, nothing
    3) factory phone reset - nothing

    I have 3 cards: a 2gb, an 8gb and a 16gb. the 16 is what I had in my Droid 1 and it had no issues whatsoever!

    Can anyone provide any insight?
     

    Advertisement

  2. pool_shark

    pool_shark Android Expert
    Rank:
     #82
    Points:
    343
    Posts:
    2,509
    Joined:
    Aug 21, 2010

    Aug 21, 2010
    2,509
    566
    343
    Male
    Enterprise Server Engineer
    Ohio
    Is it plugged into the computer when you're trying to use it?
    Is so, you have to set the Droid2 to charge only or it can't use the SD card.

    I used the 8G card it came with then switched to my 16G card, no issues.
     
  3. n1ghtwish

    n1ghtwish Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    113
    Joined:
    Feb 17, 2010

    Feb 17, 2010
    113
    4
    36
    Las Vegas, NV
    thx for the reply... no, it's not plugged in. Even on the go, it won't even recognize an SD to mount, so the mount option is grayed out :/
     
  4. SioConnellan

    SioConnellan Lurker
    Rank:
    None
    Points:
    6
    Posts:
    3
    Joined:
    Aug 18, 2010

    Aug 18, 2010
    3
    4
    6
    Frederick, MD
    I was having the same problem. It didn't recognize my SD card at all. Now these steps make no sense. This shouldn't have worked. But now it sees the card, so what can I say...

    Powered off phone
    Removed SD card
    Reinserted SD card
    Plugged phone into laptop and turned back on
    Came here and read pool-shark's post
    Unplugged from laptop
    Can suddenly see SD card

    Now, this is nuts because I was playing around with this casually last night far, far from a laptop or even an electrical plug and no matter what I did the phone would not see the card. Still have no clue what in the above steps worked, but for some reason it's OK now. Sorry I can't be more helpful. Good luck!
     
  5. n1ghtwish

    n1ghtwish Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    113
    Joined:
    Feb 17, 2010

    Feb 17, 2010
    113
    4
    36
    Las Vegas, NV
    Holy crap, that actually worked! It's amazing how the idiosyncrasies of these devices are so random and kinda difficult to figure out.

    Thank you so much for the reply!! Now to fix the issue of the Moto ADB drivers not installing :/
     
  6. Redflea

    Redflea Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    2,623
    Joined:
    Oct 6, 2009

    Oct 6, 2009
    2,623
    289
    163
    Bizarre...
     
  7. tyb_704

    tyb_704 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 6, 2010

    Sep 6, 2010
    1
    0
    5
    thanks. this actually worked:D.
     
  8. pish180

    pish180 Lurker
    Rank:
    None
    Points:
    6
    Posts:
    1
    Joined:
    Sep 19, 2010

    Sep 19, 2010
    1
    1
    6
    I was having this issue as well.

    How it started:
    I installed Unrevoked forever, radio update, and new 2.2 ROM

    My procedures:
    Phone on
    Pulled the SDCard out
    Put the SDcard in my may computer using a microsd to SD converter.
    Noticed my SDCard was almost full
    I deleted the old ROMs (zip files in the root dir)
    I backuped and removed older backup from nandroid
    ejected the SDcard from my PC and reinserted it into my phone
    Phone went thought the normal procedure of checking the card and mounted it fine.

    ===========

    Prior issues:
    I'd put the card in. It would scan it. Then it would say card is ready for removal and never mount it. I had tried removing the card several times. It would also mount to my computer though my phone flawlessly.
     
    Galarzaa likes this.
  9. iavswn

    iavswn Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    103
    Joined:
    Sep 29, 2010

    Sep 29, 2010
    103
    2
    36
    That worked for me. Really good advice. Thanks :)
     
  10. JerseyJeff

    JerseyJeff Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Oct 14, 2010

    Oct 14, 2010
    1
    0
    5
    Hi - the steps you did seem to make sense in that I think it forces the Operating System into a state that it is "willing" to remount the SD drive. I have a DINC and am having the same issue with my SD card - in my case, the OS had a meltdown when I got an incoming call and it was endlessly playing my ringtone - nothing worked to stop it; but in the course of trying to open up the back and remove the battery, I accidently ejected the card. Now it won't work. I tried your suggestion above, but it didn't work for me - just wondering if anyone has other suggestions? I will also probably go out and buy another card, in case this one is simply hosed...

    Thanks in advance!!
     
  11. k6372

    k6372 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Nov 15, 2010

    Nov 15, 2010
    1
    0
    5
    Holy crap that actually worked... >.>
     
  12. fredm22

    fredm22 Lurker
    Rank:
    None
    Points:
    25
    Posts:
    2
    Joined:
    Aug 25, 2011

    Aug 25, 2011
    2
    0
    25
    my issue is similar. I have a HTC Droid Eris and its running android 2.2. I tried almost everything I could think of. I inserted a different SD card into my phone, I formatted my SD card on the computer, I did a factory reset and none of those worked. however I can put my SD card in any phone and. it'll work. don't know. what else to try any ideas?
     
  13. ron412

    ron412 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Nov 21, 2011

    Nov 21, 2011
    1
    0
    5
    Tried all of the above with no luck. Went to Verizon store, they told me SD card needed to be replaced. I asked them to try another card to confirm and when they did, there was nothing wrong with card.

    I am being sent a new Droid 2 Global to replace my phone. Was on warranty.
     
  14. zombie tech

    zombie tech Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Feb 15, 2012

    Feb 15, 2012
    1
    0
    5
    I don't remember what I did but my issue was this:
    My phone stopped recognizing my sd card
    It would say sd card ready for removal, sd card removed insert a new one
    If I tried to mount it it would mount followed by an immediate unmount
    It worked in another phone and my pc so it wasn't the card
    Also tried turning it off and back on with the card out or in no good
    I tried cursing at my phone like a madman and that didn't seem to help me or the phone

    I tried the above and my phone started recognizing my sd card again. Something along the lines of it may have been a problem that occured when trying to use the phone as mass storage for me as it wouldn't work then i noticed the errors.

    On a scale of 1-10 i would have to say at this moment i love SioConnellan as 1000000000. Well cause I have the xperia play (400mb internal) So i absolutely need my sd card.

    Thank you so much I looked everywhere on the internets. I created an account here just to thank you as this solved my problem. If i ever run into the problem in the future I'll see if I can get a better answer. THANK YOU
     
  15. dspindler

    dspindler Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Feb 26, 2012

    Feb 26, 2012
    1
    0
    5
    I tried the above procedure but no luck for me. I did buy a Kingston 8 gb micro SD card that has the notch thing protruding from the right side as it slides into the SD slot. I lost my old card and just replaced it with the Kingston card. Could the notch be preventing it from seating correctly?
     
  16. bustinjussell

    bustinjussell Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Feb 26, 2012

    Feb 26, 2012
    2
    0
    5
    I had Connect to PC disabled on startup, enabling fixed this issue.
    My Memory card stil is playing up, It just says checking for errors for ever It happend before so I formated it and put it back in now it work but hardly has anything on it, would this be the issue? It is a 32GB Sandisk card in a HTC Legend. I think trying all the rooting may of killed it since it worked before then.
     
  17. dinkystew

    dinkystew Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 10, 2012

    Mar 10, 2012
    1
    0
    5
    I have the exact same problem...my phone got stolen, got a replacement, this did not come with an sd card so tried 3 different ones that all work in other phones but it wont even say any of the stuff it normally does when the backs off or when its trying to find the card, please tell me this has been sorted with you??
     
  18. Eoraptor

    Eoraptor Lurker
    Rank:
    None
    Points:
    25
    Posts:
    6
    Joined:
    Apr 23, 2012

    Apr 23, 2012
    6
    0
    25
    Caregiver
    Alrighty. New to the board so please bear with me.

    I am running into this same issue as everyone else: card reads as unmounted, won't mount, won't recognize the card is there, but the card is known working (IE can be read by my PC and other devices) this started after I shut the phone down and popped out the stock 8gb card for a new 16 gb. (neither will register now on the phone)

    I tried factory resetting, soft boots, and hard boots, reinstalled the drivers, turning off no-lock, and the above quoted instructions, but nothing seems to be working. I even formatted the card to FAT32 on my PC and put it back in.

    I have tried the above trick on my windows7 32 bit and 64 bit machines (both ultimate) in several different USB modes (PC sync, charge only, mass storage, etc)

    Any help would be appreciated, as I want to turn this phone into a palm-top, iPod-analogue, but can't flash anything onto it without the flash card working (and have a lot more than a couple gigs of media I want on it too) :banghead:
     
  19. Eoraptor

    Eoraptor Lurker
    Rank:
    None
    Points:
    25
    Posts:
    6
    Joined:
    Apr 23, 2012

    Apr 23, 2012
    6
    0
    25
    Caregiver
    Actually solved this on my own... installed Auto Mount on my phone. The next time I unplugged my phone from the PC, (and every time subsequently) the phone immediately re-recognized and remounted the SD card.

    whoohoo!
     

Share This Page

Loading...