1. Are you ready for the Galaxy S20? Here is everything we know so far!

SD still won't mount properly

Discussion in 'Android Devices' started by windsorclarenc, Apr 15, 2012.

  1. windsorclarenc

    windsorclarenc Android Enthusiast
    Thread Starter

    I'm trying to get a2sd to work properly. I just used Amon Ra to partition my SD card again. I partitioned about 1gb to each the swap and the apps. I flashed the new MIUI ICS I saw here. When I try to install a2sd in terminal emulator it tells me "SD card not mounted properly". I unmounted then remounted the SD card and it still gives me the same error. Is there anything I can do to fix this?

    What I'm using
    ROM: MIUI ICS with a2sd built in (the newest)
    Kernel: Tiamat that came with said ROM.
    SD card: 32gb class 10
    Recovery: Amon Ra (2.3.6?)
     



    1. Download the Forums for Android™ app!


      Download

       
  2. neo_the_one

    neo_the_one Member

    Partition your card via pc.
     
  3. argedion

    argedion The TechnoFrog

    What did you partition to? is it EXT 2, 3, or 4? I have never had a problem with EXT 2 or 3 Also no need for a swap Tiamat doesnt support swap.
     
    ocnbrze likes this.
  4. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    ndh777 and windsorclarenc like this.
  5. argedion

    argedion The TechnoFrog

    Besides you would either need to do it in Linux or have a live cd to partition it in anyways. Windows does not nor will not ever support ext partitions. I'm not sure about Apple never used one of those products. gparted would be the tool of choice if you were to ever try to do so from a computer but as ocean has stated it is best from recovery.
     
    ocnbrze likes this.
  6. windsorclarenc

    windsorclarenc Android Enthusiast
    Thread Starter

    I originally partitioned to ext2 then upgraded it to ext3 via Amon Ra. My SD card is mounted and my computer recognised it but terminal emulator doesn't.
     
  7. windsorclarenc

    windsorclarenc Android Enthusiast
    Thread Starter

    I'm getting this issue with every ROM but one so maybe it's a hardware issue?
     
  8. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    what exactly are you typing for the command? if miui has a2sd built in, then the apps are moved to the card automatically. there is no need to command it in.

    also what version of miui are you on again:
    [ROM][MIUI v4 4.0.4] 2.4.13 - xda-developers?

    or this one:
    Miui v4 2.3.23 (Full HWA) - xda-developers?

    i do not see any support or having a2sd built in. i have never tried these roms and i have not really read the threads so i could be wrong.

    if it does not have a2sd then hopefully it has support for it so that all you will have to do is flash the darktremors script to get a2sd to work on these roms.
     
    windsorclarenc likes this.
  9. windsorclarenc

    windsorclarenc Android Enthusiast
    Thread Starter

    Since the op I've switched to another version of MIUI because of the low disk space warning I got. My apps didn't automatically move to the SD card, so in terminal emulator I typed:
    su (enter)
    a2sd install (enter)
    It went through the motions until the second to last line it says "SD card not mounted properly". And then it stops. I didn't flash dt's a2sd zip so I took this to mean a2sd was built in. Most times if I try a command starting with a2sd it says command not found or valid. Then I go and flash the a2sd zip.
    Right now I'm using MIUI build number 112300 according to what it says in settings. But I get the same error message on literally every ROM except one. And I don't remember which one that was so I can't go back to it. :(

    Is there a good ROM with a2sd built in that I could switch to? I've accumulated far too many apps now to not use a2sd.
     
  10. Mikestony

    Mikestony ~30% Carbon Black ±
    VIP Member

    MikG v3.11 has a2sd baked in ...use the full wipe version and follow procedure to flash (wipe everything except sd card..I wipe 3x, then flash)
    Very stable rom.:)
    MikG v3.11 [3/9/2012]

    flashing procedure...post #3...http://themikmik.com/showthread.php?6621-Can-we-flash-over-the-old-ROM&p=86022#post86022
     
    ocnbrze and windsorclarenc like this.
  11. argedion

    argedion The TechnoFrog

    what version is your TE and what version of DT are you using?
     
  12. ndh777

    ndh777 Android Expert

    MikG didn't have A2SD when I was using it before the update, but they may have it now.

    I'm running the latest MIUI and it does have A2SD running within it. Just partition your SD card using the Recovery (not a PC, I wouldn't even recommend Linux for newbies) and use it normally.

    If this isn't working, you may have a corrupt SD card. I had one about a month ago. Try using a different SD card, any size, just to see if it works with that one. If it does work with the other card, then something is wrong with your card, if it doesn't work, something is wrong with your method.

    EDIT: If you don't have a spare card, try just completely wiping your card and using it in the phone like normally. If it doesn't mount properly, there's something wrong with your card.
    IMPORTANT: Before wiping, make sure to back up your important information too.
     
    ocnbrze likes this.
  13. windsorclarenc

    windsorclarenc Android Enthusiast
    Thread Starter

    I use terminal emulator in ROM toolbox and I'm not sure about the dt because it came with the ROM. I have a zip of the latest one, should I flash that?

    I used to get the same error with my old class 4 16gb SD card. The error message is why I bought my class 10 32gb card. I thought I followed the guides step by step, but maybe I missed something.
     
  14. argedion

    argedion The TechnoFrog


    OK I would use te stand alone and not from with in a third party program. That could be the biggest issue your having.
     
    ocnbrze likes this.
  15. brianvillage5

    brianvillage5 Well-Known Member

    Dude instead of looking for a rom that has it baked in just flash the zip over a rom you like. As long as your kernel supports it it will work. I personally run cm7.2 with tiamat 4.1.0 and I get to use ext.4 and that makes the whole you need a class ten SD card moot. I have a class 4 32 gig card and my apps run just as smooth as if they were on internal storage.

    sent from my evo 4g running a bunch of awesome mods developed by some real sweet devs.
     
    windsorclarenc likes this.
  16. windsorclarenc

    windsorclarenc Android Enthusiast
    Thread Starter

    I think I'm just destined to not be able to use a2sd. I'll just use the apps2sd in settings. Better to have some of the app moved than none at all.
     
  17. argedion

    argedion The TechnoFrog

    I think your over complicating the problem with "simplistic programs" things like rom toolbox are nice however they are problem matic when it comes to doing task that require the resources of a stand alone program I think you need to download terminal editor from the market and get dark tremors from the life after root. Rooting for dummies gingerbread edition from the all things root section here. I don't believe the problem is with your sdcard at all but with the program you choose to use. That terminal wasnt meant for real computing such as what your wishing to do.
     
    ocnbrze likes this.
  18. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    i totally agree, though i have not messed around with rom toolbox yet. never really saw the need for it.
     
  19. windsorclarenc

    windsorclarenc Android Enthusiast
    Thread Starter

    Okay I'll give this another shot. This is the procedure I'm going to try:

    1. Boot into recovery
    2. Wipe cache and dalvik cache
    3. Flash latest DT a2sd zip and reboot.
    4. Check to see if apps have moved. If they have, celebrate and quit my whining.
    5. If they haven't, in TE, type su and hit enter. Then a2sd install and hit enter
    6. Pray to various gods that it worked while it reboots.

    Is this the correct procedure?
     
  20. argedion

    argedion The TechnoFrog


    Yes in te and not through rom toolbox that is a good program however not for the use your wanting. Also make sure your partition is clean.
     
  21. windsorclarenc

    windsorclarenc Android Enthusiast
    Thread Starter

    I tried all of the above steps and still get the error "SD not mounted". But it is, I can access it no problem. Can I format the ext partition without formatting the whole SD card?
     
  22. windsorclarenc

    windsorclarenc Android Enthusiast
    Thread Starter

    When trying other commands I get "block device not found
    Cannot mount SD card"

    Can this be part of the issue?
     
  23. argedion

    argedion The TechnoFrog


    I would back up contents of drive go back in to recovery create a 1gig partition ext2 no swap the rest fat/fat32 once done take ext2 to ext3. Go to rom restore stuff on card then reboot and check things out
     
    dustwun77 likes this.
  24. windsorclarenc

    windsorclarenc Android Enthusiast
    Thread Starter

    Okay I'm going to give this one last try. I finally got my SD card backed up. So now these are the steps I'm going to be doing:
    1. Boot into recovery(Amon Ra).
    2. Flash superwipe twice. Then wipe everything, including SD card, 3 times.
    3. Partition SD card, allocating 1gb to ext and 0 to swap.
    4. Still in recovery, update from ext2 to ext3.
    5. Transfer MikG3.11 to my phone and flash it.
    6. Reboot and pray.

    Did I miss anything?
     
  25. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    sounds like a plan to me. make sure though that you backup your apps with rom tool box or titanium backup.
     

HTC EVO 4G Forum

The HTC EVO 4G release date was June 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

June 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...