1. Are you ready for the Galaxy S20? Here is everything we know so far!

Sdk emulator not working : VCRUNTIME140.dll not found

Discussion in 'Android Devices' started by etienne langevin, Mar 26, 2021.

  1. etienne langevin

    Thread Starter

    So I installed Android Studio not long ago. I installed everything right, I installed in the sdk tools :
    • Android Emulator
    • Android SDK platform tools
    • Intel (x86) Emulator accelerator (HAXM)
    I installed the API-Level 30 (x86 too)
    I tried enabling/disabling launching in a tool window
    I uninstalled and reinstalled everything several time

    Next, I tried launching the emulator with command line
    I first created an AVD: Pixel_XL_API_30 and used the command
    emulator.exe -avd Pixel_XL_API_30 in the right folder with admin and non-admin privileges
    I get a VCRUNTIME140.dll not found

    So I tried fixing the dll following mainly (https://softwarekeep.com/help-center/how-to-fix-the-vcruntime140dll-is-missing-error-on-windows-10)
    I ran scannow, I tried repair tools in all Visual studio version I could find in apps and functionalities
    Then I tried unrergistering and registering back the dll and I get the following :

    Module VCRUNTIME140.dll was loaded but entry point dllRegisterServer not found (more or less) Same for dllUnregisterServer.

    And here I am stuck and desperately in need of your help. Thanks
     



    1. Download the Forums for Android™ app!


      Download

       

Android Emulator Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...
Similar Threads - Sdk emulator working
  1. Gangul
    Replies:
    0
    Views:
    2,498
  2. doclogic
    Replies:
    1
    Views:
    2,205
  3. fra8995
    Replies:
    0
    Views:
    6,190
  4. lolcore
    Replies:
    4
    Views:
    3,496
  5. Tamas Polgar
    Replies:
    0
    Views:
    2,091
  6. James Calvert
    Replies:
    1
    Views:
    1,926
  7. nihalcybernetic
    Replies:
    1
    Views:
    4,657
  8. AlexEv
    Replies:
    0
    Views:
    3,722
  9. seafree
    Replies:
    0
    Views:
    2,106
  10. Flagged Bird
    Replies:
    2
    Views:
    630

Share This Page

Loading...