1. Download our Official Android App: Forums for Android!

Support Seriously degraded performance after 2.3.5 update

Discussion in 'Android Devices' started by shaneydroid, Jan 8, 2012.

  1. shaneydroid

    shaneydroid Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    225
    Joined:
    Oct 12, 2011

    Oct 12, 2011
    225
    10
    38
    Sheffield, United Kingdom
    I manually updated my Ace to Gingerbread 2.3.5 today via Odin.
    The firmware upgrade appeared to go without a hitch and my phone now shows it is indeed running 2.3.5 (it was running 2.3.3 before).

    My main reason for upgrading is that it is supposed to improve performance of the phone but unfortunately, I have found performance has degraded drastically.

    Basically, after turning the phone on it is running crap. I have only two home screens and just scrolling between those is laggy as hell and it just jumps between the screens about a second after I swipe.
    Pressing an app icon lags as well and takes ages to actually do anything.
     

    Advertisement

  2. praky

    praky Well-Known Member
    Rank:
    None
    Points:
    53
    Posts:
    224
    Joined:
    Jun 11, 2011

    Jun 11, 2011
    224
    91
    53
    Try reflashing with ODIN. Sometimes this happens.
     
  3. shaneydroid

    shaneydroid Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    225
    Joined:
    Oct 12, 2011

    Oct 12, 2011
    225
    10
    38
    Sheffield, United Kingdom
    Well since I was going to reflash, I figured I may as well go for 2.3.6 instead.
    Cleared the cache partition this time, which I forgot to do before but still the same problem :(
     
  4. PJ147

    PJ147 Android Enthusiast
    Rank:
    None
    Points:
    68
    Posts:
    457
    Joined:
    Jun 10, 2011

    Jun 10, 2011
    457
    143
    68
    Male
    Sales
    Hampshire, UK
    2.3.7 cyanagenmod 7??? works well for me! (+allinoneramscript)
     
  5. shaneydroid

    shaneydroid Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    225
    Joined:
    Oct 12, 2011

    Oct 12, 2011
    225
    10
    38
    Sheffield, United Kingdom
    I have to admit I'm a bit concerned by the unofficial nature of such mods and needing to root etc.

    In the meantime I have flashed 2.3.6 AGAIN.
    Cleared the cache data, restored the phone to factory settings, tried without the memory card in and still pretty appalling.

    If I am using the phone it seems ok but when left 10 minutes or so I unlock the screen and that's when the problem starts.
    Terribly slow when phone is first turned on and terribly slow when the screen is unlocked.
    It does improve a lot when wifi is turned off but I prefer to leave it on all the time when at home.
     
  6. shaneydroid

    shaneydroid Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    225
    Joined:
    Oct 12, 2011

    Oct 12, 2011
    225
    10
    38
    Sheffield, United Kingdom
    I have kind of solved the sluggishness problem.
    WI-FI

    Leaving at the default sleep policy (turns off when screen turns off, on when screen turns on) causes the problems.
    For whatever reason, when it turns on with the screen, it causes chronic slowness of the phone (for me) and recover for some time.

    Setting wi-fi to always on, even when screen is off solves all the performance problems and the phone has been running well for the past couple of days.
    Of course the downside is that wi-fi is using up battery even when the phone is off but I suppose a fast phone which runs out fairly quickly is better than a juddery, unusable phone which runs for days...
     

Share This Page

Loading...