1. Download our Official Android App: Forums for Android!

SetCPU

Discussion in 'Android Apps & Games' started by bradspace, Feb 22, 2010.

  1. bradspace

    bradspace Member
    Thread Starter
    36

    Feb 19, 2010
    12
    2
    36
    IT Support
    Ellicott City, MD
    Haven't been able to find anything on this in the forums. I went to the market and bought the app, but it doesn't seem to be working for me. When I launch it, I get a black screen that has a header that says SetCPU then is flashes up another black screen with a header that says SU Request. After about a minute or so, I get a pop up asking me to force close or wait. I went into Superuser Permissions and I get the same black screen with the SU header. Any thoughts?

    Thanks!
     

    Advertisement

    dattdewd likes this.
  2. shrink57

    shrink57 Well-Known Member
    143

    Dec 19, 2009
    1,529
    149
    143
    South Florida
    You need to be rooted for it to work. Are you?
     
  3. bradspace

    bradspace Member
    Thread Starter
    36

    Feb 19, 2010
    12
    2
    36
    IT Support
    Ellicott City, MD
    Sorry, guess I should've posted that. Yes, I'm rooted and running Fresh 1.1 with the Gumbo Kernel.
     
  4. bradspace

    bradspace Member
    Thread Starter
    36

    Feb 19, 2010
    12
    2
    36
    IT Support
    Ellicott City, MD
    Nothing? I was hoping to get this working for improved battery life.
     
  5. InstantKarma

    InstantKarma Well-Known Member
    153

    Dec 16, 2009
    1,001
    158
    153
    Male
    Houston, Tejas
    Have you contacted the developer?
     
  6. shrink57

    shrink57 Well-Known Member
    143

    Dec 19, 2009
    1,529
    149
    143
    South Florida
    I am not familiar with Fresh 1.1 and the Gumbo kernel. Have you tried reflashing the rom? It is running fine with DroidMod 1.0
     
  7. ixixix

    ixixix New Member
    5

    Feb 24, 2010
    1
    0
    5
    I had the same thing happen to me. After I forced close and restarted the app, it worked fine tho.
     
  8. shrink57

    shrink57 Well-Known Member
    143

    Dec 19, 2009
    1,529
    149
    143
    South Florida
    That goes for just about any app that requires SU access. Usually it takes just one forced close and then all is well. When I do another flash, I generally have to go through the process again.
     
  9. andrew53517

    andrew53517 Well-Known Member
    38

    Oct 31, 2009
    491
    18
    38
    So this is happening to me now. Any ideas of what to do? I'm currently running droidmod, but I flashed chevyno1's kernel and it is staying black then force closing. Then I open it up again and still stays black. :(
     
  10. bradspace

    bradspace Member
    Thread Starter
    36

    Feb 19, 2010
    12
    2
    36
    IT Support
    Ellicott City, MD
    I have not yet contacted the developer. Thought it may be a more common issue and I'd look here first before bothering them. I reflashed my device last night just to be sure and that didn't help either.
     
  11. FerraraZ

    FerraraZ New Member
    5

    Feb 24, 2011
    1
    0
    5
    I've been having this even tho superuser says its given SetCPU permission. Still getting force closes everytime.

    I've also contacted the developer.
     
  12. MojoRisin

    MojoRisin Member
    16

    Jan 26, 2011
    15
    1
    16
    Did you try rebooting the device? I had an app (cant recall which one) that did this and a reboot solved the problem
     
  13. Spr8dogg

    Spr8dogg Well-Known Member
    16

    May 19, 2010
    60
    3
    16
    Southern California
    Also try booting ito recovery and wiping partition cache dalvik cache.
     
  14. Hmmm first of all it maybe not related to Super User app as even if the app is denied permission that you can still open it and it will operate it as read only application, that being said it would not force close for that matter.

    Now as Spr8dogg suggested you can go in to recovery and wipe cache, davlik and then do fix permission. Make sure the kernel that you are using supports OC as some custom rom have performance field that specify their own governor, min/max frequency also if that the case with your rom then disable it on boot and SetCPU should be able to scan the default clock frequency and operate thereafter.
     

Share This Page

Loading...