1. Are you ready for the Galaxy S20? Here is everything we know so far!

Setting Up A Hero on Fido

Discussion in 'Android Devices' started by Perihelion, Dec 13, 2009.

  1. Perihelion

    Perihelion Member
    Thread Starter

    Here are my notes after successfully setting up a Telus HTC Hero on Fido.

    I'm on a multiyear Fido plan and didn't want to bail, so there was no way to get a Hero through my default carrier. Unlocked was the only way to go. Comparing prices of the HTC Hero (with North American 3G frequencies) online and in stores, I found that the best deal at the time was to buy a Telus HTC Hero on no contract in store and bargain in a few freebies. (Bluetooth headset, case, car charger, etc).

    After getting my Hero home and happily unboxing everything, I put the battery in, plugged in the charger and set about unlocking the phone. The cheapest and quickest way I know of is to get an unlock code from the internet. I've had good experiences going through unlock code sellers from eBay so I did a quick search and used my newly purchased unlock code. Note that the IMEI number needed is both on the barcode sticker on the box as well as under the battery inside the phone. This was the easiest unlock I've ever done, no need to find hidden menus or anything. Steps below.

    1. Go to eBay.
    2. Search for "unlock htc hero fido".
    3. Sort by price.
    4. Review seller's feedback to verify they're not a scammer.
    5. Purchase unlock code.
    6. One the phone is finished charging, insert sim card and power it on.
    7. A notification window pops up asking for the unlock code.
    8. Enter the unlock code and job done!
    Initial Setup:
    Having unlocked the network, my Hero was now fully charged and on the Fido network. Voice calls worked immediately, but 3G data did not because all of the internal data network settings were preset to Telus servers. Stepping through the first time setup wizard got the basics going and the phone functioning ok. Location detection worked fine, time settings were correct when left on "detect automatically".

    Issues Out of the Box:
    I found the following needed to be addressed before I was happy with the phone.

    • HTC widget for combined clock and weather showed the wrong weather. I found this super annoying. The location detected was correct, right city, timezone and everything but the weather was displaying as 20 degrees celcius outside when in reality it was minus 19 degrees celcius. (Fix below)
    • SMS time stamps were wrong. Texted my friend who replied but the timestamp on the reply was 8 hours too early which screwed up the message threads. (Fix below).
    • 3G data did not work because as mentioned above, the network settings were all set to Telus. (Fix below)
    • Picture messaging (MMS) did not work because the network settings were all set to Telus. (Fix below)
    • Phone always shows the "R" for roaming even though I'm a Fido client on a Fido network. (No fix found yet)
    Clock/Weather Widget Fix:
    The weather portion of this HTC widget showed the wrong weather for the "current location" despite correctly identifying my city. Manually adding the city to the list provided the correct weather but that's not what shows up on the home screen. Here's what I did about it:

    1. On the home screen, remove the clock/weather widget by holding it and dragging it to the "remove" area. Now you have a big blank space on the home screen.
    2. Click the + icon to add a widget.
    3. Select HTC Widget > Clock > big clock and weather widget.
    4. Don't use the "current location" for the weather setting, manually select your city from the search.
    5. When the widget loads, the default city showing on the widget is the one you selected. Job done!
    SMS Time Stamp Fix:
    As mentioned above, the timestamps for text messages on my Hero on Fido were all messed up for incoming messages. The reasons for this are outlined in detail on this and other forums and are irrelevant to how to get it working. First, I installed ChompSMS from the Market which has other benefits such as showing messages as speech bubbles and makes following a conversation quick and convenient. This displayed the messages in the right order but still didn't fix the timestamps meaning that the timestamps would not display in the app. Here's what I did about it:

    1. As mentioned, download and install ChompSMS which displays the messages sent and received in the right order.
    2. Download and install SMSFixTimes app from the market. Run it.
    3. When the app loads, read the instructions and click "Configure/Test".
    4. It shows a sample message and both the received time (when the message got to your phone) as well as the timestamp on the message as it moved through the network (which is wrong).
    5. Look at the difference in time. Set the "automatic offset" for the right number of hours so that the received time matches the network timestamp. This app simply modifies the network timestamp by the number of hours you select so that the time received matches the updated message timestamp. Handy! (For me, this was +5 hours as I'm in Alberta).
    6. I didn't bother with "Fix existing messages" but all new messages were stamped correctly.
    7. Note that in the notifications window, the time on the message is still wrong as it reads this stamp before the app has a chance to modify it. However, ChompSMS now shows the correct received time on the message and again the messages are in the right order for the conversation. Job done!
    3G Data Setup Fix:
    The 3G data settings (APNs) were preset for Telus which was no help to me at all. There are many posts on other forums on correct APN settings and I tried all of them with varying success. Here's what worked:

    1. On the home screen, press the Menu hardkey and choose Settings.
    2. Select Wireless Controls > Mobile Network Settings
    3. Make sure data roaming is on, and "Use only 2G networks" is off.
    4. Under network operators, I selected Fido manually to ensure I'm not accidentally roaming onto Bell or Telus.
    5. Select "Access Point Names" aka (APNs).
    6. Deleted the ones that were there.
    7. Hit the MENU button > New APN.
    8. Used the following settings:
      • Name: Fido Internet
      • APN: internet.fido.ca
      • Proxy:
      • Port: 8080
      • Username: fido
      • Password: fido
      • Server: <blank>
      • MMSC: http://mms.fido.ca
      • MMS Proxy:
      • MMS Port: <blank>
      • MMS Protocol: Wap 2.0
      • MCC: 302
      • MNC: 370
      • APN type: <blank>
    9. Power the phone off and on again. 3G and HSPA indicators came on after booting up and acknowledging the "you are roaming" message. (See below for more info). Job done!
    Picture Messaging (MMS) Fix:
    I was getting notifications that I received multi media messages but I couldn't actually get the pictures to download at first. Here's what worked:

    1. Follow the instructions above to set the 3G APN settings up. Included in that APN configuration are the servers for the MMS server.
    2. Once the APN kicks in, I was able to turn on "Automatically downlaod" for the picture message preferences and now the pictures show up in Chomp SMS perfectly.
    NOTE: My old phone (Nokia 5800) used 2 APN definitions, one for internet and another for picture messaging. This DOES NOT WORK on the Hero. You set up a single APN definition for both as explained above to get it all working.

    Always Roaming Issue:
    I don't have a fix for this yet. Based on posts I've found on this and other forums, there may not be a simple fix for this if using a Fido sim card since the the MCC and MNC numbers for Fido and Rogers don't match but they share a network. Its a bit annoying getting the warning all the time but a small price to pay to have the Hero working on a cheap Fido plan.

    Getting Value from my Hero:
    Signed up for this forum and did a bunch of reading. In particular, followed lekky's excellent tips and apps post found here:


    Hope that helps people get started, feel free to PM me to update this post if I've said something incorrect.


    koolbreeze, runlsd and bablu brar like this.

    1. Download the Forums for Android™ app!


  2. afelotreyu

    afelotreyu Guest

    I have to say I did not noticed the weather problem or the sms timestamp until I check this post. Fixed both thanks to you and also updated my APN since I was missing some settings.

    Definitely looking forward to a fix for the Roaming problem which I don't think will come any time soon :(

    As for SMS app I use "Handcent SMS" :)
    Thank you!
  3. goliath11

    goliath11 Lurker

    Thanks for the info! I'll be switching to a Fido plan soon and I'm sure this is going to be a big help. Is the roaming warning a pop-up message or just a notification on top of the screen?
  4. Blue1k

    Blue1k Android Enthusiast

    I have the Telus Hero on Fido too! :)

    The only time roaming will be noticeable is during boot up when it asks if you want to turn data on because you are roaming.

    Everything else is pretty much perfect. The APN settings only take a few seconds to delete and set up with fido. HSPA is very nice (I used to have the European GSM Hero with no NAM 3G).

    +1 for Handcent. So much better than chomp. Works great with timestamp fix (+5 hours for Vancouver)
  5. lilbbgurl

    lilbbgurl Lurker

    thanks for the fix =)
    now if only the roaming would go away >.<
  6. h_zee13

    h_zee13 Newbie

    hey I followed your instructions for the APN settings and the phone doesn't connect to the internet.

    the error msg that I get: "Connection failed due to incorrect APN settings"
  7. Perihelion

    Perihelion Member
    Thread Starter

    Where are you located? If you're close by, I don't mind taking a look to help you out. I just double checked my settings and they're still working great. I was in Northern Alberta the other day and was online with no problems there as well...

    I switched to Handcent as well. The timestamp issue cameback when I updated chomp so I left and moved over to Handcent which is stamping messages correctly. :D
  8. h_zee13

    h_zee13 Newbie

    i'm in Montreal, Quebec

    My problem is solved
    apparently a year ago, i had a cellphone whichkept going into the internet when it was in my pocket and since i didn't have a data plan back then, i had called Fido and had asked them to block the internet on my account so that i wouldn't get charged for it...
    so the block was still in my account and thats why i couldn't access internet now on my Hero

    thanks to everyone who tried to help me figure this out
  9. lanxer

    lanxer Lurker

    Hi, I am in the same situation. Telus Hero unlocked to use on Fido Network. Only difference maybe is that I'm in Ontario and I'm not sure if that changes anything for setting up the 3G Data fix.

    I've tried your settings but I am unable to get the MNC setting to 370. It defaults to 37 and if I change it to 370 the phone won't save the APN settings even after I save it. The only way to save the APN setting is to leave it on 37 and when I do that I get the "connection failed due to incorrect APN setting" notice.

    Any help would be apreciated.
  10. h_zee13

    h_zee13 Newbie

    Well what happened with me is that fido had blocked my internet access because I had asked a long time ago...so when I added the data plan the csr hadn't seen the block in my account so the settings weren't working for me.
    I dont know about ur account but a call to fido customer service wouldn't hurt and have them verify if there are any settings blocked
  11. lanxer

    lanxer Lurker

    That has been verified, there is no block on my data since I recently signed up for data on my account. The main issue (I think) is that my phone (for reasons unknown to me) won't let me input MNC 370. Not sure why but it'll discard all APN information if the MNC is 370.
  12. h_zee13

    h_zee13 Newbie

    I don't know if you use MMS but here are my settings:

    • Name: Fido Internet
    • APN: internet.fido.ca
    • Proxy: <blank>
    • Port: <blank>
    • Username: <blank>
    • Password: <blank>
    • Server: <blank>
    • MMSC: <blank>
    • MMS Proxy: <blank>
    • MMS Port: <blank>
    • MMS Protocol: Wap 2.0
    • MCC: 302
    • MNC: 37
    • APN type: <blank>

    like you said mine also won't allow me to input 370 in MNC...but you don't have to

    anyways my settings work fine and i didn't even have to put anything in the other fields like the OP, just Name and APN fields need to be filled
  13. lanxer

    lanxer Lurker

    Thanks for that information. I've put them in exactly (even upper and lower case) and still nothing. I took out my SIM card and put it in an iPhone 3G and the data worked on that so it definitely isn't an account issue.

    I will contact HTC and Fido tomorrow and see if they can sort this problem out, maybe it's an isolated problem with my phone.

    Thanks for the help.
  14. h_zee13

    h_zee13 Newbie

    good luck
  15. ckbekeong

    ckbekeong Lurker

    Hi there,

    I was wondering whether it is a normal situation i am facing.

    I recently got an unlocked Sony Ericsson Xperia X10 and i am on Fido network. I took up their data plan ($25 for 500MB data usage) and activated it without any problem. I managed to get on the EDGE network since to my knowledge Fido does not have 3G which is not a big problem for me. I also manage to get on the internet, phone calls, caller ID, SMS works for me.

    The problem is that none of my apps which requires a network connection works. An example would Android Marketplace. It says network connectivity issue whenever i tried to check out the available apps on the market place. Ditto for other apps which requires network connectivity.

    Now, if i enable my home wireless network, all my apps works perfectly but not when it is on EDGE network. Is this normal? If not is there some settings which i may have missed out?

    Any help to resolve this is much appreciated!
  16. yacinelaz

    yacinelaz Lurker

    hello everyone
    i bought an unlocked htc hero and running it on fido with no problems so far
    i got some questions though
    how do i kno which region my phone is from and if it makes a difference
    and my other question is how can i upgrade my firmware to 2.1 and is there any risks to doing so
    ps:my phone is not rooted and i dont intend to just yet
  17. brammike

    brammike Lurker

    What APN settingd do you have for FIDO, I am completely pissed right now, no service other than wi-fi, please respond.

    Thanks Mike
  18. brammike

    brammike Lurker

    Please, what APN settings are you running?????
  19. bablu brar

    bablu brar Lurker

    this setting is work for fido sony ericsin xperia x10Name:

    Name: Fido Internet
    APN: internet.fido.ca
    Port: 8080
    Username: fido
    Password: fido
    Server: <blank>
    MMSC: http://mms.fido.ca
    MMS Proxy:
    MMS Port: <blank>
    MMS Protocol: Wap 2.0
    MCC: 302
    MNC: 370
    APN type: <blank>
  20. runlsd

    runlsd Newbie

    Thanks for the great information. APN settings worked on my unlocked HTC Desire (Telus) on Fido. But since this thread was made for HTC Hero, let me know if there's anything I should change.

    Great info!
  21. Xyro

    Xyro 4 8 15 16 23 42

    Nah, APN settings are universal :) Both phones do 2G<->H so the APN will do you just fine.
  22. i got an htc legend and set the settings to all the above and changed many times to match each example ....it shows the 3g symbol but when i try to use it it says 'THERE IS NO NETWORK CONNECTION RIGHT NOW' i have a data plan ...any help will be greatly appreciated.
  23. AM Radio

    AM Radio Lurker

    to the OP and all contributors: THANKS! been scouring the net looking for info and found this. using an HTC Desire on Fido, unlocked from Telus. i know this is a "Hero" thread, but it's really saved my bacon.

    unfortunately, i've got a glitch. everything is groovy until i have to enter/change the MNC setting. it defaults to 37. but when i try to the add a "0", the APN is erased IMMEDIATELY and i have to start again. i was able to get everything going both with and without the Proxy, Port, Username and Password filled in and leaving MNC at 37, but does anyone have this seemingly wonky behaviour?

    also with these settings, i get a "3G" indicator, but there is no juice when i fire up the browser. it takes a few seconds, and then the icon switches to an "H" and things start to move quite quickly. but after an operation (like say, if page finishes loading) then it drops back to "3G". is anyone getting a steady "H" indicator constantly?
  24. rainmon

    rainmon Lurker

    I have the same problem as well. It only started happening when I upgraded to 2.1. When I was on 1.5, MNC stayed at 370. I'm wondering if it has something to do with the OS or not. Does anyone out there have the same problem ? Also, I noticed that after I upgraded to 2.1, my SIM card no longer registers with Fido, it says Rogers Wireless and the roaming is always turned on. I read somewhere else that there is no fix for the Roaming yet but I'm wondering if I'll get charged or not. Any info regarding both of these is appreciated. Thanks in advance.
  25. tynalfred

    tynalfred Lurker

    hi, my hero is already unlocked, i had try all the setting that you posted, but i still can't get the 3g network. could you please help. thank you.

HTC Hero Forum

The HTC Hero release date was July 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7200A processor, and 1350mAh battery.

July 2009
Release Date

Share This Page