1. Download our Official Android App: Forums for Android!

Support SGS not detecting my SIM card

Discussion in 'Android Devices' started by djkiernan, Jun 12, 2011.

  1. djkiernan

    djkiernan Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    19
    Joined:
    Dec 23, 2010

    Dec 23, 2010
    19
    0
    15
    Hello,

    I have an odd problem with my Samsung Galaxy S... I bought it in January, put the GSM SIM card that I was using in my old cell and everything worked perfectly. Yesterday I turned the SGS off and then turned it on because it was not correctly reading mp3 files. Now the phone does not recognize my GSM SIM card and it only allows me to make emergency calls.

    Has anyone had a similar problem before and can help me?

    Thanks in advance!!!
     

    Advertisement

  2. Carldvs

    Carldvs Member
    Rank:
    None
    Points:
    16
    Posts:
    49
    Joined:
    Oct 14, 2010

    Oct 14, 2010
    49
    8
    16
    Chemical Engineer
    Wigan, UK
    Get a new sim card, that's normally the answer.
     
    djkiernan likes this.
  3. LennyBigFat

    LennyBigFat Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jun 21, 2011

    Jun 21, 2011
    2
    0
    5
    i have the same problem. i don't think its a sim issue, since i tried it in other cell phones. i think it's got something to do with RAM. not enough of it or something. because i get the sim working after reboot and a little jiggle on the sim, and then it sometimes works, and sometimes doesnt. the only pattern i got was when syncing with gmail, tweetdeck.... and similar.
     
  4. djkiernan

    djkiernan Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    19
    Joined:
    Dec 23, 2010

    Dec 23, 2010
    19
    0
    15
    Well, replacing the SIM solved the problem. LennyBigFat, my SIM also worked in other phones (less moderns than the SGS, like a Motorola V3) and finally it stopped working on any phone. I got a new one and now it's working fine.
     
  5. mari+anne

    mari+anne Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 1, 2011

    Sep 1, 2011
    1
    0
    5
    My Galaxy S does the same thing...I replaced the SIM once and then the next time I it happened just in the middle of using the phone I tried my SIM in another phone - worked. Another SIM in the Galaxy S - didn't work. I took the phone and the SIM to a T-mobile store and the girl put it in the phone and it worked...no new SIM, no problem. She said I probably put it in backwards even after I told her it stopped working in the middle of using it. Well, it just happened again. This time I took the SIM out several times, checked it again, and then again...restarted phone, and still no SIM! I am not touching it until I get to T-mobile. This is rediculous.
     

Share This Page

Loading...