1. Download our Official Android App: Forums for Android!

Support SGS2 - Android 4.0 - Battery not charging

Discussion in 'Android Devices' started by fonduekid, Mar 13, 2012.

  1. fonduekid

    fonduekid Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    70
    Joined:
    Mar 13, 2012

    Mar 13, 2012
    70
    1
    36
    Helsinki
    Hi People,

    My first post here. I upgraded my Samsung Galaxy S2 to Android 4.0 this morning (official release).

    I have noticed the batter is not charging anymore. Did I miss something like battery calibration or similar?

    My batter is stuck at 28% now and it doesn't charge though I see "Charging" when I plug in the AC adapter or the USB.

    Can someone please help me with this?

    Thanks a lot and cheers..
     

    Advertisement

  2. caloyzki

    caloyzki Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    327
    Joined:
    Feb 13, 2012

    Feb 13, 2012
    327
    11
    38
    i just updated too, from gingerbread 2.3.4 to ICS 4.0.3, but i noticed that my phone wont charge. anybody else experincing this kind of problem too?
     
  3. Shotgun84

    Shotgun84 Android Expert
    Rank:
     #72
    Points:
    413
    Posts:
    5,406
    Joined:
    May 30, 2011

    May 30, 2011
    5,406
    3,156
    413
    Whatever he said.
    Cambridgeshire, England
    Does your phone show that its charging when it's turned off. If it does charge it to 100% while off then unplug and remove the battery. Wait for a couple of minutes and then replace the battery and power back on. That should recalibrate your battery.
     
  4. fonduekid

    fonduekid Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    70
    Joined:
    Mar 13, 2012

    Mar 13, 2012
    70
    1
    36
    Helsinki
    I did this ^ ... and it works now, charging is fine. But I notice that it's a bit slower through USB, than before. But it works.

    And also, another option is to try a factory reset (remember to backup your data before you do it).

    Another thing I noticed is that the battery drains faster than before. I have the same settings (display, power saving, etc) as before, but still the battery drains faster.
     
  5. DagSigg

    DagSigg Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 14, 2012

    Mar 14, 2012
    1
    0
    5
    I had a similar experience, but it turned out that Media server uses 78% of battery usage!
    I can hardly charge fast enough, it took 4 hours from I was fully charged until I was down to 13%!
    Considering reset to factory settings and try again ...
     
  6. fonduekid

    fonduekid Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    70
    Joined:
    Mar 13, 2012

    Mar 13, 2012
    70
    1
    36
    Helsinki
    Well it doesn't drain so fast for me.. but still.. and yes, I have done the factory reset. Also, for me its the Android OS which is taking up much of the battery!!
     

Share This Page

Loading...