1. Download our Official Android App: Forums for Android!

Support SGS2 as a USB drive

Discussion in 'Android Devices' started by LeepyLee, Jul 26, 2011.

  1. LeepyLee

    LeepyLee Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    14
    Joined:
    Jul 26, 2011

    Jul 26, 2011
    14
    2
    16
    Can anyone point me in the right direction please, to make my GS2 appear as a removeable drive when I plug it into my PC?

    When I connect it at the moment it simply appears as a Camera and there are no files visible.

    What do I need to do on the phone to make it appear as a drive?

    My other phones just appear as drive K as soon as they are connected.

    Thanks,

    Lee
     

    Advertisement

  2. steslatt

    steslatt Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,145
    Joined:
    Jul 20, 2010

    Jul 20, 2010
    1,145
    303
    163
    Male
    Design Engineer
    Manchester
    Have you installed the drivers from kies?
     
  3. LeepyLee

    LeepyLee Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    14
    Joined:
    Jul 26, 2011

    Jul 26, 2011
    14
    2
    16
    Kies is installed on the home pc but not (and cannot be) on the work pc. But on the home pc, I can see the phone as a drive rather than a camera, but still can't see any individual picture files in the DCIM/Camera folder. I can however see dozens of .tec files in the DCIM/Camera/cache folder - whatever they are!

    Am I missing something - surely it can't be this difficult just to look at files on the phone or the 32G sd card?
     
  4. lotus49

    lotus49 Android Expert
    Rank:
    None
    Points:
    153
    Posts:
    1,513
    Joined:
    May 9, 2011

    May 9, 2011
    1,513
    232
    153
    Male
    Yorkshire
    Settings->Wireless and network->USB utilities->Connect storage to PC then (and not before) plug the USB cable in and confirm when the message comes up.

    That's all there is to it, no need for drivers.
     
    LeepyLee likes this.
  5. LeepyLee

    LeepyLee Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    14
    Joined:
    Jul 26, 2011

    Jul 26, 2011
    14
    2
    16
    Yep, that's it!

    Ta very much!
     
  6. Mutton

    Mutton Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jul 26, 2011

    Jul 26, 2011
    2
    0
    5
    I have two S2's - both give the same message when following the above steps:
    "Attention - USB is connected. Remove the cable"

    Neither phone is rooted.

    Most frustrating. I have over 800 contacts on the phone and would really like to backup onto the pc.
     
  7. lankunit

    lankunit Member
    Rank:
    None
    Points:
    16
    Posts:
    66
    Joined:
    Jul 15, 2011

    Jul 15, 2011
    66
    7
    16
    You do the steps before plugging in USB cable.
     
  8. lotus49

    lotus49 Android Expert
    Rank:
    None
    Points:
    153
    Posts:
    1,513
    Joined:
    May 9, 2011

    May 9, 2011
    1,513
    232
    153
    Male
    Yorkshire
    You ignored the part of my instructions that said "then (and not before) plug the USB cable in".
     

Share This Page

Loading...