1. Download our Official Android App: Forums for Android!

Support SGS2 cannot connect to wifi networks with hidden SSID

Discussion in 'Android Devices' started by _NiNJA_, Jul 2, 2011.

  1. _NiNJA_

    _NiNJA_ Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Jun 30, 2011

    Jun 30, 2011
    6
    0
    5
    Hello all,

    Just wondering whether anyone else has noticed or experienced this.

    I have a samsung galaxy S2 and if I try and connect to a wifi network which has a hidden SSID, putting in all the details manually on the phone of the wifi network, the phone will not connect to the wifi network.

    If I make my home network broadcast SSID, it will connect to the wifi network. It says connected and it remembers details etc.

    If I then turn wifi off on my GS2 .... turn my wifi network back to not broadcasting SSID ... and then turn wifi back on on my GS2 ... the phone doesnt find the network again.

    Surely the phone should:
    - Connect to wifi networks with hidden SSID's in the first place if all the details are typed in correctly via manual setup
    - Remember the details of any wifi network it conncted to and reconnect even if the wifi network is not broadcasting SSID

    Wifi network is running b/g/n with WPA/WPA2 PSK set.
     

    Advertisement

  2. Slug

    Slug Check six!
    Moderator
    Rank:
    None
    Points:
    2,043
    Posts:
    20,552
    Joined:
    Aug 1, 2009

    Aug 1, 2009
    20,552
    16,992
    2,043
    Male
    Mobile phone retail
    Inverness, UK
    Afaik this is a limitation of Android itself. None of my three handsets have ever connected to networks with hidden SSIDs.
     
  3. vwgolfman

    vwgolfman Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    81
    Joined:
    Nov 10, 2010

    Nov 10, 2010
    81
    3
    16
    I work away during the week and WiFi is available at my remote residents.
    The SSID is not broadcast and still I have no problems whatsoever connecting.

    So maybe you are just unlucky but I can tell you for certain that it is possible to connect to a router wirelessly which doesn't broadcast its SSID.
     
  4. _NiNJA_

    _NiNJA_ Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Jun 30, 2011

    Jun 30, 2011
    6
    0
    5
    What type of router are you using ... also whats your wireless setup:
    - Router brand/type --> eg Cisco xxxxDPQ3925 DOCSIS 3.0
    - Network mode --> b/g/n ... mixed etc
    - Wireless security mode --> WEP, WPA / WPA2 Personal etc
    - Encryption --> AES / TKIP + AES

    just wondering whether a particular setup works and others dont.

    My setup is:
    Cisco DPQ3925 DOCSIS 3.0
    b/g/n mixed
    WPA / WPA Personal
    TKIP + AES
     
  5. johnno51

    johnno51 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Nov 30, 2011

    Nov 30, 2011
    1
    0
    5
    Hi,

    Just as support, before i started messing with different roms and firmwares, i could still connect to hidden SSD's. in order to do this however, i would have to expose it the first time round, and once the phone had successfully connected turn of the broadcast feature in my router.
    From theat point, anytime it was in range, it would connect to the hidden SSID
     
  6. Beeblebrox

    Beeblebrox Newbie
    Rank:
    None
    Points:
    15
    Posts:
    25
    Joined:
    Nov 5, 2011

    Nov 5, 2011
    25
    0
    15
    Had same issue for a short period. Wifi Manager works fine, another good app for that is WiFi Advanced Config Editor. They both allow you to connect / configure settings for hidden WiFi networks.
     
  7. lamassu

    lamassu Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 9, 2012

    Mar 9, 2012
    1
    0
    5
    Hi.

    Im having similar problem with my sgs2.

    But as ive just found out the solution does not lay in AES encryption (at least for me). Its just absolutely ridiculous how it works and something is bugged but i cant tell what.

    My network set up atm:

    modem : Netgear DG834GT in Modem Mode.
    router: Netgear WRN2000
    wired workstations: 2 PC+ server + Xbox360
    Wireless Devices: IPad, Wii console, iPhone 3Gs, Galaxy Nexus and my sgs2

    ive got static IP pool network cause of server providing services to WAN. I just find it easier.
    The reason why i use GT834GT in modem mode is ive had identical problem with it as im having now with WRN2000 thinking that was routers fault and bought other one.

    My Problem is that sgs2 detects protected network, asks for password and tries to obtain IP from router. after few seconds goes to disabled, remembered and such. it only happens on my home network.
    my handset has set static IP number in advanced option in Wireless settings.
    Ive tried every combination of options possible: set network to unprotected, set dinamicaly assigned IP on phone while DHCP off (why do i need it?), on router and every time same story but what works for me is this:
    Start DHCP server on router.

    Then it doesn't matter if ive got static or dynamic IP on phone. It connects every time!
    just cause of that router can now produce conflict cause ive aleady ended up having two devices with identical IP. What drives me mad is why the heck sgs2 connects only by using DHCP when my girlfriends Nexus works flawlessly no matter what.

    If thats sgs2 software bug im getting icecream sandwitch when it becomes available.
     
  8. ktor09

    ktor09 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jun 27, 2012

    Jun 27, 2012
    1
    0
    5
    Hi all,

    I had similar problem, but resolved it by deleting all other saved wifi networks, after that my phone connects to hidden ssid without problems.

    hope that this will help you.
     
  9. kenmiddleton

    kenmiddleton Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Feb 2, 2014

    Feb 2, 2014
    1
    0
    5
    You can successfully connect to a wifi network with hidden SSID/SSID broadcast disabled.


    1. Select/tap & hold old record of wifi network
    2. Select Forget
    3. Create the same network with all access details manually.
    4. Mobile should now connect to hidden network successfully.
     
  10. marcus33

    marcus33 Member
    Rank:
    None
    Points:
    18
    Posts:
    73
    Joined:
    Jan 6, 2014

    Jan 6, 2014
    73
    18
    18
    Male
    Electrician (again!)
    Harrow (England)
    I was having problems with hidden SSID and also found this solution to work.

    I even set up a second BTHomeHub2 slaved to my main Router (also BTHH2) because I thought my low signal was the problem but I still had the same issue; even when holding my phone within 4 feet of the slave, it just wouldn't find it.

    Fiddled and fiddled until I found the above solution to work. Once it works the first time you should be able to connect as soon as you turn your phone's Wi-Fi on.
     

Share This Page

Loading...