1. Check out our companion app, Forums for Android! Download from Google Play

Should i take my phone back to Orange?

Discussion in 'Android Devices' started by Viney, Aug 27, 2010.

  1. Viney

    Viney Member
    Thread Starter
    5

    Aug 27, 2010
    6
    0
    5
    Basically, i have had this problem for a while now. I have an Orange branded Desire and i'm having problems with the mobile network.

    Getting to the point, sometimes the mobile network doesnt turn on even where theres signal (full bars).

    For example i will turn on the mobile network on (through settings) and then it will be working fine. Ill leave it on whilst at work, and then when i come back a couple of hours later, the 3G/ Edge (whatver) signal is off and the mobile network isnt on. Even when i try and turn it on it doesnt work, unless i go on to airplane mode and put it on through there or turn the whole phone off and put it back on.

    Sometimes ill leave the mobile network on throughout the whole day and it will still turn off by itself sometimes and then ill have to put it back on.

    Is it a common problem? If the 2.2 update fixes the problem then, im prepared to wait as i have already had my Desire exchanged before, because of dropping calls.

    I dont no if i should return it back to Orange. HELP!!!!!
     

    Advertisement

  2. master_yoda

    master_yoda Well-Known Member
    53

    Jun 17, 2010
    260
    50
    53
    United Kingdom
    Sadly its a fairly common problem on the Desire.

    Some people seem to get this problem a lot, some get it occasionally and many never experience it at all.

    Im on the 3 network using an unbranded Desire brought sim free and luckily I only had this problem happen a couple of times during the first 2 months I owned the handset, a quick toggle in and out of airplane mode fixed it, so since it was only happening about once per month it didnt bother me.

    For the record since updating to 2.2 at the start of this month I havnt experienced the problem yet.

    Some people found this helped when experiencing the problem regularly:


    Open the Phone dialer and type in *#*#4636#*#*

    Tap on Phone Information

    Scroll Down and set your Preferred Network Type to GSM auto (PRL) - NOTE this does not disable 3G or HSDPA! There will still be the 3G and H icons in your status bar.

    Goodluck!
     
  3. Sheshnag

    Sheshnag Well-Known Member
    56

    Apr 28, 2010
    233
    9
    56
    I have this problem. Happens every day when I switch from WiFi to 3g. Sometimes even switching the phone off and turning it back on does not work. The problem is in two folds. Desire is known to have this issue. No one is bothering to fix it. And also Orange has had lots of data signal issue recently.

    If you want to return the phone good luck as it is not very easy with Orange.
     
  4. Viney

    Viney Member
    Thread Starter
    5

    Aug 27, 2010
    6
    0
    5

    Tell me about it! Are Orange the stingyest company or what! Even though my phone was dropping calls, and there was hardcore proof of it doing so, i had to go back like 3 times after they reset the phone, and did something else to it. Eventually the manager decided to replace it because i only had it 4 a week!

    When my contract is over (16 months away), i may switch to 02 tbh.

    This mobile network problem is so annyoing!
     
  5. Viney

    Viney Member
    Thread Starter
    5

    Aug 27, 2010
    6
    0
    5
    Yeah i have tried what you said and i will see how it goes. What does that do exactly?
     
  6. TigerClaw

    TigerClaw Member
    5

    Aug 11, 2010
    6
    0
    5
    its a known issue,

    its caused by the phone not picking up that the wireless is turned off and that it should activate the mobile internet.

    i fix it by doing the following.

    disabled the mobile internet the buttons with the arrows on it -->
    <--

    then activate your wireless.

    turn off your wireless

    activate mobile internet.

    it should the pick up your 3G connection if theres on in the area
     
  7. Viney

    Viney Member
    Thread Starter
    5

    Aug 27, 2010
    6
    0
    5
    I'm a bit confused with ''buttons with the arrows on it''. Sorry just not that used to the Desire.

    Do i still need to do


    ''Open the Phone dialer and type in *#*#4636#*#*

    Tap on Phone Information

    Scroll Down and set your Preferred Network Type to GSM auto (PRL) - NOTE this does not disable 3G or HSDPA! There will still be the 3G and H icons in your status bar.''
    .....as one of the posters said?

    Ive changed it to GSM AUTO PRL
     
  8. NigelP

    NigelP Active Member
    36

    May 16, 2010
    30
    6
    36
    UK
    This also happens to me quite often on Orange. When I'm in range of my home WiFi everything is fine. If I'm sat at my desk at work, where there's no WiFi, sometimes the 3G signal wakes up, other times it doesn't and no matter how many times I pressed the WiFi on/off, Mobile 3G on/off or turning the phone on and off, removing the battery & SIM and turning it all on again, whilst this sometimes solved it, it was very hit and miss and was becoming a frustration.

    Having tried the trick to change it to GSM Auto (PRL) as mentioned in this thread (which I picked up from somewhere else), it's not happened once, so seems to fix it. As an added bonus (or maybe it's my imagination as others have also commented on it), the battery life seems to improve marginally.
     
  9. Viney

    Viney Member
    Thread Starter
    5

    Aug 27, 2010
    6
    0
    5
    Ill give that a try :D
     
  10. spenspuma

    spenspuma Well-Known Member
    38

    Sep 24, 2009
    224
    12
    38
  11. Viney

    Viney Member
    Thread Starter
    5

    Aug 27, 2010
    6
    0
    5
    Hmmm the same thing happened again at work. I am not sure if its my work place itself as i leave my Desire in my locker and the signal isnt always great there, and even when on the net, i only get Edge.

    I turned the 3G off when i got there to save battery, and about 2 hours later it didnt turn on, until after work when i went deep outside, and switched airplane mode on and off.

    I dont really want to take it back, to go through all that hassel, if its just a network problem...or could it be the sim-card?

    Maybe i should just leave the 3G on all the time.

    This is so annoying!
     
Tags:

Share This Page

Loading...