1. Are you ready for the Galaxy S20? Here is everything we know so far!

sideload wonder machine mac inspire 4g help

Discussion in 'Android Devices' started by sarstube, Feb 13, 2011.

  1. sarstube

    sarstube Member
    Thread Starter

    Ok i realize there is already a swm help, but mac with terminal is a whole other beast.

    so i've never done this before but i'm getting close to pulling my hair out. all i want is swype (damn you att for making me do this btw)

    i have the swm for mac from android central Sideload Wonder Machine for Linux & Mac! - Android Forums

    i have the phone on de-dug usb, stay awake, and disk drive is mounted. I have the sype installer.apk in the "app here folder"

    swm will not push the file because it won't recognize it. when i try to list the apps, it says there are none. when i try the "push to data.sh" it finds no file and it asks for a password.

    is there a complete step by step how to? do i need to change the script to specify the swype apk?

    on the download page it has a forum with lots of people saying the same thing but with no resolution, but lots of "ok, got to work" without explaining. it's been a frustrating day to say the least.

    any and all help will be welcomed.

    ps i even tried to use my gf's shitty celeron powered vista laptop. it won't even open up the swm zipped file! says it's "invalid" FFFFFFFFFFFUUUUUUUUUUUU
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Kalvus5

    Kalvus5 Newbie

    Same here, while the windows version simply just has you pick a file to download, the mac version is hard to understand. I'm also looking for swype and I'm not sure how to do it.
     
  3. sarstube

    sarstube Member
    Thread Starter

    Done and worked, here's a step by step guide to install swype:

    [Guide] Installing Swype Beta on HTC Inspire 4G - Android Forums

    theoretically this should work for anything else you want to side load, just replace "swype-installer.apk" with what ever your apk is called and stop after step 7.

    Thanks to skroll for setting it up
     
    Blanco720 and Faramir82 like this.
  4. Kalvus5

    Kalvus5 Newbie

    im sorry for the stupid question, but when i'm using terminal on mac and type in cd/path/to/directory it just says "no such file or directory" I continued to type the rest of the commands in thinking it might work, but it couldn't even locate any of the other commands. for instance it says for chmod + the same thing. Is there a specific spot i need to put the swm folder in to make it work? it's in applications right now (again, I'm coming from jailbreaking iphones where everything is straightforward)
     
  5. skroll

    skroll Lurker

    You need to substitute "/path/to/directory" with where you extracted the files.
     
    Kalvus5 and Faramir82 like this.
  6. sarstube

    sarstube Member
    Thread Starter


    like skroll said, he had to put that because each person's computer has a different path. the easiest way to find the path is to right click the swm install file and hit "get info" (this also works with any file)

    the path is what's listed after "where:" it usually starts with "/User/". it's just the listing of the various folders where your file is.

    so just replace that entire "/path/to/directory" with your path. remember to keep the "cd " in the front though. and hit enter after each command
     
    Kalvus5 likes this.
  7. Faramir82

    Faramir82 Newbie

    Thanks, this was so easy.
     
  8. sarstube

    sarstube Member
    Thread Starter


    i appreciate, but the thanks should go to skroll!
     
  9. Kalvus5

    Kalvus5 Newbie

    any tips to make it work for step 4? I put debugging mode on as well as charge only. I type in "./adb devices" and again it says "no such file or directory"
     
  10. sarstube

    sarstube Member
    Thread Starter

    can you copy and paste what youre inputting?
     
  11. kb58

    kb58 Well-Known Member

    Make real sure you aren't missing any spaces in the input string - makes all the difference.
     
  12. Kalvus5

    Kalvus5 Newbie

    ******-iMac:Downloads ********$ ./adb devices
    -bash: ./adb: No such file or directory
    ********-iMac:Downloads *******$ cd /Users/******/Downloads./adb devices
    -bash: cd: /Users/******/Downloads./adb: No such file or directory
    *******-iMac:Downloads *******$ cd /Users/******/Downloads ./adb devices
    *****-iMac:Downloads ******$

    trust me ive tried a buch of different ways to write it to make it work. The last one i thought it worked since it didnt get an error message, but no device appeared

    apparently the $ sign becomes a face lol
     
  13. sarstube

    sarstube Member
    Thread Starter

    Start terminal up from scratch and input "cd /Users/******/Downloads/swm-mac" then hit enter, then input "./adb devices"

    It needs the correct path to where the abd is inside the swm-mac folder.
     
  14. Kalvus5

    Kalvus5 Newbie

    well I got all the way to step 7. I downloaded it to my phone and when the download was complete I typed in what it says, "./adb install ./Swype-Installer.apk. It says that it can't find "Swype-installer.apk" heres the terminal entry:


    ******-iMac:swm-mac ********$ ./adb install ./Swype-Installer.apk
    can't find './Swype-Installer.apk' to install
     
  15. sarstube

    sarstube Member
    Thread Starter

    This may seem dumb but are you sure the apk is on your phone? Meaning to say you definitely saw the "you can't install because is not a market program" message? That's all I can think of right now.
     
  16. Kalvus5

    Kalvus5 Newbie

    yea, in my download history its there, "Swype-Installer.apk" and when I press it it says that its blocked and it gives you the choice of settings or cancel. I'm not sure what to do but it's fine, they'll be other ways along the road, you guys have helped me enough. For one last way, would completely redoing the process help or no?
     
  17. sarstube

    sarstube Member
    Thread Starter


    hmmm, let's back up to step six. after you type: "./adb pull /mnt/sdcard/download/Swype-Installer.apk ./Swype-Installer.apk" does it say how long it took and "success"?
     
  18. Kalvus5

    Kalvus5 Newbie

    it says:


    ******-iMac:swm-mac ********$ ./adb pull /mnt/sdcard/download/Swype-Installer.apk ./Swype-Isntaller.apk
    515 KB/s (77213 bytes in 0.146s)
     
  19. Kalvus5

    Kalvus5 Newbie

    thats it, it seemed like it finished so i just continued
     
Loading...

Share This Page

Loading...