1. Are you ready for the Galaxy S20? Here is everything we know so far!

sim card does not allow a connection to this network

Discussion in 'Android Devices' started by scorchia, May 24, 2010.

  1. scorchia

    scorchia Lurker
    Thread Starter

    Hi all,
    I have a problem with my Xperia X10 (i)
    I purchased it new, unlocked. It worked fine for a week or so, then I switched to another network operator that works on AWS/1700 Mhz/BandIV. The phone is supposed to work with this frequency as far as I understand. Now the issue I have is every time I loose the network signal (I park my car in the underground parking:)) & when I come back to the place where there is network signal my phone does not get the network back. I try to connect manually and I get the message: " your sim card does not allow a connection to this network". When I try to connect automatically it says "Registered on network" but there is no signal.
    I changed 3 sim cards so far. Still the same. When I put the sim card in another phone that also works with AWS/1700 Mhz/BandIV the other phone manages to find the signal. I put back the sim card in my Xperia, it works fine until for some reason I have no signal and the circle continues..:( I love my phone, I want it to work, with this provider.
    I am very annoyed. The network provider doesn't know what could it be, they blame the phone. But the phone works with other providers with no problem so I assume it is something else.
    I did a factory settings restore, I checked for updates..

    I want to fix it, this issue drives me crazy and I don't want to let it go, I want to FIX it.
    PLEASEEEEEEEEEEEEEEEEE HELP!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. gogsythreat

    gogsythreat Lurker

    scorchia did you ever get a solution to this. I have the same problem and cant get the phone to register with any provider.
     
  3. murphoster

    murphoster Lurker

    Hi, did either of you ever get a resolution to this? I've got it as well
     
  4. beau420

    beau420 Android Expert

    Who is your cell phone provider and where is your Xperia x10 from?

    Is it an x10a or x10i?

    Have you unlocked the phone? Where did you get it done?

    Are you able to make phone calls? Is it only data that isn't working?

    Have you set your MMS settings under: Settings->Wireless and Mobile->Mobile Networks->Access Point Names

    Do have have any APN's in there? Or is it blank?
     
  5. genna192003

    genna192003 Lurker

    hi I have the same problem... I bought an unlocked experia from amazon and my apn is blank... it works n then it kicks off the signal and gives me error code mm #3:mad: can someone please help me
     

Sony Ericsson Xperia X10 Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...