1. Download our Official Android App: Forums for Android!

Support Sim card not working-samsung galaxy s2

Discussion in 'Android Devices' started by ns800, Sep 20, 2011.

  1. ns800

    ns800 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Sep 19, 2011

    Sep 19, 2011
    2
    0
    5
    I bought the samsung galaxy s2, and ive had a couple of problems. One that started today, was after i charged it to 100% the phone vibrated to let me know that it had fully charged, but a couple seconds later, i had a notification to say sim card was not inserted. I have checked with my old phone to see if it was a problem with the sim card, but it worked fine ,so it must be the handset. Does anyone know why this is and how i can fix this problem. ive tried turning the phone off for an hour but no luck
     

    Advertisement

  2. cds0699

    cds0699 Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,545
    Joined:
    May 22, 2010

    May 22, 2010
    1,545
    347
    163
    Shenandoah Jct WV
    Hello there, welcome to AF. I moved your thread to the Samsung Galaxy S2 forum so that you can hopefully get some better help. I'm sorry I am unable to help, I'm from the USA on Sprint and no nothing about SIM cards.
     
  3. DIsLike

    DIsLike Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Oct 30, 2011

    Oct 30, 2011
    3
    0
    5
    Hey, I have the exact same problem! No solution! :(
     
  4. MaximoKnight

    MaximoKnight Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Nov 8, 2011

    Nov 8, 2011
    1
    0
    5
    I'm Having the exact same problem.. if anyone has any info on this it would be great to know. Thanx
     
  5. Oimie

    Oimie Newbie
    Rank:
    None
    Points:
    15
    Posts:
    23
    Joined:
    Oct 26, 2011

    Oct 26, 2011
    23
    0
    15
    Where do you live and what model do you have?
     
  6. aquanim

    aquanim Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Nov 9, 2011

    Nov 9, 2011
    4
    0
    5
    I have the exact same issue!!!!!!!!! EXTREMELY frustrating!
    I have done the following procedures:

    1. YES the SIM is inserted properly
    2. NO i do not have problems with the SIM card holder
    3. FLIGHT MODE CANNOT be deactivated it is grayed out
    4. YES i did a factory reset
    5. YES i did a cache wipe out just in case
    6. YES the SIM card is working just fine on another phone

    SIM card still cannot be recognized by the phone

    Does anyone have a a solution :(
     
  7. ironass

    ironass Android Expert
    Rank:
     #19
    Points:
    1,343
    Posts:
    11,397
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    11,397
    5,596
    1,343
    Male
    Keeping one step ahead of the Tax man
    Cotswolds, England
    It seems that no-one posts twice on this thread, or answers questions.

    The reasons the sim card is not working in a phone, and yet works in others, are:-

    1. The phone is locked to an operator other than the one on your sim card.

    2. The phone is on an unpaid contract and has been blocked by the operator.

    3. The phone has been reported stolen and has been blocked by the operator/owner/police.

    Solutions.

    1. If you bought your phone through a legitimate vendor, a phone operator or shop, then return the phone under warranty and seek their advice.

    2. You can check if the handset is blocked, for a small fee, here:-

    CheckMEND Country Selection

    Hope this helps. :D
     
  8. aquanim

    aquanim Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Nov 9, 2011

    Nov 9, 2011
    4
    0
    5
    1. The Phone and the SIM card belong to the same operator
    2. The phone is on a two year contract all bills have been paid so far
    3. The Phone is sold by the operator.
    4. IF the phone/SIM was one of the above at least it would be able to dial 112 (EU for 911).

    I wanted to fix the issue and avoid returning the phone and not using it for 30 days.
    But unfortunately it appears that that would be my only option:(
     
  9. ironass

    ironass Android Expert
    Rank:
     #19
    Points:
    1,343
    Posts:
    11,397
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    11,397
    5,596
    1,343
    Male
    Keeping one step ahead of the Tax man
    Cotswolds, England
    OK... given the above, you could try...

    Settings > Privacy > Factory data reset

    to see if this resolves your issue. This will in effect, turn the phone back to the out-of-the-box condition and allow you to put in the sim card again to see if it will recognise it.
     
  10. aquanim

    aquanim Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Nov 9, 2011

    Nov 9, 2011
    4
    0
    5
    1. YES the SIM is inserted properly
    2. NO i do not have problems with the SIM card holder
    3. FLIGHT MODE CANNOT be deactivated it is grayed out
    4. YES i did a factory reset
    5. YES i did a cache wipe out just in case
    6. YES the SIM card is working just fine on another phone
     
  11. aquanim

    aquanim Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Nov 9, 2011

    Nov 9, 2011
    4
    0
    5
    In most cases i try all steps prior to posting anywhere anything but this case....... i have no idea ..........
     
  12. Russell Ng

    Russell Ng Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,384
    Joined:
    Sep 29, 2011

    Sep 29, 2011
    1,384
    166
    143
    Male
    Engineer
    Kuala Lumpur
    After doing factory reset still cannot work? I hate doing factory reset. I remember I upgraded the firmware once and I just wanted to wipe cache and end up doing it wrong. I had to restart from scratch including signing in with google again.

    I can't recall what happen with the sim card, but I think you had to log into the phone before being able to read the sim card again. Anyway, just bring it back to the service provider. They have to solve it since its an unreadable sim issue.
     
  13. Zeeshi

    Zeeshi Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Dec 2, 2011

    Dec 2, 2011
    2
    0
    5
    I have the same problem. My sim card was working fine for more than 4 months and then suddenly sgs2 is not detecting any sim card anymore. I have tried changing all settings + factory resets and everything. The only solution is to claim the warranty and get a new phone.
    Don't try Samsung support they are pathetic. ;)
     
  14. simrebel

    simrebel Newbie
    Rank:
    None
    Points:
    15
    Posts:
    13
    Joined:
    Oct 1, 2010

    Oct 1, 2010
    13
    0
    15
    Computer tech
    I had a similar problem , the sdcard was working fine for months then started acting up
    once in awhile saying i the card wasnt inserted
    bought a new 32g class 10 card, old card was a 4g class 4
    had problems copied data off old card, so far new card is working great
     
  15. Barry24

    Barry24 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Mar 4, 2013

    Mar 4, 2013
    5
    0
    5





    Hi all. I am having the same issue as "aquanim" (quoted above). Any update on this problem? All help much appreciated!
     
  16. kelis32

    kelis32 Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    303
    Joined:
    Dec 25, 2012

    Dec 25, 2012
    303
    64
    53
    Male
    UK

    Check out your settings in about phone, confirm your baseband is showing and then in status that your IMEI is present

    Also confirm your network status
     
  17. Barry24

    Barry24 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Mar 4, 2013

    Mar 4, 2013
    5
    0
    5



    Hi kelis. Thanks for the quick response.

    "Baseband version" is listed as "Unknown". "IMEI" is also "Unknown".

    "Network" is "Unknown", as is "Mobile network type".
     
  18. kelis32

    kelis32 Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    303
    Joined:
    Dec 25, 2012

    Dec 25, 2012
    303
    64
    53
    Male
    UK

    Is your phone rooted ?
     
  19. Barry24

    Barry24 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Mar 4, 2013

    Mar 4, 2013
    5
    0
    5
    hi again.

    how do i check if its rooted. i can't see any indication whether it is or isn't
     
  20. kelis32

    kelis32 Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    303
    Joined:
    Dec 25, 2012

    Dec 25, 2012
    303
    64
    53
    Male
    UK

    Get rootchecker from the play store

    Its more than likely you are not rooted or you would know

    What firmware are you on ? I think you will need to root your phone and then there is an App you can try out that may help you

    Cheers
     
  21. Barry24

    Barry24 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Mar 4, 2013

    Mar 4, 2013
    5
    0
    5
    hi,

    no, looks like Im not rooted according to the app.
    how do i get it rooted?

    my firmware is gingerbread.xwki8. or is this what you class as firmware?

    cheers
     
  22. kelis32

    kelis32 Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    303
    Joined:
    Dec 25, 2012

    Dec 25, 2012
    303
    64
    53
    Male
    UK

    Hello

    So to sum up, it looks like your EFS is corrupt, based on what you have said you are on Gingerbread 2.3.5 and you Network is 3 UK, can you confirm this

    The first step should be to upgrade to the latest official release for your carrier as this can on occasion rebuild your EFS, please confirm your network so we can point you in the direction of the correct files.

    Meanwhile do a search for and download ODIN, install it on your PC and ensure you have the Samsung USB drivers installed, if you have installed KIES they will be on there, i would also recommend backing up all your data as a failsafe

    Cheers
     
  23. Barry24

    Barry24 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Mar 4, 2013

    Mar 4, 2013
    5
    0
    5



    hi kelis,

    thanks again for your help. so my network carrier is Meteor Ireland. how do i establish what their latest official release is?
     
  24. kelis32

    kelis32 Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    303
    Joined:
    Dec 25, 2012

    Dec 25, 2012
    303
    64
    53
    Male
    UK

    Hello


    First download this firmware

    Hotfile.com: One click file hosting: I9100XWLPW_I9100METLPA_MET.zip

    This is the latest for your Network

    Then follow these instructions

    How to install Ice Cream Sandwich on your Samsung Galaxy S2 | Reviews | CNET UK

    You dont need to get the firmware from this site as yours in the link provided, however everything else will be the same.

    If you have any issues then ask befre you proceed
     
  25. alilitv

    alilitv Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Dec 27, 2013

    Dec 27, 2013
    4
    0
    5

Share This Page

Loading...