1. Are you ready for the Galaxy S20? Here is everything we know so far!

Simple steps to make adfree work?

Discussion in 'Android Devices' started by mahers, Feb 9, 2011.

  1. mahers

    mahers Android Expert
    Thread Starter

    Ok, so I finally took the plunge and rooted my phone this past weekend solely to get rid of the freaking ads on the games my kids play. I can't tell you how frustrating it is for them to keep hitting the ads, opening the market and buying stuff I don't want or need. I know the developers get paid for the clicks and need to make money somehow, but I would gladly buy an ad-free version if they had one, but they don't!

    Anyway, I need someone to help me get adfree to work. I looked over in xda and the steps there are not too easy for a newb rooter like me. I have never rooted a phone before, and need simple, basic steps. I've searched the forums, but didn't find anything I could use. Pretend you are dealing with my kids ;)

    I have a stock themed X, running 2.2.1, version 2.3.340, with LPP.
    I've downloaded the following apps, but if I missed any, feel free to educate me, please:
    adfree
    ES File Explorer
    Cach Cleaner NG
    Terminal Emulator
    DroCap
     



    1. Download the Forums for Android™ app!


      Download

       
  2. VoidedSaint

    VoidedSaint Resident Ninja

    you should just open it and it will start to search to make sure its up to date, i never had to do anything except install it from the market and that was it, once it was installed i never had to touch it
     
  3. Riverman

    Riverman Well-Known Member

    Me too. I just installed it, opened it, and it worked.
     
  4. Steven58

    Moderator

  5. mahers

    mahers Android Expert
    Thread Starter

    Thanks to those that have answered above, but I am rooted for sure (used z4, Stephen!) and I know I am rooted because I can now use DroCap and get into Superser. I tried to update adfree, tried to delete it and reinstall it, rebooted, cleaned my caches several times (after opening adfree, it tells me I should be clean of ads but that I may want to clear out my DNS cache just in case - but I have no idea what that is specifically, so I used Cache Cleaner NG to take care of the phone and SD caches). What the hell am I missing???
     
  6. dragonbro

    dragonbro Android Enthusiast

    I just downloaded it from the market, opened it, clicked on the download updates (or whatever the top button said) and it is working perfectly. No more ads in Homerun Battle!
     
  7. mahers

    mahers Android Expert
    Thread Starter

    Dammit! Why won't it work on mine?!?!?!? :mad:
     
  8. Fabolous

    Fabolous Superuser

    In your terminal emulator, type the following:

    su
    cat /system/etc/hosts

    Does it list a whole bunch of IP addresses, or just 127.0.0.1 ?

    If it's the former, it worked. If it's the latter, it didn't.
     
  9. xliderider

    xliderider Android Expert

    I've found that the Adblocker in Jrummy's Droid X/2 Overclock app works when AdFree doesn't.
     
  10. mahers

    mahers Android Expert
    Thread Starter

    Well, I can tell you it didn't work because I still see ads everywhere, but i tried your suggestion, and as expected, I saw the latter. :(

    Other that installing the app, updating it, and running it, it doens't seem like there's a specail trick to this. I just don't get why it isn't working for me. ARGH!
     
  11. mahers

    mahers Android Expert
    Thread Starter

    Do I need to install that ROM, or can I just get Adblocker by itself? Where do I get it? Remember, you're dealing with a dummy here!:eek:
     
  12. Fabolous

    Fabolous Superuser

    You may want to go into your superuser app and find the entry for address and delete it. Then, when you run adfree again, it will request root again.

    Sometimes the permissions get screwed up and you have to fix them manually this way.
     
    mahers likes this.
  13. xliderider

    xliderider Android Expert

    No rom, just the Droid X/2 overclock app. Jrummy's adblocker is also included in the Liberty toolbox.
     
  14. mahers

    mahers Android Expert
    Thread Starter

    You guys are killing me. I don't doubt either one of these ways will do the trick, but I have no idea HOW to do them. HELP PLEASE! Baby steps...
     
  15. Steven58

    Moderator

    Follow Faboulos' advice. He's a mega-expert. If you don't understand it, please ask for ask for specific clarification. His advice seemed easy enough, but if you don't understand it, you don't understand it. Please let me know.
     
  16. mahers

    mahers Android Expert
    Thread Starter

    Ok. I don't understand it. Specifically, this part, "find the entry for address and delete it."

    I know how to get into the SU app, but no idea what to do once I am in it. I know Fab is rad, but I'm a dunce. Excuse the ignorance.
     
  17. Steven58

    Moderator

    Don't put yourself down. We were all newbies once, bro.

    Go into SuperUser, AdFree will be your first item. Select it, then when the dialog box shows up, select "forget". That's it.

    If it were me, I'd then uninstall AdFree, then reinstall it, just for kicks.

    After you re-install it, then open it up and you'll be asked to give it root permissions via dialog box. Allow it. You should be set.

    Steven
     
    mahers likes this.
  18. mahers

    mahers Android Expert
    Thread Starter

    Steven, I've tried that. It didn't work. That's not exactly how I interpreted Fabolous' instructions.

    He wrote, "You may want to go into your superuser app and find the entry for address and delete it. Then, when you run adfree again, it will request root again." That leads me to believe I need to use SU to get into adfree and erase an address (I assume it's an ip address, since that's what the app blocks), but I may be mistaken.

    And you're right. There's a first time for everything. I was able to hack into my old dumbphone for stuff, which scared me at first, but I got the hang of it. I think I recall your dipping your toes into the root pool, but now you are like a grizzled veteran. Us rooks need some patience, you understand. ;)
     
  19. Trooper

    Trooper Android Expert

    Hey mahers sorry I have not gotten back to you. Been a busy week.

    What Fab is suggesting is what I told you to do via PM the other day. Its still not working for you? Are you positive that you have root access?
     
    mahers likes this.
  20. mahers

    mahers Android Expert
    Thread Starter

    Trooper, I am rooted. LOL! While it may not seem so, I wouldn't be able to get into SU if I wasn't, plus I can download and use some other root only apps. I'm going to try again. I'll report back in a few.
     
  21. TheKirch

    TheKirch Newbie

    Would an app killer be the problem? Just a suggestion...
     
  22. BimmerM3

    BimmerM3 Member

    I also found that this option works fine, it seems easier than everything else your trying. Just download the app from the market and configure it to block ads... Sorry if im only adding to the confusion though!
     
  23. mahers

    mahers Android Expert
    Thread Starter

    Ok, so here is what I did (for the third time, mind you)
    Uninstalled adfree
    Cleared my caches
    Rebooted
    Went to the market and DL'ed adfree again
    Reinstalled it
    IT FREAKING WORKS!!!!!!!!!!

    The only thing I did differently, was NOT check the second box (symlink from /data/data/hosts). I did check the auto update daily option. I guess I should not have messed with that 2nd box...hell, I don't even know what it means!

    Anyway, thanks to everyone who threw out ideas. I was really getting annoyed. Now I can focus my attention on the fun stuff like roms and themes!! :)
     
    Trooper likes this.
  24. Trooper

    Trooper Android Expert

    Awesome so glad you got it working!!!!!!! :D
     
  25. xliderider

    xliderider Android Expert

    I had trouble getting Adfree to work on my wife's Fascinate.

    What I ended up doing was I copied the Hosts file in my Droid X System/Etc folder and overwrote the Hosts file in her Fascinate's System/Etc folder. Rebooted her phone and opened AdFree. Selected Check for Updates and a pop-up window said something like updates were found and would I like to apply them, I selected Yes and everything is working great.
     

Motorola Droid X Forum

The Motorola Droid X release date was July 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, TI OMAP3630 processor, and 1540mAh battery.

July 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...