1. Are you ready for the Galaxy S20? Here is everything we know so far!

Since 2.3.6 Google Maps & Navigation don't work

Discussion in 'Android Devices' started by Berekona, Dec 26, 2011.

  1. Berekona

    Berekona Lurker
    Thread Starter

    Since the update to 2.3.6 my Galaxy S2 can not lock onto GPS, keeps saying GPS signal lost. Now Previous on 2.3.4 it was flawless. I've only had this phone for a month and NEVER had a problem. Is anyone else having a problem? Any recommendations? Should I roll back to 2.3.4?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. rmreid

    rmreid Android Enthusiast

    Wish I could help but I am not having any GPS issues, good luck
     
  3. Berekona

    Berekona Lurker
    Thread Starter

    Well I tried something I powered off my phone, removed the case and re-powered the phone back on and so far it seems to work again.
     
  4. rmreid

    rmreid Android Enthusiast

    I believe I have read some threads where users stated that when using a metal case that the GPS signal was lower or nno exsistent, not sure if you had a metal case or not but either way glad to see your issue was fixed.
    I have a silicone type case and have no issues
     
  5. I was having issues before the update where I was getting the message "Searching for GPS" for 30 to 60 minutes before it found my location. I downloaded GPS Status app from the market and seems to fix my issue was able to find the GPS location finally. It may fix your issue.
     
  6. ilordvader

    ilordvader Well-Known Member

    After we do Hard Reset

    do we need to manually update software

    & any must do Setting for fresh phone :)

    Thanks
     
  7. nhradiotech

    nhradiotech Newbie

    Try this it worked for me.

    Go to the phone dialer and dial *#1575# go to option 2 Change CP status
    Select control pane disable
    Reboot.

    Worked for me.
     
  8. rpod

    rpod Lurker

    I have not been able to get a proper GPS signal lock since the update either. I will try nhradiotech's suggestion and report back.
     
  9. (G)

    (G) Android Expert

    Since 2.3.6 I had the phone not find the GPS signal twice. After about 2 minutes, I turned the phone off and re-started it. That seemed to fix it right away.

    However, I've used it a dozen other times with 2.3.6 loaded, and it locks on to the satellites within 30 seconds.
     
  10. fldude99

    fldude99 Android Expert

    Does anyone know how to get into "angry gps"? It usually #*#*3214789650*#*# on GB.

    Btw, be careful with GPS status. It's a known battery killer.
     

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...