Nov 7, 2009
On both my wifes droid and mine, Slacker will not change stations. i.e. if you go back to the station lists and select another station, it will just put you back to the last station you were listening to. I powered up/down my phone and that worked only once (it worked for the first station change, then same old routine). I also un/reinstalled and that did not work either. We have not received 2.0.1 yet and have not force installed it. We installed a Slacker update the other day...maybe that did it?
Anybody else seeing this issue at all/since the Slacker update? Any known fix? thanks.
I did run into this last night, but I was driving and only had a few moments to test while at a stop light before the light changed. I forgot all about it after that until I saw this post. I'll mess with it a bit more and see if I can recreate and/or fix it.

Did some testing and it's still doing it. I tested with a couple stations just to be sure it wasn't my Indie Chill station that was doing it. It seems that closing out of the program alone is not enough to switch stations. You have to kill the Slacker process running in the background and then the next time you load Slacker you can choose a new station...but it gets stuck on that one now. Since I first encountered the bug last night, I did a factory reset (for an unrelated contact glitch) and the Slacker bug persists after that. I also uninstalled/reinstalled and it didn't fix the bug, so it seems like the last patch did this. Going to follow up with their online support and see if I can get it fixed.
So, my wife found a solution. You can't just back out to the station list...you need to hit the menu button, then select your station and it will change. But still, I used to be able to just pause my station (or not), back up once or twice, then select a new station...the update killed that. Also, when you open slacker again and it directs you to the station list, you still need to hit menu-->stations for it to change. It won't if you just select from the sation list right after it opens during start up.
Heh, I just found the same workaround and was coming here to post. I submitted a ticket and they responded asking for me to upload the logs so they could troubleshoot further. Hopefully they'll fix the back button thing eventually though.