1. Are you ready for the Galaxy S20? Here is everything we know so far!

Sleep function after 30 secs, cannot be changed anymore?

Discussion in 'Android Devices' started by amazijn, May 25, 2020.

  1. amazijn

    amazijn Newbie
    Thread Starter

    I had put the setting for 'Display-Sleep' to 5 minutes and all worked well so far.
    Since yesterday my Huawei Mate 10 Pro goes to sleep after 30 seconds and I cannot change it anymore in the settings...
    How come this got changed and what to do about it? I hate it going to sleep so fast, I constantly have to revive it when chatting! Not nice Screenshot_20200525_161452_com.android.settings.jpg

     


  2. Best Answer:
    Post #3 by puppykickr, May 25, 2020 (2 points)

    1. Download the Forums for Android™ app!


      Download

       
  3. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    weird have you tried a simple reboot? maybe try putting the phone in safe mode. this will determine if an app is causing the issue. if it is still happening in safe mode, then the only thing i can think of is to do a factory reset.
     
    MrJavi likes this.
  4. puppykickr

    puppykickr Android Expert

    From the pic, you have it set for power saving mode.

    Notice how the sleep settings are greyed out?

    Turn off power saving mode, then go back and look again.

    On mine, if I enable power saver, the sleep setting gets changed, so I have to go back and reset it again.

    To be honest, that issue and the idea that I don't notice much power saving in power saving mode, pretty much keeps me from using power saving mode at all.

    Just putting my device into airpmane mode saves the most power, and I just turn that off to use the device.
     
    amazijn and Dannydet like this.
  5. amazijn

    amazijn Newbie
    Thread Starter

    Puppykickr, you saved my day!
    It was indeed this power saving mode that prevented me from changing the 'sleep' time back to 10 mins!
    Once I changed that, it even automatically gave me my 10 mins sleep time back...
    Now, if only I knew how I switched on the power saving mode... I guess it was when the phone told me the battery was getting low and that it offered to switch on this power saving mode, it is not something I would deliberately do myself.
    Anyway, you are an angel, thank you very much!
     
    puppykickr likes this.
  6. amazijn

    amazijn Newbie
    Thread Starter

    Hi ocnbrze (how do you pronounce your name? LOL), I had rebooted already twice but that did not seem to make much difference.
    But as Puppykickr said, it had to do with the power saving mode on. Once I switched that off, my problem disappeared also!
    Thanks for trying to help anyway, I appreciate it very much!
     
  7. puppykickr

    puppykickr Android Expert

    On some (all of mine, anyway) devices, there is a setting somewhere in the Battery section of Settings that allows the user to allow the power saver mode to automatically engage at a certain battery level, like 15% or thereabout.

    This (on mine) automatically is disabled when the device is connected to a charger, so in that case the setting would be off- but when off the charger the setting will be on.

    This can also cause confusion.

    Glad to have been of some help.
     
    amazijn likes this.
  8. amazijn

    amazijn Newbie
    Thread Starter

    I could not find that particular setting... But good to know, thank you!
     

Huawei Mate 10 Pro Forum

The Huawei Mate 10 Pro release date was November 2017. Features and Specs include a 6.0" inch screen, 20MP camera, 4/6GB RAM, HiSilicon Kirin 970 processor, and 4000mAh battery.

November 2017
Release Date
0
Reviews
Loading...

Share This Page

Loading...