1. Download our Official Android App: Forums for Android!

Support Slow download speeds from FIOS Actiontec Router - solved

Discussion in 'Android Devices' started by dhubba, Jul 11, 2010.

  1. dhubba

    dhubba Newbie
    Thread Starter
    Apr 14, 2010

    Apr 14, 2010
    Here's kind of a subtle issue I've been trying to troubleshoot for the past few days -- just got it figured out and thought I'd post it in case someone else is dealing with it.

    I've been able to connect to my home network from the Moment to my WiFi since purchasing the phone in February. Of course I've had the CDMA lockup issues but WiFi is still usable if you employ a couple of workarounds. Anyway, everything was fine until my Verizon router failed a couple of weeks ago. After Verizon sent me a new modem/router (Actiontec MI424WR) I reset all the wireless security settings and all devices that I'd previously had connected to the router (three PCs, AppleTV, network bridge) were working fine -- except for the Moment.

    The Moment would connect to the router and obtain an IP address but the download speeds were slower than what I received over 3G. Finally after a few minutes the Moment and the router would disconnect from each other. Today I finally figured out the problem -- or at least a fix.

    The router was set to accept 802.11g/b connections. Once I configured it to accept 802.11g only, the Moment worked well again and I was able to see download speeds I'd expect from WiFi.

    I don't know if this is a Moment problem or a Actiontec problem -- just hope this helps someone else who might be experiencing this.

    Now...if Sprint would fix the airplane mode / CDMA lockup problem...



Samsung Moment

The Samsung Moment was one of the first Android Phones with a slideout keyboard.

Share This Page