1. Are you ready for the Galaxy S20? Here is everything we know so far!

Smartphone hotspot is connected & secured but no internet access on laptop ?

Discussion in 'Android Apps & Games' started by Wax Bean Tycoon, Jan 31, 2022.

  1. Wax Bean Tycoon

    Thread Starter

    So I used to be able to easily use my Motorola Moto e6 (XT2005DL) smartphone as a hotspot for my Windows 10 Dell Inspiron 5502 Laptop. Last time I tried this was, maybe, 2 months ago or so.

    Now, I can "connect" the hotspot, but there is no internet access. Windows 10 network shows "connected,secured", but I simply can't access any website.

    Before you ask......Yes, the mobile data is turned on ;)

    Back when the hotspot was working properly, I had Mcafee antivirus installed on Laptop. Now I have Webroot SecureAnywhere. So, I assumed Webroot was blocking something.

    However, I tried turning off the Webroot "Realtime Shield, Web Shield, and Firewall" protection, and I still can't access internet.

    I uninstalled Webroot. Still no good. "Connected, Secured" to the hotspot, but can't access any website via Firefox and Microsoft Edge browsers.

    I turned off Windows Defender Firewall. Still no good.

    I tried "forgetting" the Smartphone hotspot network on the Laptop, and re-connecting again. No good.

    Weird thing is, the browsers don't "time out" while trying to access a website, they just sit there forever, trying to access. Firefox might show a "performing a TLS handshake to browser xxxx forever.

    I had Avira security app on the phone, which I uninstalled, but still same result.

    Weird. I tried searching at length online before posting here. But I'm out of ideas.

    thanks in advance

    #1 Wax Bean Tycoon, Jan 31, 2022
    Last edited: Jan 31, 2022

    1. Download the Forums for Android™ app!


  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    who is your service provider? are u sure you have a plan that includes hotspot?
  3. mikedt

    mikedt 你好

    If you're in the US, check if your carrier actually allows tethering
  4. Wax Bean Tycoon

    Thread Starter

    It's a Tracfone using Verizon cell service. Yes it allows Hotspot ability.

    I've used this phone as a hotspot many times. Nothing has changed (except now computer has Webroot antivirus instead of Mcafee). But I have established the anti virus isn't the culprit, so I'm stumped.

    There must have been some "update" to Windows 10 or Android which is causing issues.

    I am about to try linking while the laptop is in safe mode, let's see what happens.
  5. Wax Bean Tycoon

    Thread Starter

    Well, that didn't work, I couldn't figure out how to access the hotspot while laptop was in safemode.

    Anyway, I tried connecting my old tablet......ACER model B3-A30 running Android 6.0, to the Moto e6 hotspot.
    It connected, but similar to my laptop and desktop computers, didn't give me internet access.

    Below are two screenshots.
    FIRST IMAGE: is while the tablet is connected to the Moto e6 hotspot.

    SECOND IMAGE: While there is no connection.

    Notice in the first image, the tablet is simply indicating this site can't be reached, yet in the second image, while no connection at all, it indicates no internet

    It's as if the computers and the tablet connected to the hotspot 'sense' the internet connection, but something is preventing actual internet access.

  6. Wax Bean Tycoon

    Thread Starter

    So, I established that yes, my laptop THINKS it is connected to the internet, during the hotspot connection to my Moto e6 phone. (see IMAGE)

    Of course, there really is NOT any connection. No internet data is flowing. can't access anything via internet.

    There must have been some update to Android, or some app. Some network security setting has been altered. WTF?

    I can't figure this out.

    motoe6 connection.jpg
  7. Dannydet

    Dannydet Extreme Android User

    Are you running a VPN or ad blocker
    GameTheory likes this.
  8. Wax Bean Tycoon

    Thread Starter

    I am not running a VPN on any device. I run an adblocker on Firefox browser (Laptop). Not on Microsoft Edge browser, but I've always had this ad blocker active when the hotspot worked properly.

    Also, my Tablet doesn't have an ad blocker, and the tablet is acting the same say as my Laptop and Desktop computers.

    I've gotta believe it's the smartphone. Some setting must have been changed, updated etc.
    It's so weird that the computer 'thinks' it's connected to the internet, but I can't access the internet LOL. Why doesn't Windows 10 explain to me what the heck the problem is?

    when I do a 'troubleshoot problems', it doesn't find any.
  9. mikedt

    mikedt 你好

    One thing you could try is pinging a server see if that responds. Open up a command line, and type e.g. "ping www.microsoft.com", and see if anything comes back.

    If ping works you should see something like this:
    PING e13678.ca2.s.tl88.net ( 56 data bytes
    64 bytes from icmp_seq=0 ttl=55 time=10.745 ms
    64 bytes from icmp_seq=1 ttl=55 time=11.986 ms
    64 bytes from icmp_seq=2 ttl=55 time=8.444 ms
    #9 mikedt, Feb 1, 2022
    Last edited: Feb 1, 2022
  10. Wax Bean Tycoon

    Thread Starter

    Hi thanks for the response.

    I tried ping www.microsoft.com on the command line (run as administrator).

    All I got was "request timed out" 4 times. o_O
  11. Wax Bean Tycoon

    Thread Starter

    I also tried linking my hotspot smartphone to my laptop via "USB tethering". Once again, the network status on Windows 10 says "you're connected to the internet" but it's false. I am not.

    IMAGE 1 BELOW: Shows Network status, when laptop connected to smartphone via USB tethering, and Mobile Data turned ON the phone
    IMAGE 2 BELOW: Shows Network status after turning OFF mobile data on phone. The Laptop clearly "senses" internet connection, but is not allowed to "reach out" and access the internet. What the heck????

    #11 Wax Bean Tycoon, Feb 1, 2022
    Last edited: Feb 1, 2022
  12. mikedt

    mikedt 你好

    Try a traceroute, that might give an indicator where the stoppage is. Think the command for Windows command line is "tracert www.type-website-here.com, and on *NIX systems it's "traceroute www.www.type-website-here.com".

    Should see something like this, although I'm using MacOS, which is a UNIX system.

    " * * * " means a node didn't respond.
    #12 mikedt, Feb 1, 2022
    Last edited: Feb 1, 2022
    Deleted User and Dannydet like this.
  13. Wax Bean Tycoon

    Thread Starter

    thanks for the reply, and all your time on this thread issue.

    I've given up on this problem, I guess it's one of those mysteries that will go unsolved. Too bad because I will be needing a hotspot for my lap top soon.

    I ran a tracert and got a few lines of long ip address attempts, followed by "request timed out" entries.

    I could try calling Tracfone, and see if there was something changed to the verizon service for hotspots, but that will be useless I'm sure.

    thanks again, but I shouldn't have to jump through so many hoops to fix this problem. Hotspot was working great 2 months ago. Maybe a hardware problem with the Motorola Moto e6 phone.
    James_Watson and Dannydet like this.
  14. Reed Howe

    Reed Howe Lurker

    Here is a virtually zero cost option which worked for me in (somewhat) different circumstances.
    "Forget" the connection to your hotspot. And then reconnect.

  15. Wax Bean Tycoon

    Thread Starter

    Hello Reed,

    Yeah, I already tried that unfortunately. I briefly mentioned it in my original post.

    I keep thinking something has changed with the hotspot service. Weird though, that all 3 devices (laptop, desktop and tablet) say they are connected to the internet (via smarphone hotspot) but they won't have any internet capabilities. Very strange.

Share This Page