1. Download our Official Android App: Forums for Android!

Support SMS contacts autocomplete fills in email address

Discussion in 'Android Devices' started by zygomorph, Jun 30, 2012.

  1. zygomorph

    zygomorph Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    11
    Joined:
    Apr 4, 2012

    Apr 4, 2012
    11
    1
    16
    I use gmail and have my contacts synced with gmail, so for many of my friends I have both their name and their email address on my phone. These are under the same contact--that is, if I look under contacts either on my phone or on a PC in my gmail account, a person's phone number and the email address are listed under the same name. I don't have a person's name twice in contacts (once with their name and once with their email) or anything.

    Anyway, my problem is that if I want to start an SMS to someone and I hit the "messaging" icon and then start typing their name in the "to" box, my phone starts to give auto-complete options..and the first option is ALWAYS their email address, and I have to scroll down to select their phone number! From within the messaging/SMS program. That seems ridiculous. How can I get it to just fill in their phone number, or at least give that as the first option?

    Also, other things I've checked: I definitely have people's phone numbers entered as "mobile phone"
     

    Advertisement

  2. g60madman

    g60madman Guest
    Rank:
    None
    Posts:
    0
    Joined:

    What ROM are you using? I am using g60-final ROM and it's working just fine as I have all my contacts in gmail with email, home #, cell #, and work #. When I type their name in the messaging app it list just their numbers, and no email.
     
  3. zygomorph

    zygomorph Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    11
    Joined:
    Apr 4, 2012

    Apr 4, 2012
    11
    1
    16
    Is that something custom?

    I'm using whatever is the stock ROM. Software version says 1010_2_039, Kernel version Apps_2.6.32.9-perf, and Android version2.2.2

    Hmm. I wonder if it could be related to the SMS Backup utility I have (which backs my texts up to my gmail account.)

    Edited: nope, just tried uninstalling SMS Backup & rebooting. Still have the issue.
     
  4. g60madman

    g60madman Guest
    Rank:
    None
    Posts:
    0
    Joined:

    Yes g60-final is a custom ROM, running android version 2.3.7 gingerbread.

    http://androidforums.com/triumph-al...al-cm7-7-2-rc1-g60-style-final-6-10-12-a.html

    While there is a few bugs with it, it's a very solid ROM.
     
  5. zygomorph

    zygomorph Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    11
    Joined:
    Apr 4, 2012

    Apr 4, 2012
    11
    1
    16
    Hmm. I'd love to check to see if other people running the stock ROM have the same problem as I do, before I go playing around with things. But that's a good option.
     
  6. ecarlson

    ecarlson Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    184
    Joined:
    Aug 18, 2011

    Aug 18, 2011
    184
    34
    43
    Programmer
    Sterling, VA
    Do you have the Mobile Phone number set as the default under their contact? That might help, so it's worth a try.
     
  7. zygomorph

    zygomorph Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    11
    Joined:
    Apr 4, 2012

    Apr 4, 2012
    11
    1
    16
    That sounded plausible, but I just tried it and it doesn't seem to help.

    Can anyone who has the stock ROM confirm that they *don't* have the problem I'm having? At least it would help with my troubleshooting.
     
  8. Wilbour

    Wilbour Newbie
    Rank:
    None
    Points:
    15
    Posts:
    11
    Joined:
    Feb 20, 2012

    Feb 20, 2012
    11
    0
    15
    I have a similar problem. One person on my list always shows their #@virginmobile.ca when they text me. I cannot just reply but have to create a new message using their phone #. Not sure if this has something to do with Gmail sync. I may just reset my phone once again.
     

Share This Page

Loading...