1. Are you ready for the Galaxy S20? Here is everything we know so far!

SMS - Hangouts not displaying name...only number

Discussion in 'Android Devices' started by dubie7006, Oct 2, 2014.

  1. dubie7006

    dubie7006 Well-Known Member
    Thread Starter

    Title pretty much says it all. Using Google Hangouts, I have a number of contacts that are displaying only the phone number when I engage in text messages with them, not the name like it should. Anyone running into the same issue?

     


    usquetandem likes this.
  2. Best Answer:
    Post #13 by themexicang, Sep 8, 2015 (3 points)

    1. Download the Forums for Android™ app!


      Download

       
  3. nyydynasty

    nyydynasty Android Expert

    i haven't seen this issue but my first guess was that you have your contacts stored in your phone and not in gmail. I might be way off but hopefully that helps.
     
  4. dubie7006

    dubie7006 Well-Known Member
    Thread Starter

    Unfortunately that is not the case. It really seems to be hit and miss. A lot of contacts are phone-only yet still show name. Just strange how some show name and some don't.
     
  5. nyydynasty

    nyydynasty Android Expert

    i'm curious...on the contacts that only show the number (no name), do you have their hangouts ID (i.e. email address) listed as their "google talk" ID? For example, my wife is in my phone with her email address and cell number. i also have her email listed under 'google talk'. I dont know if that will force it to sync properly on your end....

    just a thought. I'm kinda fishing for something, here....
     
  6. dubie7006

    dubie7006 Well-Known Member
    Thread Starter

    Quickly running through it, most of the contacts that are showing number only do not have an email associated. I'm really not sure what you mean by "google talk". I guess it appears to be strictly a hangouts SMS issue, as those contacts I am using pure hangouts with are working fine.
     
  7. yamamonster600

    yamamonster600 Well-Known Member

    do you have the area code stored in your contacts, maybe hangouts doesn't recognize the number without the area code.
     
  8. dubie7006

    dubie7006 Well-Known Member
    Thread Starter

    All my numbers do have area codes since 99% of the numbers I contact are a different area code than mine. It just really seems to be hit and miss. Just weird.
     
  9. Spaceprobe

    Spaceprobe Android Enthusiast

    I had the same problem using hangouts for text on my S3 (dont use it on the G3). Having done a search on Google I came up with a fix. You need to edit the phone numbers with the country code. IE a UK mobile number would be 07957111293 in your Google contacts it should be written as +447957111293
     
  10. dubie7006

    dubie7006 Well-Known Member
    Thread Starter

    I'm in the US and all my numbers are saved in exactly the same format. However, if anyone else in other countries is having this issue, this could be helpful to them. Thanks.
     
  11. Hilbe

    Hilbe Well-Known Member

    I also had this issue. I edited the contact, retyped the number, hit save, and I was good to go on each one. Not sure why that helped, as I typed the same number that was already there.
     
    mush10 likes this.
  12. mush10

    mush10 Well-Known Member

    I have the same issue on multiple devices. I will try retyping and see if it helps.
     
  13. I was having the same problem. Tried retyping the number, but that didn't work. I then added a company to the contacts info and that change fixed it. So my recommendation to others with this issue is to just edit the contact in some way and do so till it fixes it.
     
  14. themexicang

    themexicang Lurker

    A bit late on this, but since I've resolved it quickly I'll lend my two cents.
    SMeekWoodworks response above may indeed work but would take forever for those that have a lot of contacts and be very tedious.

    Go into Google Hangouts on your mobile device, go to Settings > SMS > SMS Enabled, Touch to change your default SMS app > Default SMS app > Choose Messaging. Now go into either the Messaging app or into Google Hangouts app and go back to Settings and change the default SMS back to Hangouts.

    This corrected the issue for me.
     
    Grey Wulf and (deleted member) like this.
  15. jsummers

    jsummers Lurker

    Thank you so much! This worked instantly for me!
     
    Grey Wulf and desnewell like this.
  16. Aleksandra89

    Aleksandra89 Lurker

    Okay first sorry for reviving this:(, but I was having this issue and figured out that I had my hangouts account set to sms and not my Google account and once I set it to my account it was fixed :D

    Thanks hope this is a solution.
     
    KOLIO likes this.
  17. Aleksandra89

    Aleksandra89 Lurker

    Okie dokie, lets see umm...

    first I opened Hangouts and selected Settings
    then under General Settings I selected SMS
    lastly under General I changed the Default SMS Messaging Account from SMS to my Google account

    I hope this better explains what I attempted to say before, still working on explaining myself clearly :D
     
  18. desnewell

    desnewell Lurker

    Thanks a lot, worked first time for me!
     
  19. JR Smith

    JR Smith Lurker

    I did both things (changed SMS account from Google, to SMS, and back, and changed default account back and forth) and neither thing fixed my issues. Names are syncing in my hangouts app on my PC, just not in my Hangouts app on my phone. Any other ideas?
     
  20. RyuRaygun

    RyuRaygun Lurker

    Ok...I've searched this issue many many times and tried everything - nothing seemed to work for me. Yesterday, I was messing around trying to fix this and discovered how to access my google contacts through my browser (Chrome) - I've never really tried before. When you are in Gmail, in the top-right corner, there is a button to access your apps (it looks like little tiles) - the contacts app is listed under "More". What I discovered was: if you add/edit the bad contacts and then save, they will start to work (i.e. sms message will show up with a name in the hangouts ap on your phone). I had to sign out/in to my hangouts account on my phone to get it to update, but after that it finally worked!! It's a bit of a pain in the ass that you have to do this, but at least there is a way to fix up the annoying contacts that always show up with a phone number instead of a name.
     
  21. dphilp

    dphilp Lurker

    Same issue, Moto X, tried all the above, no results.

    The numbers with issues are formatted differently than the number displayed where the name should be. I.e. the number displayed is (xxx) xxx-xxxx, but in the contact, it is xxxxxxxxxx or +1xxxxxxxxxx.

    Super frustrating... Thought we were done with hangouts bugginess.
     
  22. tube517

    tube517 Android Expert

    Very frustrating.

    Have you ever combined/merged duplicate contacts in Google/Gmail? I know that messed my contacts up.
     
  23. gNeal

    gNeal Lurker

    I use Hangouts because I like merged conversations with Google Voice messages and SMS together. I tried many of the solutions listed here and elsewhere to get all my contact names back, but I had no luck. I finally had success by going a few steps further than most of the suggestions:

    1. Switch default SMS app to Messaging
    2. Disable Hangouts and when prompted, uninstall updates to Hangouts, confirming that it will remove data
    3. Restart phone
    4. Enable Hangouts, install updates (may have to wait a little for them to show up)
    5. Switch default SMS back to Hangouts
    6. Change Hangouts default message account back to email address associated with Google Voice
    7. Enable merged conversations

    I am using a Droid Turbo 2, but from what I have seen with this problem, it seems to affect users with many different phones.
     
    blautens and sevx like this.
  24. Montana Fox

    Montana Fox Lurker

    I tried a lot of the things you all suggested. Adding country codes. Changing default app to Messenger and back to Hangouts. Signing out of Hangouts and signing back in after doing certain things. None of those things worked for me. Then I noticed another problem. Not only were these contacts' names not showing up in my Hangouts message archives, but when I tried starting a new SMS conversation with them, I couldn't even find them in my phone contacts at all, even though I know for sure I'd added them (multiple times, actually).

    So I went to the Google Contacts website on my computer, and sure enough, these contacts were not listed in the "All Contacts" section. I could find them if I searched, but they were not associated with my personal contact list, even though I had added them multiple times in my phone.

    Here's what I did that finally fixed the issue for me...
    1. On a computer (not a phone), go to the Google Contacts website: contacts.google.com
    2. Search for the person by name in the top search bar. There may be multiple results found for the same person. Determine which one you want to use.
    3. Hover your cursor over that record on the far right end, and click on the "Add to contacts" icon. This will add them to your contact list (even though they should have already been there anyway).
    4. On your phone, in the Hangouts app, go to Settings and sign out.
    5. On your phone, force quit the Hangouts app. (On my phone, that means holding down the home button, and then closing the app from among all the currently open ones.) This will force the app to load fresh when it opens again.
    6. On your phone, re-open the Hangouts app. Go to Settings, and sign in again. Your conversations will re-load.

    After I did this, the conversations with these people finally showed their names. Hooray!
     
    tube517 likes this.
  25. sevx

    sevx Lurker

    None of the ideas before this one worked for me, but this
    gave me an idea, which worked for me.

    I just went in to Phone Settings > Apps > Hangouts > Storage and pushed Clear Data.

    After that, I just relaunched the app, and all of the contact names were displaying correctly.
     
  26. knwpsk

    knwpsk Newbie


    Sevx, did this work for your pre-existing SMS conversations? Or only for new conversations that started after you made the change? For me, after I cleared data and re-launched Hangouts, it re-syncd/reloaded all my old conversations, and they all still look as they did before -- many of them only display numbers. So this remedy doesn't seem to have had any effect for me.

    Oddly -- for SOME of my contacts, they do display names in Hangouts. It's about 50/50, maybe.

    I also noted: on the Windows/Desktop version of Hangouts... ALL of my contacts do display names -- for the SAME conversations that are not working on my phone. So this rules out a lot of the remedies I've found online.
     

LG G3 Forum

The LG G3 release date was June 2014. Features and Specs include a 5.5" inch screen, 13MP camera, 2/3GB RAM, Snapdragon 801 processor, and 3000mAh battery.

June 2014
Release Date
0
Reviews
Loading...

Share This Page

Loading...