1. Download our Official Android App: Forums for Android!

Support SMS in galaxy S2

Discussion in 'Android Devices' started by alcalay, May 30, 2011.

  1. alcalay

    alcalay Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    8
    Joined:
    Nov 13, 2010

    Nov 13, 2010
    8
    0
    5
    I bought galaxy S2 in Korea
    2 problems. I cannot send SMS . I can a message invalid sender ??? i can recieve an SMS
    How can I make the phone keyboard numbers and english characters only and not also in Korean ?
    Thanks Joe
     

    Advertisement

  2. Blue1k

    Blue1k Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    608
    Joined:
    Oct 1, 2009

    Oct 1, 2009
    608
    190
    93
    Teacher/Web Design
    Cloverdale, BC
    In messaging app select SETTING. Scroll down to where it says Message Center. Change the number for the one listed for your carrier (you may have to look that up)

    Not sure about the korean characters. Is the rest of the language in english? (menus etc..)
     
  3. m77m7

    m77m7 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jun 8, 2011

    Jun 8, 2011
    2
    0
    5
    I have the same problem. Using a KT Galaxy S2 in Hong Kong. If you compose a new SMS, you will get the error message, and the top will have a "From" drop down from the top. if you enter your phone number, it will send. This wont' happen if you try to reply to a message you received though.
     
  4. m77m7

    m77m7 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jun 8, 2011

    Jun 8, 2011
    2
    0
    5
    I have solved it for my M250K.

    Confirm your phone doesn't recognize "my phone number"

    Settings -> About Phone -> Status -> My phone number

    likely, it says "unknown". I dont think there is a way to change it in your phone so you need to put your SIM in another phone (such as iphone 3G/3GS, or older Sony Ericssons) and edit it there. For iphone 3GS, you can do this:

    Goto Settings> Phone> Press My Number> Enter YOUR number> Press Save> Press Home

    This will save to the SIM. When you put the SIM back in, you should be able to use it.
     
  5. toeneu

    toeneu Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jun 12, 2011

    Jun 12, 2011
    1
    0
    5
    You can try go to message, if you are get your last conversation screen, press back button to see all conversation list, then press menu /setting /input mode, and select automatic.
     

Share This Page

Loading...