1. Download our Official Android App: Forums for Android!

Support SMS Messaging problem

Discussion in 'Android Devices' started by Detailingdoc, Feb 23, 2011.

  1. Detailingdoc

    Detailingdoc Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    18
    Joined:
    Oct 6, 2010

    Oct 6, 2010
    18
    0
    15
    I received the OTA Froyo update today however after it successfully downloaded when i click the messaging icon it directly goes to the stock app whereas before it would ask if i wanted it to default to handcent. Even if i open the handcent app settings it doesnt give me the option to set it as default.

    Finally when it alerts me to a new message and i respond by clicking a shortcut to handcent and replying the stock message icon still shows unread messages.

    Hopefully someone can help.

    Thanks
     

    Advertisement

  2. emogulz

    emogulz Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Feb 23, 2011

    Feb 23, 2011
    3
    0
    5
    First off, long time lurker, first time poster.

    Well this is quite annoying. I have gone as far as using "Launcher" over "TwLauncher" because that is infuriating! Tw (touch wiz) launcher is more beautiful, but I just cant handle that messaging notification. I dont want to open two apps (handcent, then messaging) just to get rid of one notification. I have the same setup as you OP.

    If you are ok with a subtle change in homescreen, and app drawer, try Launcher as default "home" setting. Not as purdy, but pretty much stock froyo.

    I will stick around for updates on this! AHHHH!
     
  3. Kelmar

    Kelmar Done by choice
    Rank:
    None
    Points:
    823
    Posts:
    11,819
    Joined:
    Nov 28, 2009

    Nov 28, 2009
    11,819
    4,745
    823
    Haven't tried it... Try going menu/settings/apps/manage apps. Select messaging (may be under the "All" tab) and clear defaults if the option exists.
     
  4. Detailingdoc

    Detailingdoc Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    18
    Joined:
    Oct 6, 2010

    Oct 6, 2010
    18
    0
    15
    Thanks for the advice Kelmar. I had tried doing that earlier but the option to clear defaults was greyed out on both Handcent and Stock Messaging app.
     
  5. Kelmar

    Kelmar Done by choice
    Rank:
    None
    Points:
    823
    Posts:
    11,819
    Joined:
    Nov 28, 2009

    Nov 28, 2009
    11,819
    4,745
    823
    The other option you have is to disable notification in the stock app (assuming you are familiar with that) and replacing the messaging icon on the dock with handcent).

    Hit apps/menu/edit and drag handcent onto to dock... Or something like that.
     
    Peachblossum and 2hammy like this.
  6. gmcgirt

    gmcgirt Newbie
    Rank:
    None
    Points:
    16
    Posts:
    26
    Joined:
    Jan 13, 2011

    Jan 13, 2011
    26
    4
    16
    In the stock messaging software, turn off all notifications (a word of caution. . .I suggest setting them to silent before shutting them off. . .as for some reason when I just turned them off . . .they occasionally still "notified" me. . .but that was in 2.1).

    Delete the icon from the home-screen and re-add it. When you do that on your first click, it should present you with the option as to which you want to use (or just drop the handscent icon there in it's place).

    That should fix both of your problems.
     
  7. emogulz

    emogulz Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Feb 23, 2011

    Feb 23, 2011
    3
    0
    5

    AHA! That looks right. I knew how to make it default. The docked app still would show an unread message however. That was annoying. Now the messaging app just shows in the app drawer. I am back on Touch Wiz now :)
     
  8. gmcgirt

    gmcgirt Newbie
    Rank:
    None
    Points:
    16
    Posts:
    26
    Joined:
    Jan 13, 2011

    Jan 13, 2011
    26
    4
    16
    awesome man!
     
  9. emogulz

    emogulz Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Feb 23, 2011

    Feb 23, 2011
    3
    0
    5
    Ha ha. I meant to quote Kelmar, but yeah. Thats the solution. Replace the messaging app on the dock from the app drawer. Dont press and hold, use Kelmars method of Menu/edit :D
     
  10. alestin

    alestin Newbie
    Rank:
    None
    Points:
    36
    Posts:
    12
    Joined:
    Oct 12, 2010

    Oct 12, 2010
    12
    1
    36
    Dallas, TX
    That is a good solution, but not complete. In the App drawer, the messaging app still shows the notification number on the icon. Just seeing that number tempts me to go into messaging app and clear the notifications :mad:
     
  11. shorty_ryan05

    shorty_ryan05 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Feb 28, 2011

    Feb 28, 2011
    2
    0
    5
    I am having the same issue. I had Sprint do the update today for me from their computers and once I got everything installed, handcent and the default messaging is giving a problem.

    I want Handcent to be my default program (which I have set it as default) and to be the only one to give notifications. I have disabled the auto-retrieve and notifications alert from the default messaging application and turned those on in Handcent. However, now when I get a text message, the number of unread messages is in a bubble on my default messaging application even if I have read them in Handcent. When I had 2.1, I never had this issue.

    Please help!! I have noticed that text messages now also show up under the call log tab. Could this be the default messaging application shows the message counter of unread? If so, how can this be fixed? It's driving me nuts!!
     

Share This Page

Loading...