1. Download our Official Android App: Forums for Android!

General SMS to MMS

Discussion in 'Android Devices' started by sam142000, Aug 16, 2011.

  1. sam142000

    sam142000 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    56
    Posts:
    107
    Joined:
    Jul 26, 2011

    Jul 26, 2011
    107
    4
    56
    Student
    India
    My SGS2 automatically converts a really long sms to mms while sending!!
    Is there anyway to disable dis on a non-rooted phone?
     

    Advertisement

  2. jaliy

    jaliy Android Expert
    Rank:
    None
    Points:
    63
    Posts:
    895
    Joined:
    Aug 7, 2011

    Aug 7, 2011
    895
    19
    63
    enable to long sms option: making it to send 2 sms instead
     
  3. ironass

    ironass Android Expert
    Rank:
     #20
    Points:
    1,343
    Posts:
    11,457
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    11,457
    5,677
    1,343
    Male
    Keeping one step ahead of the tax man.
    Cotswolds, England
    How do you do that on the stock, built-in, Messenger please?
     
  4. suhailmoghul

    suhailmoghul Newbie
    Rank:
    None
    Points:
    16
    Posts:
    21
    Joined:
    Aug 4, 2011

    Aug 4, 2011
    21
    2
    16
    Hi there,

    Try using HANDCENT SMS link below

    https://market.android.com/details?id=com.handcent.nextsms&feature=search_result

    There is an option to disable it in 'send message settings' there you will see an option for 'Auto-convert to MMS' make sure its unticked 'don't convert to MMS when length exceeds 3 messages"

    Hope this helps you, I had same problem so far good.

    Someone correct me if I am wrong about this.
    Thanks
     
  5. sam142000

    sam142000 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    56
    Posts:
    107
    Joined:
    Jul 26, 2011

    Jul 26, 2011
    107
    4
    56
    Student
    India
    Yes, please let us know how to do so!!
     
  6. jaliy

    jaliy Android Expert
    Rank:
    None
    Points:
    63
    Posts:
    895
    Joined:
    Aug 7, 2011

    Aug 7, 2011
    895
    19
    63
    actually i coudlnt' find it either but it was supported in my old phone
     
  7. jaliy

    jaliy Android Expert
    Rank:
    None
    Points:
    63
    Posts:
    895
    Joined:
    Aug 7, 2011

    Aug 7, 2011
    895
    19
    63
    k i just searched the web u need 3rd party sms app to do this
     
  8. suhailmoghul

    suhailmoghul Newbie
    Rank:
    None
    Points:
    16
    Posts:
    21
    Joined:
    Aug 4, 2011

    Aug 4, 2011
    21
    2
    16

    That is what I just posted about half an hour ago, even gave you the link.:D

    ..and PLEASE do click the THANKS button if it helps. THANKS
     
  9. DaveSyd

    DaveSyd Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    428
    Joined:
    Jul 19, 2011

    Jul 19, 2011
    428
    62
    53
    Australia
    You should not need to enable anything. In the Stock standard Messaging on my SGS2 the count just above the Send button counts down from 160, if you go over it starts again at 160/2 meaning 2 SMSs will be sent. Don't know how Sam142000 makes it convert to an MMS?

    The only way the standard SMs converts to an SMS on my device is if;
    - You attach some file or contact etc. by hitting the paperclip or
    - hit menu, more, add a subject line to the message

    If yours is misbehaving I suggest you talk to your carrier - there may be some setting they have that conveniently defaults to MMS because they are usually cvost more!
     
  10. XLAR8

    XLAR8 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jul 30, 2011

    Jul 30, 2011
    13
    1
    16
    i just tried on my GS2 (180 character sms msg) and it sent 2 sms... so id say its a carrier issue your having.

    iam using a stock GS2
     
  11. sam142000

    sam142000 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    56
    Posts:
    107
    Joined:
    Jul 26, 2011

    Jul 26, 2011
    107
    4
    56
    Student
    India
    I dont do anything to convert it, once i sent a sms of more than 4sms length and my phone automatically converted it to mms.
    I dont remember the exact message it showed.
    Why dont you try sending a sms of >4sms? Then lets see what happens!!
     
  12. MISS DIVA

    MISS DIVA Android Enthusiast
    Rank:
    None
    Points:
    63
    Posts:
    300
    Joined:
    Apr 17, 2011

    Apr 17, 2011
    300
    90
    63
    Female
    West Sussex, UK

    Mine does the same,what carrier do you use? Im on T-mobile UK.


    Miss Diva
     
  13. suhailmoghul

    suhailmoghul Newbie
    Rank:
    None
    Points:
    16
    Posts:
    21
    Joined:
    Aug 4, 2011

    Aug 4, 2011
    21
    2
    16

    Spoke to O2 UK and they confirmed that if your message length exceeds 3 sms's then it auto converts to MMS.
    That is why I posted a message above (up there)(no further up) how to over come this problem, but looks like no one is interested.:eek:
     
  14. Mark_s

    Mark_s Newbie
    Rank:
    None
    Points:
    15
    Posts:
    11
    Joined:
    Aug 17, 2011

    Aug 17, 2011
    11
    0
    15
    I'm with o2

    Message Settings Creation Mode : there are 3 settings

    warning
    free
    restricted

    Just changed mine to Warning noting happened at 3 messages but ive seen it say converting in the past will play later with it.
     
  15. sam142000

    sam142000 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    56
    Posts:
    107
    Joined:
    Jul 26, 2011

    Jul 26, 2011
    107
    4
    56
    Student
    India
    I use Airtel, India.
     
  16. GSMGuy

    GSMGuy Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    93
    Joined:
    Apr 21, 2010

    Apr 21, 2010
    93
    5
    36
    I too am having this prob with my SGS2 on Orange (debranded) I have raised it with Orange themselves, as I have unlimited texts on my talkplan, but am charged for MMS - So when a friend sends a long text to me, and I forward it (usually jokes) I will be getting chrged for an SMS @
     
  17. GSMGuy

    GSMGuy Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    93
    Joined:
    Apr 21, 2010

    Apr 21, 2010
    93
    5
    36
    Just tried all 3 "modes" - Restricted, Warning and Free... Still converts an SMS of more then 3 "messages" long to an MMS - That IS a pain..

    Mike
     
  18. suhailmoghul

    suhailmoghul Newbie
    Rank:
    None
    Points:
    16
    Posts:
    21
    Joined:
    Aug 4, 2011

    Aug 4, 2011
    21
    2
    16
     
  19. kebark

    kebark Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    106
    Joined:
    Jul 31, 2011

    Jul 31, 2011
    106
    17
    38
    ...why not just send it as a number of separate SMS's?...It'll take a little bit of time but save you money...or use Handscent...
     
  20. Bath

    Bath Newbie
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Jul 6, 2011

    Jul 6, 2011
    10
    0
    15
    I have the problem on my Orange phone and I am VERY peeved with Orange - - looks like it's a network operator set parameter. Yes I've now got Handcent on my phone and it solves the problem.
    In answer to your peevish comment - maybe, like me, folks don't want to be loading 3rd party app's onto their phones to solve issues like this when the core SMS app' is just fine!
     
  21. Bath

    Bath Newbie
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Jul 6, 2011

    Jul 6, 2011
    10
    0
    15
    For those who adopt Handcent app to overcome the 3 message limt and auto conversion to MMS.... You may want to replace the SMS application icon in the menu at the bottom of the screen with the Handcent one. To do this:-

    Select the Applications menu
    Press Menu key, then select Edit.
    Now you can move the standard Messaging widget from the bottom of the screen into the applications area and replace them with the Handcent widget.
     
  22. SebaKL

    SebaKL Android Enthusiast
    Rank:
    None
    Points:
    113
    Posts:
    746
    Joined:
    Oct 4, 2011

    Oct 4, 2011
    746
    226
    113
    Interactive Designer/Developer
    Kuala Lumpur, Malaysia
    Sorry, not going to contribute anything useful.

    It's bloody unbelievable that there is no native SMS setting of such type. I have stupid 5 years Nokia which can send 10 pages SMS without problem, and I would really expect much more from such advanced phone.

    Plus, for fork sake, every person I know SMS more than calls, what genius came out with idea to convert that SMS beyond 3 pages into MMS.
    It seriously blows my mind.

    Personally I hate to install 3rd party apps to do what the phone should be doing by default.

    ughhhhhhh......
     
  23. Hawker

    Hawker Android Expert
    Rank:
     #57
    Points:
    433
    Posts:
    4,095
    Joined:
    Aug 2, 2011

    Aug 2, 2011
    4,095
    1,911
    433
    Male
    UK
    Didnt you try doing it it before posting?
    TUT TUT!
    :D

    I seem to remember an SMS mod on Revolution ROM. I have a feeling it was something to do with this for the Stock messaging app. I'll have to do a bit of poking around and report back later.....
     
  24. Skezza

    Skezza Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Dec 1, 2011

    Dec 1, 2011
    2
    0
    5
    I know I'm reigniting an old thread but this problem isn't going to go away.

    For those who don't really want to install Handcent (don't blame you, nothing wrong with the stock messaging app apart from this) go on the Market and type BigSMS. It's a very lightweigth front-end that provides one function, and one function only, the ability to send massive SMS's. It's free as well.

    I don't think people realize the severity of this issue. It's not a bug. It's a feature, an anti-feature, included to cost users money.
     
  25. fireblox

    fireblox Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Jan 25, 2012

    Jan 25, 2012
    4
    0
    5
    I Just had the same problem.
    Go in Settings>SMS options> Input mode> GSM Alphabet

    The problem came when my S2 updated to 4.0 ^^
    I Hope it help you.
     

Share This Page

Loading...