1. Download our Official Android App: Forums for Android!

General Soft bricked HTC one M8

Discussion in 'Android Devices' started by hiten81, Feb 28, 2016.

  1. hiten81

    hiten81 Lurker
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    4
    Joined:
    Feb 28, 2016

    Feb 28, 2016
    4
    0
    15
    Guys and Gurus
    Hope you all doing well.

    I have a problem which I cant fix at all and looking for SOS asap.

    What I did
    Followed this http://htconeroot.com/htc-one-root/how-to-root-htc-one-m8/ and rooted my HTC one M8
    Installed TWRP using updatesu_v_1.94. But failed with errors
    Accidentally took "NO BACKUP"
    WIPED off everything on phone including boot partition ( I am not sure).

    What I tried ?
    1. RUU update from HTC site - tried various versions, but every single one fails with Signature Error (132)
    2. Tried to copy files using adb into /sdcard and installed Updates_su_v_2.24 but failed
    3. I can get it to fastboot mode, but cant install any ROM and OS
    4. SU update says , No OS installed, do you want to still boot ?

    Attached are images for reference, please help
     

    Attached Files:


    Advertisement

  2. saltire

    saltire Android Expert
    Rank:
    None
    Points:
    273
    Posts:
    1,011
    Joined:
    May 10, 2011

    I think you have some of the steps that you have listed under where you say "what I did" a bit confused. Also, you can't just select any RUU and expect for it to work - you are S-ON so the RUU needs to be signed (completely unmodified) and needs to match your phone's CID and model number.

    I'll need you to provide some more info first.

    Do you have a Win PC/laptop with the adb/fastboot tools installed? You can get it here if not:

    ADB Guide (updated 2014/11/11)

    along with instructions to install.

    Reboot phone to bootloader and plug in to PC (so you see FASTBOOT USB on bootloader screen). Open a command prompt window in the adb/fastboot folder on your PC - if in Explorer hold shift + right click, and pick "Open command window here" from context menu.

    Then type:

    fastboot devices (this is to check fastboot connects to phone ok, it should also return the phone serial number)

    If it does, then type:

    fastboot getvar all

    and post the info the command returns here but scrub out your IMEI number and serial number.
     
  3. hiten81

    hiten81 Lurker
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    4
    Joined:
    Feb 28, 2016

    Feb 28, 2016
    4
    0
    15
    Hi Saltire

    Thanks for your inputs

    Here is the information, please advice

    C:\Users\hiten\Downloads\Fastboot\Fastboot>fastboot getvar version-main
    version-main:
    finished. total time: 0.001s

    C:\Users\hiten\Downloads\Fastboot\Fastboot>fastboot getvar all
    INFOversion: 0.5
    INFOversion-bootloader: 3.19.0.0000
    INFOversion-baseband: 1.25.21331147A1.06G
    INFOversion-cpld: None
    INFOversion-microp: None
    INFOversion-main:
    INFOversion-misc: PVT SHIP S-ON
    INFOserialno: HT45EWM07167
    INFOimei: 358714053933291
    INFOimei2: Not Support
    INFOmeid: 00000000000000
    INFOproduct: m8_ul
    INFOplatform: hTCBmsm8974
    INFOmodelid: 0P6B10000
    INFOcidnum: H3G__001
    INFObattery-status: good
    INFObattery-voltage: 0mV
    INFOpartition-layout: Generic
    INFOsecurity: on
    INFObuild-mode: SHIP
    INFOboot-mode: FASTBOOT
    INFOcommitno-bootloader: dcdaa6e0
    INFOhbootpreupdate: 11
    INFOgencheckpt: 0
    all: Done!
    finished. total time: 0.178s
     
  4. hiten81

    hiten81 Lurker
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    4
    Joined:
    Feb 28, 2016

    Feb 28, 2016
    4
    0
    15
    Hi there
    Tried this one, but failed as well , any ideas
    C:\Downloads\Fastboot\Fastboot>fastboot flash recovery cm-12.1-20151117-SNAPSHOT-YOG7DAO1K1-m8-recovery.img
    sending 'recovery' (17986 KB)... OKAY [ 2.183s]
    writing 'recovery'... INFOsignature checking...
    FAILED (remote: signature verify fail)
    finished. total time: 2.831s

    thanks in advance
     
  5. saltire

    saltire Android Expert
    Rank:
    None
    Points:
    273
    Posts:
    1,011
    Joined:
    May 10, 2011

    OK, hang on. I thought you had TWRP recovery installed? In any case we want to stick with TWRP as I know it works. What version of TWRP do you currently have installed?

    Also, can you just confirm that your bootloader is still Unlocked?
     
  6. hiten81

    hiten81 Lurker
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    4
    Joined:
    Feb 28, 2016

    Feb 28, 2016
    4
    0
    15
    Hi ya

    Yes I have TWRP, but also tried to install Cynogenmod.
    Right now the status is Unlocked with S-ON
    And have a image flashed into the device through recovery on the boot loader.

    Now please tell me one thing.
    The phone should be unlocked, s-on to flash a recovery image ?
    I have done this --> fastboot flash recovery cm-12.1-20151117-SNAPSHOT-YOG7DAO1K1-m8-recovery.img with s-on
    Its pretty confusing, please help.

    Thanks
     
  7. saltire

    saltire Android Expert
    Rank:
    None
    Points:
    273
    Posts:
    1,011
    Joined:
    May 10, 2011

    Ok, can you remember at all what software version you were on before this happened? The version of TWRP installed via the rooting process you followed is I think a 2.7.x.x version and it seems to wipe info on the firmware version installed (why the OS entry in bootloader screen, and the version-main entry from the getvar all command are blank).

    Edit: meant to ask, what happened in the first place to put the phone in this state?
     
  8. mounaashihuh

    mounaashihuh Newbie
    Rank:
    None
    Points:
    25
    Posts:
    15
    Joined:
    Sep 18, 2016

    Sep 18, 2016
    15
    0
    25
    Male
    I have soft bricked htc m8 sprint ....and recovery flash img version in 2.7.1.0 how can i relive my phone?
     

HTC One M8

The HTC One M8 is the Taiwanese company's flagship phone for the first half of 2014. It built on its predecessor with an upgraded 5-inch 1080p display, Snapdragon 801 processor, 2GB of RAM, 32GB of internal storage, and an UltraPixel rear Duo Camera.
Tags:

Share This Page

Loading...