1. Are you ready for the Galaxy S20? Here is everything we know so far!

Softbrick (s-on, unlocked bootloader, VODAPE17) Please help

Discussion in 'Android Devices' started by Elementalys, Aug 16, 2015.

  1. Elementalys

    Elementalys Newbie
    Thread Starter

    Hello everyone,

    My friend has tried to get into the rooting scene and without proper knowledge he managed to get himself stuck on the boot screen.
    I offered him my help, since I thought that this would be an easy fix because the phone still has access to the TWRP recovery.
    What I didn't know is that the phone was branded and S-on. The CID is: VODAPE17.
    ADB works in recovery mod ! [​IMG]

    To sum it up:
    The bootloader is unlocked
    Acces to custom recovery
    no backup
    adb works
    fastboot works

    What I have tried:
    I tried to get the device S-off with HTC dev. But it required me to boot up the phone, so that didn't work out.

    I have found a nand backup that should work with this CID on this page: http://forum.xda-developers.com/show...2701376&page=5
    This one: - TWRP Thanks to Petert87 (what does that number: 3.29.1619 mean?)
    I unpacked the file. Send it to the internal storage and renamed it to a backup that I had made myself (otherwise TWRP wouldn't recognize it?).
    After wiping I restored the backup, but to my surprise the phone still was stuck on the HTC one logo when I tried to boot it!

    I tried to get as much information from the phone as possible.
    This is what I got:

    version: 0.5
    version-baseband: 1.25.214500021.06G
    version-cpld: None
    version-microp: None
    version-misc: PVT SHIP S-ON
    product: m8_ul
    platform: hTCBmsm8974
    modelid: 0P6B10000
    cidnum: VODAPE17
    battery-status: good
    battery-voltage: 0mV
    partition-layout: Generic
    security: on
    build-mode: SHIP
    boot-mode: FASTBOOT
    commitno-bootloader: 3aa067db
    hbootpreupdate: 11
    gencheckpt: 0

    My question

    Can anyone help me to get this phone running again? I don't really know what to do anymore. [​IMG]

    Every bit of help is appreciated very much! [​IMG][​IMG]
    Thank you in advance!

    #1 Elementalys, Aug 16, 2015
    Last edited: Aug 18, 2015

    1. Download the Forums for Android™ app!


  2. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    This isn't a problem but you'll have to wait a few hours until I get back.

    In the meantime, please don't try anything else, you're clearly not accustomed to HTCs.

    HTCdev.com is an unlock site, not s-off, and s-on is fine.

    The nandroid backup you tried is way out of date.

    Just sit tight, I'll be back.

    PS - please say what TWRP version it's on, thanks.
  3. Elementalys

    Elementalys Newbie
    Thread Starter

    Thank you for the quick reply.
    I will not try anything until you get back :)
    The version of TWRP is:

    I am looking forward to your response.
  4. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    So, hello Netherlands!

    Happily the TWRP is up to date, thanks for checking. :)

    Please get the stable ViperOneM8 4.3.0 from here -


    TWRP, Wipe, Advanced, wipe cache ONLY.

    In TWRP, Mount - Check on the internal storage or sd card. The phone will appear on the pc, copy the rom over. When done, uncheck ONLY the box you checked to mount.

    Back to main menu, Install, choose the ViperOneM8.

    The ViperOneM8 Aroma installer launches. Choose the default, stock rom full install and do NOT choose to uninstall any optional apps.

    When asked, choose the default to do a full wipe by ViperOneM8.

    Maybe because of the state of the phone, the wipe may take time - do not worry even if 20 minutes or more - it's ok.

    The rom will work with your CID.

    When done, boot up - expect it to take time to compile and build everything, ViperOneM8 first time boot is never fast anyway. Again, even if 20 minutes or more, it's ok.

    Verify everything is working, then let me know if some particular rom is desired instead.

    Even if he doesn't want Viper, it's a very good rom and he can be running something while making other decisions.

    Viper has a great explanation of features at the XDA thread, like power menu - you can choose reboot, then recovery to go straight to TWRP.

    If it won't install, of course stop and let me know.

    If he does like ViperOneM8 but wants to try the latest, please make a backup of the stable and try experimental 4.5.1 - guys building it are in Germany so I think you'll be ok but try the stable one first to be safe.

    I'm moving this to the root forum but you won't notice, just refresh the browser page after you read this and you'll be there.
  5. Elementalys

    Elementalys Newbie
    Thread Starter

    Netherlands it is indeed ;)

    It didn't work... :(
    I wiped the cache, put the ROM on the root of the SD card.
    Then I flashed the rom with the aroma installer, I did the wipe like you told me and the rom seemed to be installing just fine. But when it is trying to reboot it doesn't manage to pass the HTC one screen. I have been waiting for 40 minutes now, so I don't think that anything is going to happen.

    This is exactly the same as happened with Insertcoin and ARHD.

    Can it have something to do with the firmware being outdated?
  6. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Your firmware is up to date according to the getvar output. And that would only cause working issues, you would get past the white screen.

    So -

    Open the ViperOneM8 rom zip file on your pc - extract the boot.img file.

    Copy/move the boot.img file over to where you have fastboot installed.

    Place the phone in FASTBOOT USB mode again, from command window -

    fastboot flash boot boot.img

    Let me know if you get a failure - if you get OKAY then

    fastboot reboot
  7. Elementalys

    Elementalys Newbie
    Thread Starter

    It flashed succesfully, but it didn't fix the problem.
    Still stuck at the HTC one screen.
    I really don't know what is wrong with this phone.... :(
  8. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    OK, don't panic, we'll probably find it.

    Please go back into FASTBOOT USB and try -

    fastboot erase cache

    fastboot reboot

    Failing that, please remove sim and sd card, and hold volume up + power until phone powers off - that will clear any stuck silicon - and then try to power up.
  9. Elementalys

    Elementalys Newbie
    Thread Starter

    I followed the instructions but that didn't work either.
    Have you got other idea's?
  10. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Yep, we're going to have to get stock everything back on the phone and go for a factory reset from HBOOT - that's the only thing that will do a partition repair short of an HTC-distributed RUU.

    Give me some time to track down pieces.
  11. Elementalys

    Elementalys Newbie
    Thread Starter

    I really can't say enough how much I appreciate your help :)

    I don't know if it helps, but my friend told me that the phone wouldn't boot anymore after he did a format. It seemed strange to me, but perhaps it gives you an idea? I don't know if he formatted the device in the bootloader or in the recovery.

    I am looking forward to your next step.
  12. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    I'm on travel relying on my mobile browser.

    I found the matching stock recovery for that nandroid backup you have - got called away - and lost the link.

    It's at XDA - get back to stock with s-on, something like that, collection of stock recovery images.

    You want to restore that nandroid you came in with originally, flash that stock recovery from fastboot, and Factory Reset from HBOOT.

    Right now, that's your best shot.

    I tried to find the link again this morning, ran out of time.

    If you find it, try that.
  13. Elementalys

    Elementalys Newbie
    Thread Starter

    I understand that it is difficult to help me now, no problem.

    I actually found a different nandroid backup that has the correct CID. The same uploader also had the OTA, recovery and firmware, so I downloaded all of them. Is this better to try or worse?

    The version is : TWRP_4.19.161.2

    Could you tell me what the number behind TWRP means? What is different from this backup to the one I originally came with?
    I noticed that this one matches with my version-main: , that's how I found it.
  14. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    That match of numbers is correct and just what you think you need. It matches all other firmware except for recovery.

    After restoring it, you must flash the matching stock recovery (to replace TWRP), then everything is truly stock, then hboot factory reset, that only works with true stock.
  15. Elementalys

    Elementalys Newbie
    Thread Starter

    I really don't get it.
    Just restored the backup. Flashed the corresponding recovery. Did a factory reset in Hboot and still no progress at all.
    Stuck at the HTC One screen just as before.
    I also have to tell you that booting the phone takes a very long time. Until I get to the HTC one screen takes about 10 minutes.

    So, can we do something else?
  16. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    There's no publicly available RUU.

    And you've tried booting with no sim, no sd card?
  17. Elementalys

    Elementalys Newbie
    Thread Starter

    Just tried it for the second time but no.
    It didn't work.
    Do we still have options left?
  18. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Let me grab one of the guys smarter than me, @scotty85, see if he's got something I missed.

    I'll give him a call, hang in there, he's a busy guy...
  19. Elementalys

    Elementalys Newbie
    Thread Starter

    Good to hear. Hopefully he will come up with some fresh idea's.
  20. scotty85

    scotty85 Extreme Android User

    my sincerest apologies,it slipped my mind to follow up with you and see how things were going after chatting with EM.

    have you made any progress? if not,one more thing comes to mind. if i am understanding this post correctly,you have found and dounloaded and OTA file that takes you to your current version. what we should do is flash the firmware.zip file from this OTA. this file contains the bootloader,kernel,radio,and several bits of firmware that may be beneficial.

    if youre sure the firmware you downloaded is the untouched,unmolested file extracted from the OTA you can use that. otherwise,extract the OTA_blah_blah.zip file using 7-zip or equivalent. inside youll find the zip file marked "firmware".

    first, restore the matching nandroid if you have flashed something else.

    place the firmware file into your fastboot directory. its an official,signed file,so youll need to relock the bootloader to install it.

    install the file:
    fastboot devices

    fastboot erase cache

    fastboot oem rebootRUU

    fastboot flash zip firmware.zip
    (assuming the name of the file to still be "firmware")

    the phone will flash hboot and a couple other bits,then fail with a "reflush again immideately" message. dont worry this is normal. just enter again

    fastboot flash zip firmware.zip

    after its finished:

    fastboot reboot-bootloader

    now try one more factory reset and see if the phone will boot.

    if something happens and you become locked into hboot with a security warning,dont worry. youll just need to relock the bootloader.

    im off to work,but ill try and watch if youve any questions :)
    EarlyMon likes this.
  21. Elementalys

    Elementalys Newbie
    Thread Starter


    No worries about responding late. I am already very grateful for every minute you guys spend on my problems. :)
    Since I hadn't made any progress I tried your steps.

    I didn't get the message: reflush again immideately
    The flashing wasn't successful. The phone still doesn't boot.
    This is the message that I got:

    C:\adb>fastboot flash zip firmware.zip
    target reported max download size of 1826418688 bytes
    sending 'zip' (52107 KB)...
    OKAY [ 2.471s]
    writing 'zip'...
    (bootloader) adopting the signature contained in this image...
    (bootloader) zip header checking...
    (bootloader) zip info parsing...
    FAILED (remote: 99 unknown fail)
    finished. total time: 2.771s

  22. scotty85

    scotty85 Extreme Android User

    Oops, did you lock the bootloader? I just realized that I left out that command:

    Fastboot oem lock

    Do that before the rest of the commands

    Sent from my HTC Desire 510 using Tapatalk
    EarlyMon likes this.
  23. Elementalys

    Elementalys Newbie
    Thread Starter

    That fixed the flashing issue.
    But sadly, the phone still doesn't boot...

    Maybe I should flash something different to see if that works?
    I don't get it....

HTC One M8 Forum

The HTC One M8 release date was March 2014. Features and Specs include a 5.0" inch screen, 4MP camera, 2GB RAM, Snapdragon 801 processor, and 2600mAh battery.

March 2014
Release Date

Share This Page