1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Solution] Picasa Share "failed to retrieve account information"

Discussion in 'Android Devices' started by Member416487, Feb 2, 2011.

  1. Member416487

    Member416487 Guest
    Thread Starter

    Hey, folks!

    Again talking about Moto Defy/Android bugs, I wanna talk a little now about the well-known Picasa Share error message: "failed to retrieve account information".

    For my surprise (and for any other Defy user) the native Picasa image and video share is not working in Android 2.1. Instead of uploading, it returns the above error message and it is taken as a bug (already reported by many people in Google Android forum).

    Several possible workaround were suggested, but none worked out (such as resetting to factory default settings and etc.). The only ways to possibly upload a picture to Picasa from Moto Defy were:

    * By using the Motorola Blur service (which allows to share images on Picasa, Facebook...)
    * By using the "quick upload"
    * Or by using a 3rd party app (such as PiQture), with basically the same function as Moto Blur image sharing.

    HOWEVER, for my pleasure and for many others', now it is working!
    What I did:

    * Reset the Moto Defy to the factory defaults (Privacy menu in Settings)
    * I SKIPPED the Moto Blur account setup (press the "Dial" button on the bottom-left corner of the phone to show the menu and then select SKIP CONFIGURATION). Then I was taken to the Home screen.
    * In the "Accounts" option of the Apps menu, simply I added my Google account: xxx@gmail.com and my password. Still without adding the Blur account...
    * Then I accessed the Gallery, selected a random pic and chose SHARE. In the Share popup I selected 'Picasa' and, on the next screen, I typed in a Caption for the picture, the Google user account (only one available) and the Picasa album (for the first time all my existing Picasa albums were present on the list); I just picked any album and selected UPLOAD.

    The Image Gallery then shown a new message (somtehing like "check status bar to see the status of the upload"). Few seconds later, the upload was successfully completed and the picture now is available in my Picasa web albums!!!

    I REALLY hope this new tip can help others having the same damn issue!!!




    NathanWolf likes this.

    1. Download the Forums for Android™ app!


  2. NathanWolf

    NathanWolf Lurker

    Thanks for this tip!

    I'm afflicted with this issue, but only since resetting my phone to factory settings. (I also now get an annoying debug-looking popup on each app install, but I'm picking my battles here)

    I'm going to try this out, and I'll let you know if it fixes me up. I'm using Motoblur currently, but have been considering "abandoning" it as much as possible- I was not aware, for instance, that you could even skip the registration at the beginning.

    I bought this phone mainly to use with my various Google accounts and services- if Motoblur is getting in the way of that somehow, it's goooooone! :)

    I'll come back and thank you if it works, or let you know if it doesn't.... thanks either way, though!

    EDIT: BTW, I'm on an Atrix, not Defy- same problem, same error message, though.
  3. NathanWolf

    NathanWolf Lurker

    Worked for me! For my Atrix, I had to follow these (insane!) instructions in order to skip Motoblur setup:

    xda-developers - View Single Post - [HOW TO] Use the Atrix without a SIM and no Motoblur account.

    I apologize if it's not ok to link to other forums, but that's not strictly an Android forum so hopefully it's ok. I didn't want to steal credit for this, I frankly have no idea who figured that one out, or how. It's like the Konami code for Android :\

    Anyway, after skipping Motoblur, I continued with the steps above, and have successfully uploaded a photo to Picasa. Thanks!
  4. NathanWolf

    NathanWolf Lurker

    One more post, I wish I could double-thank you, Andre!

    After setting everything back up, it appears that I no longer get that annoying permissions/move dialog pop-up on app install, either.

    I can't blame that on MotoBlur (don't think), but I'm glad it's gone nonetheless :)
  5. NathanWolf

    NathanWolf Lurker

    It seems like, for AT&T+Atrix at least, Motoblur is very much required, unless you area able to manually set up all of your AT&T account info, to actually use the network. I ended up going back, and hoping that it doesn't interfere with Picasa anymore.
  6. jumpinjac

    jumpinjac Lurker

    I hardly find this an adequate solution since it requires factory reset. There must be an alternative option. I've searched and read dozens of other forums with the identical complaint and it appears the only solution is factory reset, then add google account BEFORE adding motoblur. Of course, on the Atrix the only way to do this is to enter a secret code. Seriously? WTF?

Motorola Defy Forum

The Motorola Defy release date was October 2010. Features and Specs include a 3.7" inch screen, 5MP camera, 512GB RAM, TI OMAP 3610 processor, and 1540mAh battery.

October 2010
Release Date

Share This Page