1. Are you ready for the Galaxy S20? Here is everything we know so far!

[SOLVED] download / install button not working

Discussion in 'Android Devices' started by Boerminator, Apr 28, 2012.

  1. Boerminator

    Boerminator Lurker
    Thread Starter

    After getting my Desire S back from repairs 2nd time in six months, I'm now having a new problem. I can sign into my google account. Email updates, Talk works and I can browse the apps in Play. But the 'download' (or for the apps that I installed in the past, the 'install') button is not working. I can read the comments on that app and see the screencaps but not download or install anything. The button doesn't even highlight.

    Here's what I tried to solve it.

    • Clear Play cache under 'applications'
    • Connect by wifi only
    • Connect by mobile connection only
    • Restore phone to factory settings (and format SD card)
      • Then I initially get the old Android Market, where I have the same problem. After a few minutes it asks me to update to Play. Same problem there, of course.
    • Install apps to my phone by using play.google.com on my regular pc. Nothing happened.


    Another weird thing: When I first got this phone, I just switched it on and selected my carrier from the set-up list. That automatically configured mobile internet. This time however selecting my carrier did not configure internet. I had to manually set up an access point to get it to work. And a few days later my carrier sent me a text with "what to do when you didn't get your internet connection working" instructions. I have a feeling the two issues are related. Then again, same problem on wifi only.

    Has anyone encountered this before? I'm at a loss...

    Android 2.3.5 with HTC Sense 3.0
     


  2. coydroid

    coydroid Newbie

    You're probably better off posting this in the appropriate HTC forum. I just installed 1 paid + 4 free apps through Play one hour ago, so the issue is not Google.

    cd
     
  3. Boerminator

    Boerminator Lurker
    Thread Starter

    That probably makes sense, though I doubt the problem has to do with the brand and type of my phone. My money is on a corrupted stock ROM or something like that.

    @Moderator, can this thread be moved to a more suitable location? You can probably best decide which one yourself...
     
  4. CDPlant

    CDPlant Android Expert

  5. Boerminator

    Boerminator Lurker
    Thread Starter

    @CDPlant, thanks.

    Ok, so I spent today fidgetting with my phone and reading up on how to root your phone. Never had the need for it so I never tried it before.

    Long story short. I followed these steps to downgrade my phone from 2.00.0002 to 0.98.0000. This so I could use Revolutionary to get S-off, opening the way to custom ROMs. Since the hardware of the device seems fine, I figured if anything helps it'll be a whole new ROM.
    I had to use a vodafone-branded ROM since the phone had a vodafone-rom to start with. (No sim-lock, though. I bought the phone without a contract. I know, weird.) I'm now on Android 2.3.3 instead of 2.3.5. The bloody download buttons STILL DON'T WORK :mad: And what's even more frustrating is that I apparently need to download ROM Manager, from the marketplace so I can try out different ROMs to solve this issue.

    Guys, I'm all out of ideas. Any input would be much appreciated!
     
  6. Boerminator

    Boerminator Lurker
    Thread Starter

    Ok, laugh all you want. After voiding my warranty by rooting the phone I found out that the touchscreen in the specific location of the marketplace download / install button is not functioning. When I switch to landscape it works.
     
  7. Nahid

    Nahid Member

    really sad story. but I think you have chance to claim warranty. look in All things root section, there you'll find guide to unroot your device which will help you to claim warranty.
     

HTC Desire S Forum

The HTC Desire S release date was March 2011. Features and Specs include a 3.7" inch screen, 5MP camera, 768GB RAM, Snapdragon S2 processor, and 1450mAh battery.

March 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...