1. Download our Official Android App: Forums for Android!

General [Solved] How do I change Contact association from 'Phone' to 'myaccount@gmail.com'?

Discussion in 'Android Devices' started by JCUMV, Nov 15, 2014.

  1. JCUMV

    JCUMV Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    112
    Joined:
    Jan 17, 2010

    Jan 17, 2010
    112
    7
    36
    Hello all,
    I've just spent a solid hour searching old posts and couldn't come up with a solution. My wife has a S3 that needs a factory reset, and I'm backing everything up. It's proving to be a PITA... here's why: Her calendar events and contacts (which have all been entered by her on the device for the past 2 years) have been against the default 'Phone' account, rather than the 'account@gmail.com' which is second in the drop down list.

    On the calendar events, I went into every one manually and by selecting EDIT, I was able to re-associate it to her gmail account. So those are now in her GMail calendar and will sync automatically. Unfortunately, you can't do this with Contacts. I found the Export to USB option in the settings. So I docked the S3 to my PC, ran the export, but can't find a file anywhere in the phone directory. I was hoping to edit the file and re-import the contacts.

    Do you all know of a way to accomplish this? If I can't get these contacts re-associated to her gmail account, I'm looking at manually keying all 200 records into Gmail Contacts manually. Gross!

    Thanks!

    UPDATE: So I used the Contact > Export function as I noted above. Then I turned right around and used the Import function. It brought up file explorer on the phone, I select the vcf record that had been exported, and then it prompted me to select which association. So quickly select the gmail account profile rather than phone profile. And they all came back in with the Gmail association. Now at this point, I have double entries for every contact... one associated with "phone" and another than associated with "email@gmail.com". So I went into Settings > Manage Applications > and did a Clear Cache on the Contacts. That clear all the "Phone" contact associations" and left me with only GMail associations. All good! Thought you guys might want to know :)
     

    Advertisement

    funkylogik likes this.

Share This Page

Loading...