1. Are you ready for the Galaxy S20? Here is everything we know so far!

*SOLVED* How to unlock a smartphone?

Discussion in 'Android Lounge' started by KetchupAndFries, Jul 25, 2013.

  1. KetchupAndFries

    Thread Starter

    I am in a desperate need to unlock my old Samsung Captivate. I contacted AT&T and they gave me an unlock code and a set of weird instructions that didn't work. I also put a TMOBILE sim card in and put in the unlock code they gave me but it failed. I only have a few more tries before it locks up forever. I told this to ATT but they told me to contact Samsung who did not respond to my numerous messages. Now I really need some help with my Captivate as I am leaving for Europe on 08/02. Just so you know, I know how to root a phone, I also know how to install a custom ROM in case any of this will be required. I'd appreciate any help you can give me with this. Thank you

    EDIT - Also if you need it I can post my IMEI and the unlock code.

    1. Download the Forums for Android™ app!


  2. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    I think your IMEI is something you'll want to keep private.

    Let's see if we can you some help here. :)
    funkylogik likes this.
  3. Frisco

    Frisco =Luceat Lux Vestra=

    Have you tried any of the unlock code generator patches?

    SamsungUnlocker_v1.4 | Samsung Network/Sim Unlock Code Generator/Patcher

    Many out there... but the Captivate's been around a while. ;)
    D-U-R-X, Doc, EarlyMon and 1 other person like this.
  4. LilBit

    LilBit Extreme Android User

  5. KetchupAndFries

    Thread Starter

    Thanks for the quick responses. I will try these when I get home.
    El Presidente, LilBit and EarlyMon like this.
  6. KetchupAndFries

    Thread Starter

    So I tried the smartphone unlocker program that was in that youtube video and it gives me an error when I run it.
    Here is everything that it says:
    One click Unlock for Galaxy S Family
    Copy nv_data.bin
    * daemon not running. starting it now *
    * daemon started successfully *
    failed to copy '/efs/nv_data.bin' to './nv_data.bin': Permission denied
    Extract code

    SGUX v0.92b (C) 2010 By Mark0 & rbnet
    Samsung Galaxy Unlock code eXtractor
    (based on info by rhcp0112345 & RazvanG)

    * Error: unable to find file <.\nv_data.bin>
    Could Not Find C:\Users\God\Downloads\Galaxy_S__unlocker_windows\Generate Unlock
    Windows\Generate Unlock Windows\nv_data.bin
    Please donate to DagentooBoy for the scripting
    Please donate to rbnet.it and marcopon for the SGUX utility used in the script
    Special thanks to Bowsa2511 for helping with the script
    Script complete!
    Press any key to continue . . .

    EDIT: Do I need to root the phone and add superuser before I run this?
  7. KetchupAndFries

    Thread Starter

    Any ideas as to how I can fix the issue with the unlocking program?
  8. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Maybe google their names, see if they have an account here or another forum?

    I know time is getting short, and it sounds like they left files out. :(
  9. KetchupAndFries

    Thread Starter

    After hours of working on this I finally solved it. Basically what did it for me was one of the links I found on a forum post. Samsung Galaxy S Unlocker
    At first I had issues with it not working but here is what I did to make it work.
    1. My firmware version was 2.3.5, so I had to flashback to 2.1 to make this work for me. Here is the link where I found the stock 2.1 ROM http://forum.xda-developers.com/showthread.php?t=1300843
    2. Then I had to root the phone, the easiest way for me was to download that famous update.zip file, copy it to the phone storage (Root directory), and run it from recovery mode.
    3. Then I had to download the Android SDK package so that I could run ADB and ADB shell. Android SDK | Android Developers
    4. After I got it, I unziped the whole thing to C:/ADB
    5. Then I made sure that I can run adb from the console. To do that right-click computer, hit Properties, hit Advanced System Settings, hit Environment Variables, scroll until you see Path and hit edit, there add the line ;C:\adb\sdk\platform-tools and hit OK until you are out.
    6. Then I followed the instructions at Captivate & Vibrant Unlock Instructions
    The simple method worked for me, I downloaded the two .bat files and ran them and the phone was magically unlocked.

    In addition to that I installed cyanogen mod and the phone runs smooth as butter now. Getting it done was a pain, but I learned a lot in the process. Hope this helps somebody.
  10. EarlyMon

    EarlyMon The PearlyMon
    VIP Member


Share This Page