1. Are you ready for the Galaxy S20? Here is everything we know so far!

[SOLVED] Please help: Insufficient Storage Space Error, after root

Discussion in 'Android Devices' started by SwoRNLeaDejZ, Jan 1, 2013.

  1. SwoRNLeaDejZ

    SwoRNLeaDejZ Android Expert
    Thread Starter

    I rooted over a week ago and ever since have been receiving an error when i try to download about 35% of apps from the play store. Video attached. Any ideas?


    Thanks in advance


    If this happens to you after rooting, go to the play store and follow these steps:

    2. Install it
    3. Open it, if prompted, grant it super user access through superSU
    4. Tap menu, then settings
    5. Scroll down to Install Location
    6. By default it is set to external, change it to automatic.
    7. Exit Link2SD and try downloading an app that was not working before, again, it will work now

    Link2sd v2.3 download: http://www.sendspace.com/file/bh4c89

    :) so glad this is finally fixed. Thanks for the help guys


    The Motion is currently on firmware version F. For some reason, every time they release a new firmware, at least one app still will not update or install. For firmware E it was MixZing and for firmware F it was MX Player. Not sure why this is, if I find a workaround I will add it to this OP.

    FisheyLP, Frank Kh, extensive and 4 others like this.

    1. Download the Forums for Android™ app!


  2. traajik

    traajik Android Enthusiast

    uninstall google play updates, also clear it's cache and wipe data from the built in app manager.

    also maybe find a googleplay or androidmarket.apk from the net somewhere and install that instead.

    happens to alot of people. problem only temporary though. i'm posotive there's been a thread created about this here in this phones sectrion somewhere if you want to look.
  3. twogbsd

    twogbsd Android Expert

    Have you tried the unbrick guide? Factory reset? Rebooting?

    On a side note, what app do you use to record your phone like that?
  4. SwoRNLeaDejZ

    SwoRNLeaDejZ Android Expert
    Thread Starter

    I just spent 2 days customizing my phone with Nova Launcher to get it exactly how I wanted it in a factory reset would wipe all of that out not really an option...

    I believe the screen recorder I used was the screencast demo in the play store, 1 of the few app that will actually install on my phone ;-)
  5. SwoRNLeaDejZ

    SwoRNLeaDejZ Android Expert
    Thread Starter

    Thanks for the help. Did some searching, and found a working solution. Added it to the OP.
  6. sammyz

    sammyz LG Whiz Kid

    Can you rename the title with [SOLVED] at the beginning? That would be great :D
  7. SwoRNLeaDejZ

    SwoRNLeaDejZ Android Expert
    Thread Starter

    I tried to, won't let me change the title

    Edit: nvm, figured it out
    sammyz likes this.
  8. bart2201

    bart2201 Android Enthusiast

    I can't get link2sd to work. It shows error insufficent storage. I've tried reloading it and made sure it was up to date. Also Zd box won't allow moving any apps to the sd card.

    I have link2sd set to automatic, doesn't help.

    KA24DERACER Well-Known Member

    Also, after uninstalling Google Play updates, wiping the cache and data, I also had to go through and delete any left over .odex files from bloatware I had cleaned out. doing all of that I can guarantee will get rid of the issue.
  10. SwoRNLeaDejZ

    SwoRNLeaDejZ Android Expert
    Thread Starter

    You can also try an app called Market Fix, I heard that is supposed to also fix the error
  11. Cidious

    Cidious Lurker

    Marvelous!!! I've tried everything to get rid of this bug, even the lucky patcher fix, which I couldn't install because I had insufficient storage, lol. This works perfectly! two thumbs waayy up and hand jobs all around to these ppl!
    SwoRNLeaDejZ likes this.
  12. ellrllgllo

    ellrllgllo Newbie

    I've been working on this same problem for a day and a half. I first noticed it when I uninstalled HeyTell, then attempted to reinstall it and got the "Insufficient Storage Available" message.

    I went through a few different options to fix the problem(cleared my cache, cleared the data from Google Play Store/Framework, removed fixes and backups in Lucky Patcher, etc) and nothing worked.

    Some time before this issue arose, I had installed Link2SD but hadn't set it up/used it(I'm still relatively new to Android in general). After reading this post and selecting 'Automatic' in Link2SD, I was able to reinstall HeyTell without issue.

    Many thanks to SwoRNLeaDejZ!!!
    SwoRNLeaDejZ likes this.
  13. ThiSidUp

    ThiSidUp Lurker

    Tried about everything her and still no luck. Insufficient Storage Available.

    Tried uninstalling everything I added after I rooted . . no good.
    I think it all started right after I tried installing Titanium, then ROM manager. Didn't do anything with ROM manager other than do a clockwork backup.

    Link2SD won't work on my device, so it says. Although I installed it, it says "Apps2SD is not supported on your device. Because your device has a primary external storage which is emulated from the internal storage. You can link the app in order to move its files to your SD card."

    I have no clue what to do.
  14. MrGlowy

    MrGlowy Android Enthusiast

    Don't use ROM manager!!
  15. ThiSidUp

    ThiSidUp Lurker

    Kinda too late for that now . . lol. I didn't use ROM manager other than running a clockwork backup. Uninstalled ROM Manager but nevertheless the problem persists.

    Any ideas what to do to fix the issue? I'm seeing that a lot of people are having the same trouble.
  16. SwoRNLeaDejZ

    SwoRNLeaDejZ Android Expert
    Thread Starter

    Honestly, use the unbrick guide, get back to base firmware, then root again, if you end up with the insufficient storage error, follow this guide. Wouldn't use ROM Manager the second time around ;)
  17. sammyz

    sammyz LG Whiz Kid

    And factory reset as well.
  18. puyow18

    puyow18 Android Enthusiast

    I get the same problem. Anyone else get this or have a solution?
  19. SwoRNLeaDejZ

    SwoRNLeaDejZ Android Expert
    Thread Starter

    I just installed the newest version and it says the same thing. Look for an older version. I will try to find one for you as well and add it to the OP
  20. SwoRNLeaDejZ

    SwoRNLeaDejZ Android Expert
    Thread Starter

    Ok so this emulated check was something they added after version 2.3. I have added a link for version 2.3 to the OP but if you want it here it is: http://www.sendspace.com/file/bh4c89

    That version will definitely work, i tested it ;)
    puyow18 likes this.
  21. klokovitz

    klokovitz Lurker

    Link2SD won't work on my device, so it says. Although I installed it, it says "Apps2SD is not supported on your device. Because your device has a primary external storage which is emulated from the internal storage. You can link the app in order to move its files to your SD card."


    so do i, even downgraded to Link2SD v2.3, still the same. problem not yet solved. anyway, maybe this proc is for LG users only. been using samsung tab 2 p5100, note 2 and s3. all rooted. better modify the thread title for LG units only.
  22. extensive

    extensive Lurker

    i was getting this error and couldnt figure it out until i came to your post. i forgot i changed this setting with rom toolbox pro...went in and changed it to auto and it is great! thank you so much.

    so just a note to everybody else, you can use rom toolbox pro as well.
  23. orion2323

    orion2323 Newbie

    I had a problem where a few apps would give me the insufficient storage error when trying to install
    New apps would install OK, just certain apps I had uninstalled @ some point

    I was able to bypass this by navigating to the root folder, data/data and then renaming the existing folder for the app I was trying to install.
    I had to use logcat to capture the actual error and it told me that the error was "app or folder already exists", it also showed me the path
    Then I used simple file explorer, with root permissions and renamed those folders (any name...couldn't delete them)

    After this, the problematic apps installed just fine :)
  24. AishaHumaira

    AishaHumaira Lurker

    thanks a lot ! this solved my problem. thanks you so much. i am so happy. i tried some other ways to fix this problem but to no avail. :)
  25. AishaHumaira

    AishaHumaira Lurker

    and i forgot to tell you that my phone can't install link2sd v2.3 . so,i tried using link2sd of the latest version and it still works. thnks again.

LG Motion 4G Forum

The LG Motion 4G release date was August 2012. Features and Specs include a 3.5" inch screen, 5MP camera, 1GB RAM, Snapdragon S4 Plus processor, and 1700mAh battery.

August 2012
Release Date

Share This Page