1. Download our Official Android App: Forums for Android!

Support [SOLVED] Problem Connecting Bionic to PC - PLEASE HELP!

Discussion in 'Android Devices' started by Reverence, Sep 10, 2011.

  1. Reverence

    Reverence Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    250
    Joined:
    Jun 21, 2010

    Jun 21, 2010
    250
    19
    38
    So I have all my files from my old 2GB SD card that I had on my Incredible backed up on my computer.

    I went to connect the Bionic to my computer and it defaulted to USB storage mode and 2 removal disk drives appeared in my computer. When I click one of them (H:), it brings me to my SD card. However, when I click the other one (I:), it says please insert a disc.

    So, to access my internal storage, I have to choose PC mode on the phone and then it reconnects to the computer, and in my computer both removable disk drives disappear, but MTP Device under Audio devices appears. From there I can then access my DATA AND MEDIA folders, and can copy pictures over. But the issue is it won't let me copy over any of my backup files for my apps over because they aren't media files.

    This isn't normal, and any suggestions on how to get everything transferred from my old SD card to my new SD card or phone would be greatly appreciated.

    Not to mention that the restore features on some apps is all messed up because the SD card is listed as sdcard-ext and internal storage is listed as SD card. What a mess.
     

    Advertisement

  2. Reverence

    Reverence Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    250
    Joined:
    Jun 21, 2010

    Jun 21, 2010
    250
    19
    38
    The only work around that I have found so far is to copy the files from the computer to the external SD card. And then use ES File Explorer on the phone to copy the files from the external SD card to the internal SD card/phone storage.
     
  3. Reverence

    Reverence Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    250
    Joined:
    Jun 21, 2010

    Jun 21, 2010
    250
    19
    38
    Another update. I have tried so many things, and still it won't work. I have tried a different USB port. Restarted both the computer and the phone. Tried taking the sd card out and mounting it.

    I think it has something to do with the internal storage not being able to unmount, which seems like a hardware issue. Because I decided as a last resort I would try formatting the internal storage, and when I went into the settings to do that, it says unmounting internal storage, and just keeps doing that but never succeeds.
     
  4. Reverence

    Reverence Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    250
    Joined:
    Jun 21, 2010

    Jun 21, 2010
    250
    19
    38
    Really felt like I was talking to myself here, which I was, haha. But regardless, since this thread is here and I'm sure other people will run into this issue, I will post how I resolved it.

    PROBLEM SOLVED

    For some reason it seemed as though the internal storage did not want to mount/unmount correctly for whatever reason. Steps to relieve this issue were to perform a battery pull. Remove the SD Card. Re-insert the battery and turn on the phone. Connect the phone to the computer, give it 30 seconds (make sure usb mass storage is selected in notification drop down bar) and it will find the internal storage and mount it so the files can be accessed. After verifying that it successfully mounted and unmounted, disconnect phone from the PC. Reinsert SD Card, phone will recognize SD card, and then from then on forward when you connect the phone to the PC, it should allow you to access both the internal storage (sdcard) and external storage (sdcard-ext). Case closed, lol.
     
    HotDawg likes this.
  5. johnlgalt

    johnlgalt Antidisestablishmentarian
    Rank:
    None
    Points:
    453
    Posts:
    9,415
    Joined:
    Oct 28, 2009

    Oct 28, 2009
    9,415
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    tomw3141 likes this.
  6. Reverence

    Reverence Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    250
    Joined:
    Jun 21, 2010

    Jun 21, 2010
    250
    19
    38
  7. amoeller

    amoeller Newbie
    Rank:
     #1,378
    Points:
    18
    Posts:
    19
    Joined:
    Jul 20, 2010

    Jul 20, 2010
    19
    18
    18
    I had this same issue. I seem to have solved it from what I can see. I backed up everything from both internal and external SD cards to my PC. Then I did a full format on both internal and external SD cards. The external one I used a SD card reader and formatted to FAT32 with defaults. To format the internal one you have to go into Settings and into Storage. If it hangs on Unmounting when you hit format, then reboot the phone. As soon as the phone is started try again and then you can restore your both SD card data.
     
  8. tjreishus

    tjreishus Android Enthusiast
    Rank:
    None
    Points:
    88
    Posts:
    746
    Joined:
    Nov 8, 2009

    Nov 8, 2009
    746
    94
    88
    Airline Pilot
    So this brings up some good questions about the storage and how things are stored.

    On the internal storage there is 3.5GB of "application storage," which is where apps install by default. Then you have 8GB of "Internal storage," on which you can save photos, movies, music, etc. Apps also can store data here as well, so you'll likely see it decrease over time. So this leaves us with 8GB to use, but app data needs this space. How much space are you willing to use of this 8 for your personal storage of files? Im sure it would be difficult to exceed 2 gigs of app data so your probably safe storing 6GB, but this is all just a guess.

    What does everyone else think?
     
  9. rebar42

    rebar42 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 15, 2011

    Sep 15, 2011
    1
    0
    5
    OMG !! Your solution worked for me !!!! Thanks so much for your advice.
     
  10. Lars

    Lars Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,439
    Joined:
    Mar 24, 2010

    App data is stored in a different partition /data
    Webtop uses the internal flash too.
    8gig /sdcard
    4gig /data/app or /data
    4gig webtop
    16gig /sdcard-ext or whatever size you have in there.
     
    johnlgalt likes this.
  11. johnlgalt

    johnlgalt Antidisestablishmentarian
    Rank:
    None
    Points:
    453
    Posts:
    9,415
    Joined:
    Oct 28, 2009

    Oct 28, 2009
    9,415
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Ahhh, so there are 2 SDCards - the internal, split into 4.2 / 3.8 / 8 and the external.

    So, the ROM and RAM are still internal NAND flash?
     
  12. HotDawg

    HotDawg Android Enthusiast
    Rank:
    None
    Points:
    63
    Posts:
    338
    Joined:
    Nov 24, 2009

    Nov 24, 2009
    338
    33
    63
    data analyst
    Okay, finally got around to doing this. Wouldn't recognize internal SD card with or without ext SD card. Tried USB Mass mode and PC mode. Grr. So, I still have no access.
     
  13. johnlgalt

    johnlgalt Antidisestablishmentarian
    Rank:
    None
    Points:
    453
    Posts:
    9,415
    Joined:
    Oct 28, 2009

    Oct 28, 2009
    9,415
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    It's not instantaneous - on my system it can take up to a minute for the internal card to be recognized by the system using USB Mass Storage selection.

    On PC it lumps everything together as one device, there is no separation of hte 2 (or more) partitions.
     
  14. HotDawg

    HotDawg Android Enthusiast
    Rank:
    None
    Points:
    63
    Posts:
    338
    Joined:
    Nov 24, 2009

    Nov 24, 2009
    338
    33
    63
    data analyst
    Yeah, I worked with it for a long time - gave it plenty of time. Maybe I should try again - I have a 32GB ext card in and it might take longer.

    It will see the Droid in PC mode, but shows no files and doesn't allow browsing. In USB Mass mode it only shows the external card - which is better than nothing, I can cut and paste. I don't need to do this very often anyway.

    We can take the conversation over to zebrajeb's thread since this one is "solved" :)
     
  15. daadco

    daadco Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jun 24, 2010

    Jun 24, 2010
    2
    0
    5
    I tried this, it worked 1 time only & then never again. I only see the card not the internal storage??????
    Any other ideas to resolve this?

    Help doesn't work for my bionic
     
  16. johnlgalt

    johnlgalt Antidisestablishmentarian
    Rank:
    None
    Points:
    453
    Posts:
    9,415
    Joined:
    Oct 28, 2009

    Oct 28, 2009
    9,415
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    OK, let's walk through the entire procedure to get it working. Start from the beginning and let me know what you do step by step.

    Also, what operating system are you running on your computer, and do you have the latest drivers from my signature?
     
  17. HotDawg

    HotDawg Android Enthusiast
    Rank:
    None
    Points:
    63
    Posts:
    338
    Joined:
    Nov 24, 2009

    Nov 24, 2009
    338
    33
    63
    data analyst

    Mine did the same - I could see them all for about ten seconds, then nothing.
     
  18. Duckster

    Duckster Well-Known Member
    Rank:
     #534
    Points:
    48
    Posts:
    219
    Joined:
    Jul 20, 2010

    Jul 20, 2010
    219
    24
    48
    I'm curious as to how many of you who are having this problem is using your previous USB charging cable or the one that came with the Bionic. I was having this same problem until someone told me that I needed to use the cable that came with the Bionic. I stopped by the Verizon store and inquired but the employee there quickly dismissed my comments. Well, I got home and tried using the old cables with no success. I then used the USB that came with the Bionic and viola...it worked! Even customer support has not heard of this! The argument was that there are NO drivers in the cables (duh). My argument is that all it takes is one more wired connection in the Bionic USB cable and it works. I still can't navigate around my screen and you need to be on a HOME page when connecting.

    I hope this works for you as well.:)
     
  19. Thom

    Thom  
    VIP Member
    Rank:
     #20
    Points:
    1,243
    Posts:
    11,701
    Joined:
    Feb 16, 2011

    Feb 16, 2011
    11,701
    4,843
    1,243
    Male
    Software Developer
    Keene, NH USA
    I spent more time than I care to recall on this one also.

    I would diddle and diddle and for no apparent reason it would start to work. It would work once. The next time I connected it wouldn't.

    I just tried something that seemed to work.

    I am connected with the USB cable that came with my Droid X cradle (last year). The Home screen was on my Bionic. It was only recognizing my SD card.

    With it still connected I powered the Bionic off and powered it back on.

    When the Home screen was displayed the SD card was displayed. After 12 seconds later another disk drive displayed phone memory.

    I unplugged the USB cable and both went away. I plugged in the USB cable and only the SD card was shown. I powered off and powered on and both appeared again.

    This comes pretty close to PROBLEM SOLVED
     
  20. Duckster

    Duckster Well-Known Member
    Rank:
     #534
    Points:
    48
    Posts:
    219
    Joined:
    Jul 20, 2010

    Jul 20, 2010
    219
    24
    48
    FYI, I checked again and I get both drives showing by using the cord that came with my Bionic. When I tried another cord, it froze the phone and I had to unplug to get the phone to respond again. It seems that there is something like an extra connection in the Bionic cord that makes it particular. I'm just surprised (ok...not really) that Verizon/Motorola hasn't addressed this yet. My old cord charges fine...just no looking at the cards within.
     
  21. Thom

    Thom  
    VIP Member
    Rank:
     #20
    Points:
    1,243
    Posts:
    11,701
    Joined:
    Feb 16, 2011

    Feb 16, 2011
    11,701
    4,843
    1,243
    Male
    Software Developer
    Keene, NH USA
    Did you try the solution I found ... turn it off and turn it on again?

    My GUESS is that the condition is sometimes raised preventing it from recognizing the memoiry and the condtion is reset with a power off/power on.

    I get the same result with the cable that came with ...

    Droid X (last year)
    Droid X Cradle (last year)
    Bionic (this month)

    This reset ALWAYS works for me.

    (Also ... I do not have to have the Bionic on the Home screen when conecting the USB cable. The displayed screen seems to have no effect.)

    ... Thom
     
  22. Duckster

    Duckster Well-Known Member
    Rank:
     #534
    Points:
    48
    Posts:
    219
    Joined:
    Jul 20, 2010

    Jul 20, 2010
    219
    24
    48
    Yes, I tried your suggestions but they did not work for me. My suspicions is that the older LG cable I tried did not work because it may have been missing a connector wire within the cable itself. Over on the Motorola forum, they are having some great discussions about this and it seems that using the original cable that came with the Bionic is solving their issues.

    As for being able to use it on any page other than the home page, I have not much luck there. Some of this may have to do with the computer type as well (I'm using it on a Vista Laptop). I need to try it on my desktop Windows 7 (x64 bit) later.
     
  23. Thom

    Thom  
    VIP Member
    Rank:
     #20
    Points:
    1,243
    Posts:
    11,701
    Joined:
    Feb 16, 2011

    Feb 16, 2011
    11,701
    4,843
    1,243
    Male
    Software Developer
    Keene, NH USA
    It soundes like you had a different problem than the one I was having.

    Mine has stopped happening. Now that I have a solution I don't seem to need it.

    My workstation is a dual quad-core Windows 7 x64 machine with all maintenance applied.

    Since none of the 60 people who read this have chimed in I conclude that it might be that I was running into an internal timing problem unque to my enviropnment.

    Has anyone else had the hang and tried the power off/power on solution?

    ... Thom
     
  24. barry.holroyd

    barry.holroyd Newbie
    Rank:
    None
    Points:
    16
    Posts:
    11
    Joined:
    Oct 10, 2011

    Oct 10, 2011
    11
    2
    16
    Yes, I'm having the same problem. I tried the pull battery approach last week and it partially helped -- it allowed me to see the internal drive if the SD card wasn't installed, but never both drives at once. I just tried it again and without the SD card both drives show up but are not accessible (either read or write). The fact that for me (and many others) it *sometimes* works and, without changing anything, then stops working, indicates that there may not be a stable solution, at least for many of us.

    Barry

     
  25. Thom

    Thom  
    VIP Member
    Rank:
     #20
    Points:
    1,243
    Posts:
    11,701
    Joined:
    Feb 16, 2011

    Feb 16, 2011
    11,701
    4,843
    1,243
    Male
    Software Developer
    Keene, NH USA
    With the USB cable connected, pull down the notices, select USB Connection
    Make sure USB Mass Storage is selected

    Then do the poweroff/poweron without opening the case.

    Let me know.

    (It ALWAYS works for me.)

    ... Thom
     
    gueeds23 likes this.

Share This Page

Loading...