1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Solved]USB bricked messed up badly :(

Discussion in 'Android Devices' started by Exiled_SouL, Jun 10, 2011.

  1. Exiled_SouL

    Exiled_SouL Newbie
    Thread Starter

    Problem Solved,follow this guide


    Hi,All..yesterday i flashed gingervellain 2.5 rom without any problem but after i tried to browse the market,things went south.it started reboot my phone and bootloop

    then i tried to restore my nandroid backup from recovery and got sd card mount failed+i was unable to flash and android sdk also failed to recognize my device after that so no adb shell

    but in windows device manger when i connected my phone usb via fastboot it shows my device was connected but unable unroot with ruu.exe from pc.

    i was usb bricked before but fixed it with adb shell n terminal emulator but this time it's not working,i tried xda n this forums possible usb brick fix for rooted(s-off) nothing seemed to work..

    then i got desperate and unrooted my desire with pb99img.update from hboot as i thought it gonna fix the brick now things are more messed up and i am stuck on stock froyo2.2 ,s-on without any usb function.
    then i tried the unrooted(s-on) desire usb fix and stuck

    Copied the exploit binary (rageagainstthecage-arm5.bin), the flash_image and modifed mtd0.img to the sdcard via an external card reader.

    tried to Copy the files to the Terminal app data directory using the command

    cat /sdcard/rageagainstthecage-arm5.bin > /data/data/jackpal.androidterm/shared_prefs/rageagainstthecage-arm5.bin
    It says invalid directory/file not exist

    this is the thing i did in past 10hr still no luck..now my question is can i fix this problem by myself or did i just permanently usb bricked my desire sorry for long post i need help badly and pardon my English :(

    1. Download the Forums for Android™ app!


  2. Rastaman-FB

    Rastaman-FB Extreme Android User

    if you flashed a pb99img or RUU and its still having the problem then you have some other hardware issue as RUU/PB99img would fix the misc partition

    just wondering... have you tried connecting to a different computer or using a different cable just to make sure its not that?
  3. Exiled_SouL

    Exiled_SouL Newbie
    Thread Starter

    ya tried different cable and laptop,desktop still nothing..should i reflash the pb99 update and is it possible that gingervellain 2.5 kernel caused this problem??
  4. Rastaman-FB

    Rastaman-FB Extreme Android User

    its possible that something killed the misc partition. its usually a recovery that can cause a problem.
    if you flashed cwm 3.x.x.x then its probably that

    cwms after are baddies
  5. Exiled_SouL

    Exiled_SouL Newbie
    Thread Starter

    is there any way to fix it..right now i am trying this from terminal emulator

    cat /sdcard/rageagainstthecage-arm5.bin > /data/data/rageagainstthecage-arm5.bin
    cat /sdcard/flash_image > /data/data/flash_image
    cat /sdcard/mtd0.img > /data/data/mtd0.img
    cd /data/data/
    chmod 755 rageagainstthecage-arm5.bin flash_image(got stuck here it says no directory)


    restart the terminal

    cd /data/data/
    ./flash_image misc mtd0.img
  6. Rastaman-FB

    Rastaman-FB Extreme Android User

    link me the guide you are using please
  7. Exiled_SouL

    Exiled_SouL Newbie
    Thread Starter

    after 24hrs of restless search(androidforum/xda) for solution i finally got it :DDDDDD
    this 2 thread help me alot to understand what i need to do
    Code (Text):
    1. http://forum.xda-developers.com/showthread.php?t=813476&page=2
    2. http://forum.xda-developers.com/archive/index.php/t-700734.html

    here is the steps i did

    after i unlocked my sd card via fastboot command"fastboot oem enableqxdm 0" sd card recognized by phone and i can browse it via file explorer.

    then i copied the visionary+(it gave me temporary root access which is needed to work this whole thing out).
    root explorer,terminal emulator apk and those usb bricked update file(image_flash,mtd0.img) to sdcard from pc via card reader and installed them.

    before copy those update file on sd card i edited the mtd0.img to put correct cid n rom info via hex editor.

    after that i copied those update file in phone memory
    /data/data/ and set permission for r/w and execute with the help of root explorer as i got root permission :D

    after that i simply typed this command in terminal emulator
    /data/data/flash_image misc /data/data/mtd0.img"

    Rebooted my phone and voila usb brick is gone htc sync,usb tethering,sd card mount,charge everything is working :D

    Note-you don't need the rageagainstthecage file which only need if you try to get root access via terminal emulator which is lengthy n complicated but with visionary+ you can get root access with 1 click and it's much easier than typing command in T.E..

    hope this information helps other who got stucked like me :)
    Rastaman-FB likes this.
  8. Rastaman-FB

    Rastaman-FB Extreme Android User

    yes very good to know, ive subscribed to this thread . will be one for the toolbox
  9. Exiled_SouL

    Exiled_SouL Newbie
    Thread Starter

    another strange thing happened when i tried to reroot with unrevocked

    at the end of root process i got cid missing error..after that i opened my app drawer n saw the superuser icon is there..

    then i rebooted my phone i opened recovery which take me to cmw recovery 2.5 or something forget the version number but text was green..
    there is also some error like E:\cach,misc partion something

    after that i rebooted my phone re-formated n partitioned my sdcard via g-parted..then s-offed my desire via alpharev..which bring me back to cmw then i wiped data/cache partition/dalvik cache..after that e:\ cache partition error was gone.

    then i changed the hboot partition to alpharev-cm7 via android flasher,flashed the rcmix-hd(cm-7hboot) rom without any problem..

    now what's bugging me is how can i got the superuser,root access,cmw-recovery while rooting end up with cid missing error? as i read on forum if cid missing error shows up during root process then root is unsuccessful:thinking:
  10. Rastaman-FB

    Rastaman-FB Extreme Android User

    the new hboots fix misc partition
    and cid missing error is a wierd one, it could mean unsuccessful but it can also mean you have rooted but something is up

    what is the pvt version on your device and the erase size

    if its pvt4 you need to do this in android terminal and do this
    cat /proc/mtd
    if its 40000 then you need to flash amonRA
    any CWM after causes problems over time with desire (would explain the usb brick)
  11. Exiled_SouL

    Exiled_SouL Newbie
    Thread Starter

    Mine is pvt4
    erase size-40000

    about amonRA,if i flash amon ra recovery do i need to reflash my rom?
  12. Rastaman-FB

    Rastaman-FB Extreme Android User

    your misc part error on is due to the erase size
    you will not need to wipe after flashing amonRA2.0.1 you can flash it from fastboot as you are s-off

    any backups made with CWM will not be valid and must not be used or it will cause usb brick
    Exiled_SouL likes this.
  13. Exiled_SouL

    Exiled_SouL Newbie
    Thread Starter

    Now that's clear some issue i didn't understand thanks Rastaman.I will flash amonRA.:)
    Rastaman-FB likes this.
  14. Rastaman-FB

    Rastaman-FB Extreme Android User

    no problem and welcome to the forums. were a friendly bunch here and help eachother out with all sorts of stuff

    linger about in the "all things Root" section and read the guides there. see the things that come up, hell you might be able to help some people there.

    the erase size issues etc are written in our guides as SUroot, myself and a few others have gone over them and tried to accommodate every eventually.
  15. Exiled_SouL

    Exiled_SouL Newbie
    Thread Starter

    i will and i browse this and XDA forum regularly.and things i like about this forum is friendly attitude and quick response from expert user like you,Suroot :)
  16. maniX86

    maniX86 Lurker

    Did exactly the same, and worked fine til i got to the last thing:
    /data/data/flash_image misc /data/data/mtd0.img"

    as I
  17. mr-mixalot

    mr-mixalot Newbie

    Good Evening

    When I run the visionary temp root the screen just goes black?

    What am I doing wrong? :thinking:

HTC Desire Forum

Features and specs are not yet known.

Release Date

Share This Page