1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root Some help with Gparted would be appreciated..

Discussion in 'Android Devices' started by Jon_LTD, Sep 17, 2011.

  1. Jon_LTD

    Jon_LTD Android Expert
    Thread Starter

    All I want to do is partition my 16gb SD Card with a 1024 FAT32 Ext3 partition set as "primary" to use with Apps2SD+

    Will this do the trick?

    Every guide varies and I don't want to commit to doing it when I'm not sure :thinking:
     

    Advertisement

  2. SUroot

    SUroot Extreme Android User

    Do exactly what I said in the root memory faq.
     
  3. Jon_LTD

    Jon_LTD Android Expert
    Thread Starter

    SURoot

    Your guide doesn't address the questions I'm asking.

    Basically, I am ready to press apply on the following:

    New partition #1 - FAT32 - 13.84 GiB
    New partition #2 - ext2 - 1023.00 MiB

    I don't know if the ext2 is correct? As I see ext 2/3/4 banded about and I don't know what any of them do? Will it "automatically" work with Apps2sd+ supported ROMS?
     
  4. Jon_LTD

    Jon_LTD Android Expert
    Thread Starter

    I've attached on image of what exactly I am hovering "apply" to.

    I've followed the guide, but like I stated, I don't know if then partitioning the card to how I've set it up will then just allow Apps2SD+ to work? Ie, teppics74's Gingerbread Sense ROM.

    If yes, how does it work?

    [​IMG]

    I really appreciate you helping me out SURoot. Again, I'd happily buy you a pint!
     
  5. shauny13

    shauny13 Android Expert

    Looks fine to me, although i prefer ext 3. When you have installed teppics rom, set the default install location to internal and it will use the ext 2 you have made by default. Download quick system info from market to confirm this. (will show as a2sd storage).
     
    Jon_LTD likes this.
  6. Jon_LTD

    Jon_LTD Android Expert
    Thread Starter

    Ah, thanks Shauny. I'll definitely download that app. One quick question..

    Any particular reason?
     
  7. shauny13

    shauny13 Android Expert

    not really sure tbh, was just the norm when i partitioned my card.
     
  8. Jon_LTD

    Jon_LTD Android Expert
    Thread Starter

    Thanks,

    However I seem to be having a nightmare.

    My phone is only recognising the 1024 I reserved for Ext2.. And saving everything to that! I'm still on Cyanogen as I was having some seperate issues installing Teppic's Gingerbread ROM.
    I can't access my 13.84gb Partition!

    Any advice would be greatly appreciated to anyone!
     
  9. SUroot

    SUroot Extreme Android User

    go back into gparted and check what the partitions read as I would suggest
     
  10. Jon_LTD

    Jon_LTD Android Expert
    Thread Starter

    Good morning all

    After a rather late and busy night I have my phone back to working order but achieved nothing.

    SUroot, my Gparted showed exactly what my screenshot displayed as I hit apply from that. I'm still not sure what went wrong but I had to format the SD card and luckily I had my back up to cyanogen! My only thought is that my fat32 partition was the 1024 MiB and the rest was ext2 even though I read a stupid amount of guides and video's which alluded to me doing the opposite.

    Could this be what happened?

    As for flashing teppic's rom.. that's a completely different thread but neither the radio and rom would install, aborting after about 5 seconds. Very frustrating.
     
  11. shauny13

    shauny13 Android Expert

    What errors did it give? Did it fail on signature verification? If it did you can toggle that off in recovery also.
     
  12. shauny13

    shauny13 Android Expert

    ps, you probably wont even have to flash a different radio.
     
  13. Jon_LTD

    Jon_LTD Android Expert
    Thread Starter

    Morning Shauny,

    The error message I got was the following:

    [​IMG]

    As for the radio, I was told that I didn't need to but it wouldn't be a bad idea to. I figured I'd give it another go for learning purposes and experiences. Ooops!

    As for the SD Card, can you see any obvious glaring error I did what I am currently overlooking? It's quite discouraging as I don't really want to try again. I'm going to buy a 2nd SD card as my guinea pig I think.. I spent 6 hours lastnight doing one large circle and it's quite frustrating, but you guys are being as patient as ever!

    Thank you all, by the way :p

    PS: I got a similar error message with the radio
     
  14. SUroot

    SUroot Extreme Android User

    So the second time you mounted the sd card as usb mass storage, it showed exactly as it should?
     
  15. Jon_LTD

    Jon_LTD Android Expert
    Thread Starter

    When I mounted my SD card on my phone, the 1024mb partition was being used as opposed to ~14gb one.

    I copied & pasted all my old Android folders back onto my SD Card (backed up) and it was going into my 1024 partition. I was installing apps and choosing to put them on the SD Card, however I was almost out of memory. I checked under Settings > Storage, and I still had the ~14gb available. Plus when I put it in a separate card reader, Windows could only see a the ~14gb FAT32 section. I had to format it and now it's back to normal.

    It blew my mind.
     
  16. SUroot

    SUroot Extreme Android User

    Windows can only see the first partition on a sd card.

    So in the way you avoided my question, I assume you didn't go back into gparted a 2nd time to check? That's fine.
     
  17. Rastaman-FB

    Rastaman-FB Extreme Android User

    you are getting this error cos you are using a shit version of clockwork mod
    if you are pvt 1,2,3 or 4 20000 erase size use cwm2.5.0.7
    if you are pvt 4 40000 erase size use amonRA 2.0.1
    do not use cwm 3,4 or 5. they are fail

    if you are s-off use fastboot to flash recovery ( recoveries can be downloaded from the link in my sig) if you are not sure about fastboot use androidflasher
     
  18. Jon_LTD

    Jon_LTD Android Expert
    Thread Starter

    I didn't intend to duck the question, apologies.

    I can't say with 100% conviction I remember anything which seemed erroneous on Gparted, so I assume it partitioned as per my original screenshot.. But long story short, I cannot honestly remember. But I pressed "apply". The only thing I changed was Ext2 to Ext3 as Shauny said it was the norm for him. I figured if it worked for him with Ext3, that's good enough for me.
     
  19. SUroot

    SUroot Extreme Android User

    Yeah the first screen shot was fine. What I.wanted to know was if something had changed or gone wrong which only revisiting gparted would have told me
     
  20. Jon_LTD

    Jon_LTD Android Expert
    Thread Starter

    Wow.. Why is nothing simple? :D

    Is there any guides/FAQs regarding these processes? I feel overwhelmed by it all :(
     
  21. shauny13

    shauny13 Android Expert

    Worked fine for me first time. Only difference for me was i used a bootable cd instead of vm.
     
  22. Jon_LTD

    Jon_LTD Android Expert
    Thread Starter

    Ah.. I couldn't honestly say. I might have to try again and see what happens.

    It's going to be a long day.
     
  23. SUroot

    SUroot Extreme Android User

    Yes I wrote a fastboot faq in my signature
     
  24. Jon_LTD

    Jon_LTD Android Expert
    Thread Starter

    Can anyone elaborate or link me to somewhere that explains to me what that all.. Means?

    Also, I believe I am S-off. I'm just pawing through the FAQs and guides now.
     
Loading...
Tags:

Share This Page

Loading...