1. Are you ready for the Galaxy S20? Here is everything we know so far!

Someone please help, very important to me...

Discussion in 'Android Devices' started by Trav S, Jan 12, 2013.

  1. Trav S

    Trav S Lurker
    Thread Starter

    ANY HELP IS APPRECIATED HERE...So heres the back story...My wife and I bought our Samsung Galaxy S' about 2 1/2 years ago..about 3 months ago they both started acting funny, force closing apps alot, and the screen would randomly shut off and not come back on(i later found out it's refered to as the sleep of death)..My wife would plug her phone in and just let it sit and it would eventually come back on..I found a trick to tap the power button really fast and it would eventually turn back on..The other day my phone was acting weird so I rebooted it and I cant get the screen to come back on since...Anyway, I could care less about the actual phone, I sucked it up and bought a new one(not that I was happy about that either) but I did it..The Important thing to me is, I have an 18 month old daughter and ALL of her pictures are on my phone (not backed up anywhere)..I'm talking about her pictures from the hospital the day she was born until now..When I called Tmobile and Samsung the best option for me was "Factory reset the phone"..obviously I can't do that..Does anyone have a solution to this..or any possible way to atleast get the pictures off the phone???

    Things I've tried:
    Taking out battery and replacing.
    Boot to recovery screen and clearing cache.
    Leaving it plugged in for long periods of time.
    Tapping power button.
    Plugging in USB to computer(phone was set to ' Ask On Connection ').
    Removing SD card.
    Removing SIM card.
    Removing Both at the same time.

    Information about the Phone:
    Samsung Galaxy S
    Froyo 2.2
    Rooted w/ oneclickroot
    Titanium Backup Installed (but never backed up, fml)
    Anything I missed please ask...again ANY HELP HERE IS APPRECIATED, anyone with kids will understand..also, I'm not a complete noob, good with computers but just got into the Android scene..so I'm not completely up to date on it...

    1. Download the Forums for Android™ app!


  2. breadnatty08

    breadnatty08 pain rustique

    Welcome to the forums, Trav S, and sorry for your misfortune. :(
    Do you have a custom recovery installed once you rooted (like ClockWorkMod or TWRP)?
    If so, a factory reset from there shouldn't touch your photos.

    Edit: Also, do you have the correct drivers installed on your computer and an up to date version of Kies? Do you recall if you have USB Debugging enabled? If the photos are stored on your SD Card, can you remove it and have the PC read them separately?
  3. Liamo_210

    Liamo_210 Android Expert

    Is it possible these photos were stored on a external SD card if so you could take it out and put it in to another phone to check.
    breadnatty08 likes this.
  4. Mikestony

    Mikestony ~30% Carbon Black ±

    I wish I knew more about adb commands if it was possible to pull the pics from storage. If even possible. :thinking:

    Edit: like-- adb pull /sdcard/DCIM\wherever on his computer
  5. OutOfPhase

    OutOfPhase Premium Member

    It is possible if adb debugging is enabled. Since Trav S is rooted it is most likely debugging is enabled.

    1. Download sdk tools here and unzip to a folder on your c:\new folder name
    2. plug in your phone and let the drivers in stall
    3. open a command prompt in windows. If you are using windows 7 or 8 got to the folder you created using explorer and click on the folder in the top left, the address will turn blue. type cmd and hit enter. If you are using visita click start and in the search bar type cmd the hit enter. a cmd screen pops up. type cd c:\name of new folder you created
    4. type adb devices and make sure a device id comes up. it will be a string of numbers.
    5.type adb pull /sdcard/DCIM/new of folder created
    6. In using windows explorer look to see if the photos show up. they will be in a sub folder DCIM.

    Good Luck.
    Mikestony, Liamo_210 and breadnatty08 like this.
  6. argedion

    argedion The TechnoFrog

    Depending on what recovery you have there should be an option to mount the internal sdcard and you should be able to navigate to the DCIM folder for your pictures.
  7. OutOfPhase

    OutOfPhase Premium Member

    That would definitely work but we can't get the screen to come on.
  8. argedion

    argedion The TechnoFrog

    Excuse me I had one of those brain moments :D

    forgot about screen not working so then yes adb is the way to go. just adb pull and wala
  9. OutOfPhase

    OutOfPhase Premium Member

    I have those on a daily bases.
  10. Trav S

    Trav S Lurker
    Thread Starter

    Thanks for all the fast replies guys..the photos were def all stored on internal memory..ive since got a new phone and have the old sd card in new phone..usb debugging is enabled..I started messing with adb before even getting all of your replies..i was able to access all system files and whatnot, used logcat and seen all the fatal errors that were occurring..but for some weird reason I couldn't pull any files other than factory installed files..nothing I downloaded or pictures or anything..any idea why that would be?
  11. Trav S

    Trav S Lurker
    Thread Starter

    I dont recall if I had any recovery apps installed other than titanium backup and would hate to take that chance...I do have kies, but the phone is set to ask me on connection if I want kies, media player, or mass storage..debugging is enabled, files def saved to internal memory..thank you for your quick response...I just remembered I do have rom manager installed...
  12. argedion

    argedion The TechnoFrog

    you may need to try to run adb as root:

    adb root

    then run your pull command

    adb pull /sdcard/DCIM \sdcard\DCIM

    note i use Linux so not sure if you need to change the / to a \ for windows or not. you may have to play with that a little bit.
    breadnatty08 likes this.
  13. OutOfPhase

    OutOfPhase Premium Member

    i believe they will all be \

    also You might have to mount the sdcard before pulling the dcim folder.

    Type adb shell & press enter (Wait for the "#" to appear)....

    Type mount sdcard next to the "#" sign & press enter
  14. Trav S

    Trav S Lurker
    Thread Starter

    again thanks for the timely responses...when I try to use command ' adb root ' it says "cannot run root in production build " ...also, just incase anyone reads this in the future, it is frontslash, ie; /
    it also wont let me use command "su" unless I run "superoneclickroot" EACH time i plug the phone in..I also have Android Commander, and the same applies where it wont have root access unless I use superoneclickroot first...I did make some progress lastnight though by rerooting the phone (i guess) I was able to access my apps..maybe that will give you guys some more info on what went wrong?

    List of Apps:
    Ram Manager Pro
    Titanium Backup
    Rom Manager
    Terminal Emulator
    Gemini App Manager
    Root Explorer
    Game Guardian

    Thats just the apps that need SU permissions..I figure one of those caused my problem..Ram Manager Pro was the last app I installed before the crash...however the only thing on my wifes phone(hers acts funny but still works) is its just rooted the same way.

    Edit: Also, it wont let me use the 'mount' command, its asking me for all the variables ( read, write, options)...Again I appologize but its been a long time since i've used Dos and cant get the line right...I think this is going to work as soon as I get the command right.
  15. OutOfPhase

    OutOfPhase Premium Member

    change the commands to

    Type adb shell & press enter (Wait for the "#" to appear)....

    Type mount sdcard rw next to the "#" sign & press enter

    this should give you permission to pull the folder
    argedion likes this.
  16. OutOfPhase

    OutOfPhase Premium Member

    Can you see the screen now? How are you accessing the apps.
  17. Trav S

    Trav S Lurker
    Thread Starter

    I'm trying to take a screen shot and add it to this but cant figure it out but this is what it looks like when I try that

    adb shell
    # mount sdcard rw
    mount sdcard rw
    Usage: mount [-r] [-w] [-o options] [-t type] device directory
  18. OutOfPhase

    OutOfPhase Premium Member

    lets try
    adb shell
    # mount -o remount -w /sdcard
    adb pull /sdcard/DCIM/new of folder created
  19. OutOfPhase

    OutOfPhase Premium Member

    Do you know the path of the internal sd card? Such as /sdcard or mnt/sdcard
  20. Trav S

    Trav S Lurker
    Thread Starter

    same "Usage" message comes up..i'm almost positive its " /sdcard " ..i was able to pull the "mnt" folder..the mnt folder contains a folder ".lfs" then a bunch of stock pictures files ie;
    ani_upload_3_forced_upload.jpg, ani_upload_4_power_reset.jpg, ani_upload_5_user_fault.jpg, charging.jpg, dummy.bin, logo.jpg, logo_ATNT.jpg, logo_T959.jpg, movinand_checksum_done, movinand_checksum_pass, nps_fail.jpg, nps_status, param.blk

    When using "Android Commander", i can see the sdcard folder but it has a Green arrow next to in instead of a folder symbol ...i don't know if your familiar with that program, but it's supposed to be the same as ADB, except it has a GUI like windows.
  21. Trav S

    Trav S Lurker
    Thread Starter

    Does anyone know what happens when I boot into recovery mode and "reinstall packages" ...will that erase current data? ...I'm thinking something got corrupted and would like to try to it..but I don't wanna risk it if I don't know exactly what it will do.
  22. argedion

    argedion The TechnoFrog

    as long as you don't wipe you can reinstall the rom but if you cant see not sure how well that will do you.

    Your issue is why I can never stress enough about doing backups. A little preventative maintenance would have saved you all this headache. Anyway's it is what it is now lets work to get those pics off of there.

    A factory reset should be doable as I have done them on my EVO LTE and it has not wiped the contents from the internal SDCARD however I'm not familiar enough with Samsung to know if it would just do the same or if it erases all users data.
    OutOfPhase likes this.
  23. argedion

    argedion The TechnoFrog


    been doing some research here and it appears that what you do in the adb shell is only inside the device and will not link outside. I have tried to copy several things and failed however I do know you don't have to worry about mount. You will however need an External SDCARD to copy stuff to in order to get it off of the device. your shell command will be similar to this:

    shell@android:/ #

    from here you need to cd /storage

    shell@android:/storage #

    from here cd to /storage/sdcard0/DCIM
    mkdir /storage/sdcard1/mypics
    cp -r /storage/sdcard0/DCIM/* /storage/sdcard1/mypics/

    this should copy everything over to the external sdcard
    breadnatty08 and OutOfPhase like this.

Samsung Galaxy S Forum

Features and specs are not yet known.

Release Date

Share This Page