1. Download our Official Android App: Forums for Android!

Support Sony Ericsson Xperia Mini Pro WiFi Internet Problem

Discussion in 'Android Devices' started by wflead, Nov 24, 2011.

  1. wflead

    wflead Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Nov 23, 2011

    Nov 23, 2011
    4
    0
    5
    Hello, I just got a Sony Ericsson Xperia x10 mini pro. I had a very old phone before so i am not very familiar with all these apps and features on this Sony phone.

    The first day I was able to use the internet through Wi-Fi ( I think... ). I stop using the next day because I was afraid of paying for all the data because I don
     

    Advertisement

  2. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #5
    Points:
    3,118
    Posts:
    31,510
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    31,510
    22,933
    3,118
    Scotland
    Welcome to AF! :)

    If you've got an E, that looks like Data is enabled. Uncheck the mobile network -> data traffic and see if that changes things.
     
  3. wflead

    wflead Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Nov 23, 2011

    Nov 23, 2011
    4
    0
    5
    Thank you I went ahead and try what you told me.

    I unchecked the data traffic and E symbol with the up and down arrow is gone. Then i went to the browser and it said " Web page not available."

    Thank you for your help, do u have another suggestions. I would greatly appreciate it.
     
  4. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #5
    Points:
    3,118
    Posts:
    31,510
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    31,510
    22,933
    3,118
    Scotland
    On your phone, can you see an option to assign yourself a static IP address?

    If you head into the WiFi Settings, Click Menu, then Advanced, is there anything on that page which says "Static IP"?
     
  5. wflead

    wflead Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Nov 23, 2011

    Nov 23, 2011
    4
    0
    5
    Yes, i found under Wi-Fi setting>>> Advance>>> "Use Static IP"

    But it is not checked.

    Should I check it?
     
  6. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #5
    Points:
    3,118
    Posts:
    31,510
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    31,510
    22,933
    3,118
    Scotland
    Yeah, no harm in giving it a shot. You'll need to enter some info though. It will relate to your home network. Do you know whats required or do yo want a walk through?
     
  7. wflead

    wflead Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Nov 23, 2011

    Nov 23, 2011
    4
    0
    5
    A walk through would be great.

    Thank you
     
  8. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #5
    Points:
    3,118
    Posts:
    31,510
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    31,510
    22,933
    3,118
    Scotland
  9. gopu18

    gopu18 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Nov 30, 2011

    Nov 30, 2011
    1
    0
    5
    These didn't work for me. Can anyone please detail me what to do?

    My xperia k10 mini is detecting my home wifi. but after the message "Connecting" it is showing disconnected. Password for my wifi given in the phone is also correct.
     
  10. shreteh

    shreteh Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 27, 2012

    Mar 27, 2012
    1
    0
    5
    i faced this problem today and found that this issue Related with router so you have to Disable MAC address in wireless setting and it will be work !
    in shaa Allah = Allah willing,
     

Share This Page

Loading...