Spacebar and "type to compose" box issue

Got the Mytouch last night and love it, but does anyone else have an issue where when going to text the "type to compose" box isnt very responsive? It's like I have to tap on the top of the box rather than inside of it. The same goes with the space bar. I thought maybe it was the screen protector but taking it off made no difference. I also tried holding the menu key to bring the keyboard up, which pushes the box to the middle of the screen and its still the same issue, so I've pretty much ruled out it being defective.

Could someone else try and see if theirs does it to?

I am currently on the latest cyanogen mod, but also had the problem fresh out of the box on 1.5.


Android Enthusiast
Try recalibrating the screen and see what happens.

Settings > Locale & Text > Touch Input > Text Input > You have two options: Calibration tool or Reset Calibration


Thread starter
calibration tool always crashes when I open it. Reset doesn't help. I tried the demo unit at tmobile and it did the same, so at least mine isn't defective. Really annoying tho.