1. Download our Official Android App: Forums for Android!

Support Speaker phone turns itself ON, for every call

Discussion in 'Android Devices' started by charliehorse, Nov 3, 2011.

  1. charliehorse

    charliehorse Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    11
    Joined:
    Oct 18, 2011

    Oct 18, 2011
    11
    6
    16
    Out of nowhere, my speaker phone is turning itself ON when I make and answer calls. VERY annoying because people start talking before I turn it off and the world gets to hear it....

    How do I reverse this?

    Thanks!

     

    Advertisement

  2. jamesdean

    jamesdean Android Enthusiast
    Rank:
    None
    Points:
    78
    Posts:
    633
    Joined:
    Nov 14, 2009

    Nov 14, 2009
    633
    80
    78
    Have you by chance added the youmail app?
     
  3. KenB123

    KenB123 Lurker
    Rank:
    None
    Points:
    6
    Posts:
    7
    Joined:
    Oct 5, 2011

    Oct 5, 2011
    7
    1
    6
    Does Driver Mode automatically turn on speakerphone, perhaps? If so, turn off Driver Mode.

    Also check your status of Setting-> Call Settings -> VoiceMail -> Speakerphone.
     
  4. dougleppard

    dougleppard Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    76
    Joined:
    Oct 17, 2009

    Oct 17, 2009
    76
    2
    16
    Male
    innovator
    Orlando
    I have the same issue. Driver mode is off, at least as much as I know. I turned it off and on to test.

    Also I turned the automatic speaker phone on and off and that doesn't do it.

    Also rebooted.

    Now what?
     
  5. itatodd

    itatodd Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 21, 2011

    Dec 21, 2011
    1
    0
    5
    Mine is also doing the samething. And it seemed to happen after the last system update of the phone. I can't seem to figure out where or how you can turn this off. Seems to me like a bug in the lastest system update. Anyone figured out how to correct this, has it's a PITA every time you use the phone!:thinking:
     
  6. mitchigan

    mitchigan Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jan 24, 2011

    Jan 24, 2011
    2
    0
    5
    I had this happen to me before and I found that it was due to a third party power cable that I was using to charge my phone. Somehow, the phone thought I was in driving mode as a result, and I couldn't get out of it.

    Basically, I don't use that cable anymore, and I think I had to restore to factory default.

    Just wondering if you were using a third party cable rather than the one that came with the phone?
     
  7. Andhu71

    Andhu71 Lurker
    Rank:
    None
    Points:
    25
    Posts:
    2
    Joined:
    Jan 19, 2012

    Jan 19, 2012
    2
    0
    25
    I had the same problem and finally found out that the speaker phone option was to do with the GPS settings. Unknowingly I turned it off and closed the app and voila! The problem was solved. : )
     
  8. jackson86

    jackson86 Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Jan 19, 2013

    Jan 19, 2013
    1
    0
    15
    This has been driving me crazy for weeks. I have looked at every setting on my phone a 100 times. Finally came across a thread that solved it - I have an app called Auto Call Record and there is a setting called "enable or disable auto speaker" - not even sure what the purpose of this setting is in the app - but it was defaulted to activate - when I un-activated the setting problem solved! If you are having the issue - and did the obvious - turn driving mode off - and looked at all phone settings - and still having the issue - then the problem lies in one of your app settings - look for an app tied to your phone or voicemail.
     
  9. Cruisin53

    Cruisin53 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 3, 2013

    Mar 3, 2013
    1
    0
    5
    Thanks for these forums,,however none of this seems to help me turn off my speaker on my phone.When I answer a call or dial a call,my speaker is alway on.Does anybody else have some ideas..I have a samsung galaxy s2..thanks...
     
  10. sofusb

    sofusb Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 8, 2014

    Jan 8, 2014
    1
    0
    5
    I have the same problem. Speaker auto-turns on when a call is in progress. Absolutely frustrating! Came across this thread / discussion.

    I have had little / a bit / no luck solving the problem - yet. Haven't called Samsung Support YET - but plan to; soon!

    My only guess regarding WHAT causes this problem is MEMORY - LOW MEMORY. Have tried to insert new / blank SD Card without luck. So if it is memory it will be the internal memory being FULL causing this problem.

    Any view on this will be welcome.

    Thanks in advance....
     
  11. umapst

    umapst Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 8, 2014

    Mar 8, 2014
    1
    0
    5
    Male
    Telecom Engineer
    Coimbatore
    Hi
    Just put off your phone and remove the battery for 10 seconds at least. This has solved the issue for me.
     
  12. ferret141

    ferret141 Member
    Rank:
    None
    Points:
    38
    Posts:
    71
    Joined:
    Aug 1, 2012

    Aug 1, 2012
    71
    12
    38
    Male
    Mech. Eng. Student
    London
    I'll throw in why this happened to me in the past. An app called Viber. Re-installed it and the problem went away.
     
  13. calkidlv

    calkidlv Lurker
    Rank:
    None
    Points:
    6
    Posts:
    3
    Joined:
    Mar 13, 2014

    Mar 13, 2014
    3
    2
    6
    I have a Sprint HTC Evo 4G LTE. My speakerphone recently started turning on automatically on outbound calls. I spent an hour on the phone with Sprint tech support this morning; they couldn't figure it out and suggested I take phone to service center. After phone call I dug some more and discovered that this isn't unique to Sprint, HTC nor KitKat since I only have Jelly Bean (4.1.1) on my phone. I checked when latest Chrome browser was released -- Feb 28 -- which was about the time the speaker started automatically turning on. So... I disabled Chrome (ver 33.0.1750.136), installed Chrome BETA (ver 34.0.1847.62) and the problem is fixed, for now at least.
     
  14. ramzi2002

    ramzi2002 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jun 20, 2014

    Jun 20, 2014
    1
    0
    5
    Try to disable the developer options in setting
     
  15. DZ of ABQ

    DZ of ABQ Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Dec 13, 2014

    Dec 13, 2014
    1
    0
    15
    Taking battery out did not work for me. What DID work is going to settings, my device and turned off all motions and gestures capabilites (my palm motion setting was on).
     
  16. Shashi Chettiar

    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Jan 5, 2015

    Jan 5, 2015
    1
    0
    15
    I tried all the in phone settings but nothing works ! Try this, download auto speaker from Google play and set the app to turn off speaker while a call is active and set the time delay to zero.
    I'm doing this till I see the HTC service guys. Hope this helps
     
  17. Paula N

    Paula N Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 9, 2015

    Jan 9, 2015
    1
    0
    5
    I had this same problem. I had Profile Scheduler app installed. I turned off "speaker mode" in the profile and the problem was solved. So if you have a similar app, you should propably chech the options in the app. If you don't have an app like it, then maybe you could solve the problem by installing one. I find the app really handy.
     
  18. ripleyhamster2012

    Rank:
    None
    Points:
    16
    Posts:
    4
    Joined:
    Jan 29, 2015

    Jan 29, 2015
    4
    1
    16
    Female
    It wouldn't have killed u to show everyone else how acces the gps settings. I can't even find the gps settings on my phone.[Q="Andhu71, post: 3827211, member: 850441"]I had the same problem and finally found out that the speaker phone option was to do with the GPS settings. Unknowingly I turned it off and closed the app and voila! The problem was solved. : )[/QUOTE]
    It wou
     
  19. ripleyhamster2012

    Rank:
    None
    Points:
    16
    Posts:
    4
    Joined:
    Jan 29, 2015

    Jan 29, 2015
    4
    1
    16
    Female
    This only helps other ppl that have the same appn what about the ppl that don't have that app but have the same issue? QUOTE="jackson86, post: 5450191, member: 1308566"]This has been driving me crazy for weeks. I have looked at every setting on my phone a 100 times. Finally came across a thread that solved it - I have an app called Auto Call Record and there is a setting called "enable or disable auto speaker" - not even sure what the purpose of this setting is in the app - but it was defaulted to activate - when I un-activated the setting problem solved! If you are having the issue - and did the obvious - turn driving mode off - and looked at all phone settings - and still having the issue - then the problem lies in one of your app settings - look for an app tied to your phone or voicemail.[/QUOTE]
     
    Robert Iarrobino likes this.
  20. ripleyhamster2012

    Rank:
    None
    Points:
    16
    Posts:
    4
    Joined:
    Jan 29, 2015

    Jan 29, 2015
    4
    1
    16
    Female
    What is the youmail app?
     
  21. ripleyhamster2012

    Rank:
    None
    Points:
    16
    Posts:
    4
    Joined:
    Jan 29, 2015

    Jan 29, 2015
    4
    1
    16
    Female
    What is profile scheduler?
     
  22. Robert Iarrobino

    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Mar 23, 2015

    Mar 23, 2015
    1
    0
    15
    Male
    [/QUOTE]
    Jackson86, Thanks Bro. I was trying to figure out this speaker phone thing for a while and saw your post abour auto call record. I have the same app and turned off speaker and it worked. Thanks again!
     
  23. Jaz

    Jaz Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Jun 14, 2015

    Jun 14, 2015
    1
    0
    15
    Female
    The same thing happen to my mums phone I took the battery out for about 10 seconds and put it back in and it work
     
  24. MarvinSwordenski

    Rank:
     #1,508
    Points:
    16
    Posts:
    30
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    30
    4
    16
    +1 on the battery removal.
    HTC EVO 4G
    Speaker goes auto on when calling or answering. PITA to quickly turn it off. Removed battery and reboot. Hasn't reoccurred.
    Sometimes it's the simple things.
     
  25. DVinney

    DVinney Lurker
    Rank:
    None
    Points:
    16
    Posts:
    1
    Joined:
    Oct 21, 2015

    Oct 21, 2015
    1
    1
    16
    Male
    I have a call recorder app that was set to speaker on when called, problem solved.
     
    Bedpan Alley likes this.

Share This Page

Loading...