1. Are you ready for the Galaxy S20? Here is everything we know so far!

Speaker stop workings after using bluetooth headset

Discussion in 'Android Devices' started by George0211, Mar 3, 2011.

  1. George0211

    George0211 Android Enthusiast
    Thread Starter

    I first reported this problem under "Ringer doesn't work" title, which was misleading. I decided to start a new thread (Mods, please don't merge, this is a big bug IMO), since I've investigated this issue with my phone in more depth and I feel that this is a very bad bug and, at least to me, this is even worse than the GPS issue.

    I use Bluetooth headset with my Captivate all the time and never had any issues, until I updated to 2.2
    Here is what happens, once you use your bluetooth headset once on a phone call, right after that speaker on the handset itself stops working. There are no notification sounds coming out of it, no ringing when someone calls, not even audio if you try to play music, simply nothing. It seems like it's in Silence mode but it's not. This issue can be replicated 100% of the time. I use BlueAnt Q2 headset and also a built-in bluetooth in my car.

    I found 2 ways to fix this:
    1. Restart the phone. This fixes the problem 100% of the time, until you use the bluetooth headset again, then the problem occurs again.

    2. Disconnect your bluetooth device from the phone and make a phone call and put it on the speaker on the phone, once it starts ringing you can hang up and the sound is back on the phone. But this doesn't work as consistently as solution 1. Again, this breaks as soon as you use your bluetooth device again.

    Has anyone seen anything on this or experienced the same issue?
    Also, I'd like to mention that this happened on 2 phones now. This happened when I first updated my original Cappy to 2.2. I called AT&T and they gave me a refurbished Cappy as a replacement, and this issue happened on the replacement phone as well. This never happened with 2.1, by the way.
    Last night, I flashed the phone to Cognition 4.1 and again, the same issue happens.
    As I stated above, this is a BIG issue for me, because I've already missed a few important phone calls, because the phone doesn't ring.

    I remember when a lot of people said, regarding the GPS problems, that hey, this is a phone not a GPS. Well, ability to ring is a big part of any phone.

    Thanks.
     


    xfx likes this.
  2. Nelimungous

    Nelimungous Newbie

    Hey George,

    I just tested this on mine and it works fine. Although I did a wipe then the install of 2.2 so it may not be the same set of variables. Did you an update or do a fresh install?

    Mike
     
  3. filiberto69

    filiberto69 Lurker

    @George0211

    I have the exact same problem, and the only thing that seems to fix the problem is restarting! It all happened when i installed Froyo (Captivate on Rogers Wireless). Its annoying to constantly miss calls, i dont want to have to keep my headset on all the time.

    Let me know if you find a solution. I'm going to try and flash to Serendipity 6.2 and see if that helps.
     
  4. racoon922

    racoon922 Lurker

    I have this same problem ever since I upgraded to 2.2!!! Very frustrating!! Anyone have a solution to this problem?
     
  5. filiberto69

    filiberto69 Lurker

    So i installed Serendipity 6.3 and the phone is working perfectly! Phone rings on the headset and device.

    100% less headaches.
     
  6. fldude99

    fldude99 Android Expert

    I unchecked the option to use my jawbone icon with media and it seems to have stopped this issue.
     
  7. xfx

    xfx Lurker

    Thank you for posting - I have the EXACT same problem.
    Both of your fixes behave as described - This IS a software problem.
    Now I can stop pressing the speaker with my thumb (which does not fix this bug).

    Eager to learn of a permanent fix. I'll begin holding my breath now...

     
  8. imnok1

    imnok1 Lurker

    i may have had this problem before and didn't realize it might be related to attached bluetooth. i can't recall how it might've been that it was resolved but somehow it was working until yesterday. i have the icon as well and just went back to sense to update radios and then back to cyanogen again. at the same time as i was updating radios, i went to update my icon with the mytalk site/software. after coming back into sense to check radio versions, i made and received a few calls. ringer worked normally. reloaded cyanogen 7 (which i've been using for a few months - gingerbread rom) and suddenly phone won't ring when icon is connected.

    i unchecked the option for media and the ringer works again so thanks for this post.
     
  9. fontdroid

    fontdroid Lurker

    I'm having the same issue. Also, the notifications will sometimes make the sounds but they broken up. Four returned phones and still happening with nothing else installed. Captivate with Jawbone Icon produces the problem on two phones and two Icons. Captivate with Plantronics Pro does not seem have the problem. I'll try turning off the media option and see what happens.
     
  10. macrochip

    macrochip Lurker

    Just an FYI. I have this issue with My icon after upgrading my Captivate to FROYO. I just picked up my new Galaxy S2 with Gingerbread yesterday and hooked up my jawbone icon and same thing happens on My new phone. ANNOYING!!! I realize this thread is old. But I hope someone can find an EZ fix I hate having to remember to reboot my phone after a long day of using the headset and then if I don't I miss calls.
     
  11. kwhafe

    kwhafe Lurker

    Yes, does anybody know what is going on here? This is how it happens for me:

    -Using my BT headset, works fine, etc etc..
    -then, NO audio comes from handset, no ringers, notifications, music - anything
    -only way I know of to fix it is to reboot, which sucks

    Somebody?
     
  12. joojanta

    joojanta Lurker

    This also happened to me some time back using my Desire starting with a Starburst 2.2 Froyo ROM, after I crowbarred the voicedialer onto it.

    The problem for me was only ever triggered if I used the bluetooth voice dialing function (just connecting with bluetooth was not enough to cause it). After using voice dial, everything seemed fine until I disconnected bluetooth after which the phone would not make any sound. Sound would play through bluetooth if it was reconnected, but never from the speaker or headphone jack until the phone was rebooted.

    Between myself and the ROM producer (droidzone), we eventually tracked it down to the kernel - if callrec (2 way call recording) is compiled into it then it seems to behave in this way. Using a kernel without this feature does not cause this.

    Pretty much all the custom ROMS that I've used recently have this feature in the kernel so I have to go scavenging for an alternative kernel without it. This was 100% reproducible for me once I figured out what was going on, so I'm willing to bet that no-one with a stock kernel who's lucky enough to have bluetooth dialling will have this problem.

    HTH
     
  13. imp81318

    imp81318 Newbie

    I am running CM7.1 on my HTC Incredible and I'm also having this problem. I am new to rooting and custom ROMs. I was going to try a different radio- would that potentially fix this problem? Is it 'ok' to use a different kernel with CM7? (I'm not really sure what a 'kernel' is or what it does?) Thanks.
     
  14. joojanta

    joojanta Lurker

    As far as I understand, updating the radio will not affect the kernel - they are two completely separate beasts - the kernel looks after the overall computer operating system on your device and the radio looks after the hardware features. I've never tried any of the Cyanogenmod installs so I can't advise on an exact kernel for you to use; in my case I am using a supernova rom (based on a stock HTC Desire ROM) so needed a reasonably standard kernel. I eventually tracked down the Gingercake series of kernels which fitted the bill for me.

    I reckon if you ask on a CM specific forum or scour their resources you may have some luck getting hold of the right kernel for your situation, unless of course a CM someone here can point you in the right direction!
     
  15. judess69er

    judess69er Lurker

    So basically this issue is a common recurring issue for the android OS and not just phone specific... This is pathetic android 2018 and you still cant make a phone with working bluetooth technology... Thats sad man
     

Samsung Captivate Forum

The Samsung Captivate release date was July 2010. Features and Specs include a 4.0" inch screen, 5MP camera, 512GB RAM, Hummingbird processor, and 1500mAh battery.

July 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...