1. Download our Official Android App: Forums for Android!

Support Speakerphone defaults on outgoing calls

Discussion in 'Android Devices' started by towney, Jan 21, 2011.

  1. towney

    towney Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    12
    Joined:
    Jun 13, 2010

    Jun 13, 2010
    12
    1
    16
    West Orlando
    Ok I've search and can not find the solution to getting the speakerphone off when making calls and receiving. Ive done the battery pull and turn off voice mail speaker but still no luck, this just started happening a couple days ago.
     

    Advertisement

  2. quijibo

    quijibo Well-Known Member
    Rank:
    None
    Points:
    68
    Posts:
    107
    Joined:
    Jun 28, 2010

    Jun 28, 2010
    107
    101
    68
    Trades
    Denver
    Mine started doing the same thing, at the same time too. I can get it off of speakerphone, but I have to do it on every call? Maybe a bad proximity sensor?
     
  3. Mr. Ed

    Mr. Ed Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    6,675
    Joined:
    Jun 27, 2010

    Jun 27, 2010
    6,675
    1,464
    313
    Phones
    Over Yonder
    there have been five or six threads on this but not one resolved post. some have fixed it by going into speaker phone settings and toggling the speaker phone option. a few by hard reset the phone. someone mentioned an app that caused the issue so look at any apps you may have installed just prior to the issue.

    in the end if no other methods fix it, take it in to a sprint repair center. reportedly if they can't fix it they order a new phone.
     
  4. Syprus21

    Syprus21 Lurker
    Rank:
    None
    Points:
    6
    Posts:
    4
    Joined:
    Jan 24, 2011

    Jan 24, 2011
    4
    1
    6
    I'm having a similiar issue. Speakerphone defaults on all outgoing calls. I can toggle it off when i make the call, but why is it the default?

    I'm curious, but Ive also found my phone randomly in Car Mode. First off, I have no idea how to set this, but I wonder if it has anything to do with the speakerphone defaulting. Has this happened to any of you?
     
    younggreenanne likes this.
  5. quijibo

    quijibo Well-Known Member
    Rank:
    None
    Points:
    68
    Posts:
    107
    Joined:
    Jun 28, 2010

    Jun 28, 2010
    107
    101
    68
    Trades
    Denver
    I brought mine into Bestbuy and they tried doing all of the resets and it still had this problem. They sent it in to get repaired. The salesman also noticed that the pins in the charging port look mangled, maybe it's grounding some of the pins and putting it into car mode. This would explain why it defaults to speakerphone?
    I guess I'll have to wait the two weeks to maybe find something out.

    Adam
     
  6. Syprus21

    Syprus21 Lurker
    Rank:
    None
    Points:
    6
    Posts:
    4
    Joined:
    Jan 24, 2011

    Jan 24, 2011
    4
    1
    6
    Yea, I found another thread where someone brought their phone into a Sprint Tech and they said it was a known issue where the Car Mode sensor goes bad. This causes outgoing/incoming calls to default to speakerphone, and if you have headphones plugged in, you cannot control the media volume.

    I'll be bringing mine in sometime this week. Yay.
     
  7. bobbo1229

    bobbo1229 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 26, 2011

    Jan 26, 2011
    1
    0
    5
    The way I was able to get it off of car mode was by holding the power button down till the power menu came up then I selected airplane mode then I shut the phone then put it back on then I got it out of airplane mode then put it on silent mode then back to normal. I am not sure if silent mode is needed but my speaker phone does not come on anymore when I make a call. Hopefully everyone has the same luck I did.
     
  8. gonefshin

    gonefshin Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 5, 2010

    Sep 5, 2010
    1
    0
    5
    This worked for me as well but only a short while..Then it started hapenning again
     
  9. younggreenanne

    Rank:
    None
    Points:
    6
    Posts:
    5
    Joined:
    Jul 16, 2010

    Jul 16, 2010
    5
    1
    6
    Dallas, Texas
    The same two things were happening to me but strangely hasn't happened in about two weeks. Ive also found my phone randomly in Car Mode and defaulting to speakerphone mode.
     
  10. joshzorp

    joshzorp Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Aug 10, 2011

    Aug 10, 2011
    2
    0
    5
    That worked for me , i'll let you know if it goes back to the same.
     
  11. randsom

    randsom Member
    Rank:
    None
    Points:
    16
    Posts:
    34
    Joined:
    Jan 9, 2010

    Jan 9, 2010
    34
    5
    16
    I was fine before the recent update to 4.53.651..1 - now I have this issue!
     
  12. sonntpk

    sonntpk Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 1, 2012

    Jan 1, 2012
    1
    0
    5
    Hi all, I had this problem, and I fixed it by turn off the Navigate application. Hope it help :)
     
  13. Mussolini

    Mussolini Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Feb 13, 2013

    Feb 13, 2013
    4
    0
    5
    I've heard spraying canned air into the microUSB port can fix it, anyone tried that?
     
  14. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Rank:
     #13
    Points:
    1,923
    Posts:
    23,596
    Joined:
    May 13, 2010

    May 13, 2010
    23,596
    14,436
    1,923
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    what to help fix the speaker default on incoming calls? this worked for you?
     
  15. Smash It Up

    Smash It Up Lurker
    Rank:
    None
    Points:
    6
    Posts:
    1
    Joined:
    Feb 19, 2013

    Feb 19, 2013
    1
    1
    6
    Male
    Las Vegas, NV
    Hey guys,new here,i found this thread while searching for the same issue of the speakerphone always on when making a call which started a couple dqys ago. While reading i remembered that i had tested the dock mode and that it could have something to do with this. The dock mode icon was still on in the notification area at the top of the screen. I went into the dock mode settings and unchecked auto launch and auto connect,then made a test call,and it seems to have cleared the problem. Hopefully this will be of use to someone having the same issue.
     
    Mikestony likes this.
  16. Mikestony

    Mikestony ~30% Carbon Black ±
    Moderator
    Rank:
     #6
    Points:
    3,118
    Posts:
    28,611
    Joined:
    Sep 10, 2010

    Sep 10, 2010
    28,611
    22,076
    3,118
    Male
    Next to you
    Thanks for the input Smash!
    And welcome to the forums:)
     
  17. sjgmoney

    sjgmoney Newbie
    Rank:
    None
    Points:
    16
    Posts:
    10
    Joined:
    Sep 24, 2012

    Sep 24, 2012
    10
    4
    16
    I ad this problem for ages but finally fixed it by cleaning the micro USB port and also making sure the charging plug was not pushed into far. I think at one point it got jammed in too hard and left the phone thinking it was always in a car port or something. I have prevented the problem from re-occurring by being very careful whenever I insert the cord.
     
    ocnbrze and Mikestony like this.
  18. marsham

    marsham Lurker
    Rank:
    None
    Points:
    6
    Posts:
    1
    Joined:
    Aug 23, 2014

    Aug 23, 2014
    1
    1
    6
    Hi all I am so pleased with my self I have just joined forum to share
    I had to send my galaxy s2 for repair due to charging problem ..hadnt backed up anything so lost photos vids (grandchild we struggle with access so were very oreciuos) contact ect ..so when phone returned I started to build up again ..onky to find that contacts cant hear me unless i turn on speaker phone ..not good for family calls in busy office at work !!!!
    Took to 02 guru ? As advised ny network provider ..he said only way is to send away for fixing ..arghhh not again !!!
    So googled and checked out forums for ideas ...guess what I'VE FIXED IT !!
    I took off all paired devices and took off any new apps since phone return .now im back to normal ...im going reintroduce apps and device share (think car one cud be culprit) and check default on route .YEEEEE oops just wanted to share hope it helps someone as android /it phobic as I am ....was ha
     
    Mikestony likes this.
  19. Mikestony

    Mikestony ~30% Carbon Black ±
    Moderator
    Rank:
     #6
    Points:
    3,118
    Posts:
    28,611
    Joined:
    Sep 10, 2010

    Sep 10, 2010
    28,611
    22,076
    3,118
    Male
    Next to you
    Welcome, welcome, welcome marsham :D

    Thanks for joining! And glad you got your issue fixed!!
     
Tags:

Share This Page

Loading...